EX 2 Dead on Arrival?

Greetings,

I bought a EX2 MyCloud which arrived today from Amazon. I bought it without disks. I purchased two 6 TB red drives. I installed the two drives and started the setup process. A few lights would flash, then it would settle with the power light flashing yellow and the two drive lights on solid blue. Eventually after about 30 minutes or so the two blue drive lights went out. The power light continued to flash yellow. I called tech support and talked with a fellow that was very nice and patient. He had me do a reset with a paper clip and I tried again. Same issue. He had me plug the Ethernet directly into the computer. I tried a different router, same issue. Finally he declared that the unit was defective. Since I bought it from Amazon, I am returning it for a replacement. I have kept the drives. 

The question is, should I try anything else. I am hopeful that the new unit will fix everything, but I still wonder if it was something that I was doing in the setup.

Any thoughts would be appreciated.

Jim

1 Like

I strongly doubt your EX2 is defective. See this thread esp. points 1 & 2 ->  http://community.wd.com/t5/WD-My-Cloud-EX2/EX2-Install-and-Launch-Issues-The-Blinking-Yellow-Light/m-p/799573#M1352

Another tip…if you are a relatively tech-savvy person, you can skip installing any software and just use your browser to access http://wdmycloudex2 (assuming you are using a Windows computer - I think for Macs it gives out a different name which I can’t remember now). Once the dashboard comes up in your browser login (password is blank by default, userid is admin). Then get to the Settings tab and under Utilities sub-section look for the Format functionality. You should be able to then format both your drives from there. Once they are formatted the yellow blinking power light should change over to solid blue. In the 8 months I have had this device, I never once installed the software. The dashboard accessible through a browser has been sufficient for all my needs.

If this helps, please click the star under my username to the left of this post to give me a kudo.

4 Likes

i had the same experience. 

but with  the help of a WD employee  it was solved in no time with the browser. 

the point is it should be in the manual. 

(and the manual should be on paper,  but that is an other story) 

I’m disappointed in the WD products,  because of the backup problems.

my white single drive WDMyCloud has problems too. 

and from WD no news! 

cybernut1

Thank you so much. I am in business, or at least I solved the dead unit problem with your help. I used the setup software. When it got to the page where it said to wait for all of the lights to turn blue, I continued on and, amazing, it immediately found the EX2 and asked me if I wanted to format the drive(s). Of course I said yes. After a warning that it would delete all data, it continued and I had all blue lights within about 10 minutes. I then updated the firmware and I am now on to trying to figure out the rest of this beast.

It is too bad that the nice tech support guy at WD had no idea about this. It is also silly that there is nothing in the setup information or manual. Thanks to this forum.

I am sure I will have other questions, so will probably be back later with another topic.

Jim

Glad to have been of help :slight_smile:

Kudos!:smiley:

Apologies if I’m hijacking the thread, but it contains information I cannot seem to find elsewhere. You said you purchased two 6tb red drives? It turned out they worked OK?

I have a 2tb Mycloud EX2, and I was looking to upgrade it with 5tb or 6tb drives, but I can’t seem to find a definitive answer if it will work.

Thanks,

LS

louiss3000 wrote:

Apologies if I’m hijacking the thread, but it contains information I cannot seem to find elsewhere. You said you purchased two 6tb red drives? It turned out they worked OK?

 

I have a 2tb Mycloud EX2, and I was looking to upgrade it with 5tb or 6tb drives, but I can’t seem to find a definitive answer if it will work.

 

Thanks,

LS

Yes, your question should have been a new thread as it has nothing relevant with Jim’s issue. But briefly to answer your question, yes, it would work, even if you bought an EX2 with drives pre-loaded and not just the shell-only model. Just be sure to get NAS-specific drives, if you want your investment in the large drives to last a long time. I will not be responding to any followup questions, as this thread if for a different issue altogether.

This article helped me to solve the problem. Thanks

I have the same problem, blinking yellow light. Bought it two weeks ago, several mail conversation with WD employee. I understand from the thread that I have to format the drive. To do this I have to install the software. But I can’t install thhis because the light should be steady blue. And that just the problem.
The link http://wdmycloudex2 doens’t work. I have a windows computer.

1 Like

Just want to make sure that the model you bought is EX2 and not EX2100 or some other model of My Cloud NAS. Because that link should definitely work if you put in an EX2 in your network. By the way, you don’t need the software to format the drive. That’s an incorrect assumption. You do need to be able to access the web dashboard at http://wdmycloudex2 from a browser on a Windows machine - then from that web deashboard, without installing any software on your computer, you can format EX2’s drives. It’s all in the EX2 manual. Please consult it.

It is really ext2 model. Thanks for asking. The link does not work. Page can not be displayed.
I read the manual already. The Orange blinking light wasnt mentionned hand also not what to do when the link doesnt work.
Thanks very much for your reply.

I’ve opened the link for the dashboard in a separate browser but the system states it cannot find the network to connect. My Power button and HDD lights are doing the same thing. I am a techie - any other thoughts? Otherwise, I would connect them as external HDDs separately and format that way. A longer drive to the same pier.

I am having the exact same problem with my EX2 Ultra that I purchase from Amazon, I purchased it with 2 drives included. There are no network lights in the rear of the device. The link that solves the problem does not apply as I purchased with drives. The POWER light continues to flash yellow and the HHD lights flash blue. Any idea why a new product is not able to connect to the router (there is no network activity light on the back the drive or the router). Hope someone know what is doing on or I guess I also will have to box it up and ship back to Amazon.