Need help getting started

I’m having problems right out of the gate. I unpacked my system, followed the directions. Installed the hard drive. Plugged in the power, I get a flashing yellow light when it should be blue.

So, what next. I have tried going through this site finding that answer. This site is hard to navigate. If I could ask a question, it would be this. I didn’t buy the red disks, I bought a compatable seagate. 2 TB. Should I format them on my home computer before putting in the my cloud, or will the my cloud do it?

The cloud will format the disks if needed.

Flashing Yellow indicates that it’s not connected to your network properly.  Have you double-checked your cabling / network connection to the EX2?

Ok, i have a lynksys router in my living room that is bridged with my netgear dsl router. I had it hardwired there…flashing yellow. Brought it to my main computer and directly connected it to the Netgear 7550 dsl modem…flashing yellow. I guess i could change out the cable that came with the mycloud incase it has a short in it or something. Any other ideas. I read a lot of posts on the internet and there seems to be quiet a few of these that are DOA.

Any suggestions?

I never heard about any DOA EX2 units so far…don’t know where on the Internet you read these posts. It is possible that you have a bad unit, but my guess is that’s not the case.

Have you looked at the EX2 manual for troubleshooting steps? And have you called WD’s tech support line? They offer 30-day free tech support to aid with setup if you have issues. I’d try those avenues first.

The other thing I would suggest, besides trying connecting to either of your routers with a different ethernet cable (which you’ve thought of already) is to go on your router’s web interface and see if it’s seeing the device (likely not). Also, try all ports on the routers…if you have one port that you have something else plugged in and you know that ethernet port works, then disconnect that device temporarily from that port and connect the EX2 on that to rule out the possibility that you don’t have a bad port on the router (unlikely but sometimes unlikely things happen and it’s best to rule everything out systematically).

FYI - This is from the EX2 Manual;

Front Panel Power LED
The following table describes the front panel power LED behavior.
Note: For non-compatible drives, the power LED blinks yellow during power up.
Front Panel Hard Drive (HDD) LEDs

Power Down
Black (off)

Drive in standby/sleep mode.
Powering Up

Device is powering on or in the process of updating the firmware.

Power Up

Device is in a power up (on) state.

Power Up (degraded)

Device is powered up but the volume is degraded.
Action required

A condition, such as a network cable has become unplugged, which requires you to act.

Note: For incompatible drives, the hard drive LEDs blink red rapidly as the unit powers up.

Ok…well, changed cable. Changed routers. Changed cable to each port on router. Light still flashing yellow. Sent an email to wd about 2 days ago, still no response. Will send another.

Question…should I waste more time with support here, or RMA it to NewEgg?

If you are certain you have a compatible hard drive, and it is not on your network IE you cant log in to the user interface, then I would RMA the unit ASAP.

Instead of emailing WD, call them. They offer free phone support for first 30-days after purchase.

According to the list, there’s only two drives you could have selected:

Seagate ST2000DM001


Seagate ST2000VN000

That’s what you added?

What are the DRIVE STATUS LEDs telling you?

I have 2 Seagate Barracuda ST2000DM001 2TB drives. I was told in an earlier post that the mycloud will format these drives, so I just installed them per the directions. I emailed support (2 kids and 3 baseball teams, no time to call) and they suggested pressing the reset button on the back. I did. Flashed blue and stuff for about 5 minutes, then yellow flashing again. I did this a couple of times.


Time for RMA or something?