DX4000 blank screen with remote desktop

After having removed one of the 4 RAID5 disks on a DX4000, I had a side effect. The unit is working OK, it rebuilt the RAID5 with another disk without problem. However when accessing the unit with remote desktop I just find a blank desktop, no icons, no lower bar, no start button. Pressing ctrl alt end I can still access almost everything by direct executing commands e.g. consolelauncher.exe for dashboard etcetera, but that is not very efficient. Is there any way to regain control of the starndard desltop?

I assume you have rebooted?
In that cmd run thing type explorer.exe (I think)

Exactly, everything works via the task maanger called with Ctrl Alt End. Funnily enough trying to search for this error I found a similar post I wrote two years ago. Same problem in the same exact boundary conditions (a drive which had to be replaced - so ti seems a recurring issue with the DX4000)

I already tried most of the solutions found on the web but I still get an empty desktop without icons, start button etcetera. Everything works but has to be managed via task manager, weird.

did you do run explorer.exe?

explorer.exe was running, I tried as suggested in your email to kill and restart it but nothing happened. I have the impression the issue might have something to do with the user priviliges, is there any way to setup another user which can allow access via remote desktop? I tried adding a new user with administrative priviliges but it seems it can’t allow remote access

add the user in the remote desktop settings. Keep in mind you will get a lot more hits if you google whs 2011 Same thing (almost) just limited to 10 users and cannot join a domain

That said years ago I don’t think I had any luck adding users outside the dashboard

2

Press Windows Flag+Pause / Break, then on the right had side click “Remote Settings”, Next, make sure you have enabled and allowed Remote Desktop, and enabled the users you want to connect with.

thanks, tried - no luck. Even with a different user same empty desktop. Actually I have to correct myself: explorer.process exe is not there at the very start. Maybe that is the problem (or one of the consequences)?

as additional information: if I type explorer.exe the explorer windows does not appear. So something looks corrupted there

sorry was on the road. I have never had it fix anything for me but wonder about
sfc /scannow

chkdsk /f /r ??

or copy it from another system?
Lots of time you cant copy but you can rename exlporer.exe explorer.old
copy explorer.good
rename to explorer.exe

that was the solution, crazy. Actually I renamed the explorer.exe to explorer2.exe and then modified the

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon\Shell

entry in the register (I could not rename explorer.exe but probably I was too lazy to kill the process and wait)

Kewl :slight_smile:

Hate it when lil things take so much time to figure out. The trick is to remember for next time !

Glad you got it sorted. What a time you have had this time around

Weird that even googling around almost nowhere that simple solution is reported. And on the other hand I really wonder what is happening to explorer.exe after DX4000 reports a faulty HD, as this same thing happened to me two years ago in the same situation.

no clue, afaik explorer.exe is not written to or changed.
they the same file size and date?

for giggles does asfc /scannow show anything?
I would still do chkdsk /f/r
have to hunt in the event log to find the results after it reboots

I did everything before copying the file. sfc /scannow reported that some operations could not be completed but nothing more on the dos shell. I also forced chkdsk but no idea of what happened, for sure the problem was still there. The explorer.exe had exactly same length and date… I also checked authorization and they were identical between the two.

like I said the report is in the event log but it is not like the first event after the startup. I guess it has code but i don’t remember what it is

you can run a md5 checksum thing and compare the 2 files
not sure what that would prove as you know v1 does not work…