DX4000 no more RDP access after new IP / reboot


#1

Hello,
Today i took out the dx4000 of the old network and connected it to our new network, that has a different IP range (old network used 192.168.1.xx and new is using 192.168.192.xx) .
I changed the IP settings, subnetmask and def. gateway and then rebooted the dx4000. Everything seemed to work fine, NAS showed up in network connections and shares showed up and were accessible.

But i cannot connect to the dx4000 using remote desktop anymore. I get the message that no remote desktop service is running on the server. (tried both using IP adress and servername)

So im affraid that after the reboot, the RDP service didn’t start. Like i said, the shares are showing and are usable and i do get a ping reply from the new IP adress.

Is there any way to get access to the server or is there a way to reset all network settings?


#2

Well, things went from bad to worse (thanks WD… NOT)
I followed an advice to do a recover and downloaded the 1_7_5_17 ISO from the WD sitw and created a bootable USB.
Booted the DX4000 into recovery mode and tried to do a factory reset without deleting my data (since the drives were OK)

It ended with an errorcode 0x80070570 and thanks to this “awesome” ISO, the NAS now refuses to boot. It hangs in “Loading OS”


#3

You need to verify your iso download with a md5 hash file first
Well if you can’t rdp a recovery is about the only option though I would have tried a restart first


#4

Thanks for the reply :slight_smile:I tried several restarts and although the server came up just fine and with working shares, there was no way to make an RDP connection so apparently the rdp service crashed or bugged.

I dont know how i can check the md5 hash but till now i tried 2 different ISO versions from the wd website and both failed with the same errorcode.
And like i wrote earlier, after the errorcode, the dx4000 wont boot up anymore so the recoverysoftware did damage my OS/.

I downloaded the following versions btw :
EMEA_SvrRecovery_1_7_5_17 and
EMEA_SvrRecovery_1_7_6_21__

not sure if there are any md5 hashes available

edit: Right now i started from the EMEA_SvrRecovery_1_7_6_21__ usb image and doing a full recovery (incl. formatting). The formatting is working atm and im not sure if it will continue after format or just crashes with the same error.


#5

there is a hash for the panam around here somewhere


#6

So far i haven’t been able to find one. I did try the PANAM version today but that too ended in the same error all other ISO’s gave.
dx4000 error

I did check the logfiles and different ISO’s have different errors at the end of the log though.


#7

if the hash is correct you may have to recreate storage. If you do not have a copy of the data and need it you should try a 3rd party raid recovery app first. Well, if you have more than 2 drives in it

C:\Users\Budro\Downloads\PANAM_SvrRecovery_1_7_6_21_.iso:
Verified: Unsigned
File date: 1:53 AM 1/14/2017
MD5: 32031F2454D3510D7CE2BF5891F7D25D
SHA1: EF0E132813182B2202A5FF54180C840BEE44F59E
SHA256: 6D511FC43FEFBC088E6A069397539B575AA6E81067D0A5BC81E1FEF12CDCD1B1
ives in it.

C:\Users\Budro\Downloads\PANAM_SvrRecovery_1_7_6_21_.iso:
Verified: Unsigned
File date: 1:53 AM 1/14/2017
MD5: 32031F2454D3510D7CE2BF5891F7D25D
SHA1: EF0E132813182B2202A5FF54180C840BEE44F59E
SHA256: 6D511FC43FEFBC088E6A069397539B575AA6E81067D0A5BC81E1FEF12CDCD1B1


#8

Hi Gramps,

I tried everything so far. 3 different ISO images (Both had the correct hash), all refused to install. I even formatted the raid since i already had a working backup of the data. The tool formats the drives correctly (takes hours though) and then, again, stops with the same code. So i might just give up.

After reading the, mostly negative, reviews about WD customer service, and the fact that so far WD hasn’t answered even one email or handled our open tickets, my boss canceled the replacement order of 3 EX 4100 and will buy Seagate BlackArmor NAS instead.

Thanks for all the effort though :slight_smile:


#9

Well if you want to piddle with it in your spare time it should recover.
You may have to start totally from scratch.
Use diskpart>clean to totally erase all drives
then do recreate storage
then recover
I would use the panam iso as we know the hash for that one works
if it fails I would suggest a different thumb drive.
I suppose bad memory could also be an issue, but no clue how to test it.

all this said, it is a very old box/technology and there is no decent support for it. Well me excluded of course LOL


#10

I will try that. Actually im deleting all partitions right now. I just hope it doesnt take 6 days to recreate.
I agree that its an old system but at least WD can have the decency to replpy to an email or to a ticket we opened. There’s just no response at all, which makes it quite an unreliable company in my eyes.
For my hobby i work with old equipment and old pc’s and find that most “normal” companies, eventhough the support ended long ago, still provide the original drivers, software, manuals on their site, no matter if its a 4 year old system or 16 year old.

imo the least WD could do is keep the ISO’s online together with their hash.

But your help is really appreciated :slight_smile:
I found out that the drives have a regular Windows partition and an EFI partition. So if anything else fails i might be able to install windows on the drives directly (or even Linux)

Still hope i can get it to work because the 4 slot bay is really nice.


#11

it is hard to install windows without a monitor, though some dude figured out a way with vnc and has an iso for it
you just have to search around here in the forums perhaps for server 21012r2

Never tried it but I find 2012r2 to be very hardware independent friendly. My thoughts would be to install server on a pc with efi and then just put the drive in the dx
power it on and wait a while for it to reconfigure itself.


#12

Yes, ive read something like that. Also one guy managed to install Linux on it, although it would only boot with the resetbutton pressed.
Not sure if anyone ever tried an USB monitor on the NAS. Would be nice if it was recognized. Ill try some things and definately keep you posted :slight_smile:


#13

usb monitors need drivers


#14

Well, believe it or not, i finaly got everything working again :slight_smile:

Removed all partitions like you said on both drives (including the EFI ones), downloaded yet another PANAM ISO version. Then i did a storage rebuild which on empty drives, only took 60 sec.
After that i ran the restore option which took a bit longer. After that i could use the web interface to connect but that too had a lot of issues because of an (apparently) old certificate. So i had to disable all securitychecks on my browser to get things started.
Another issue i found out was that i wasnt able to select my own country (Netherlands) during install from PANAM Iso. It didnt complain but after 3 minutes just crashed with an error. After i tried again and selected US as country, things went fine.
Now, after 3 hours of installing updates, it looks like the NAS is back to life.

For other people with the same problem, i used : PANAM_SvrRecovery_1_7_6_21_.iso (just dont select a non US country when installing)

Thanks a lot for your awesome support and patience Gramps :slight_smile: I couldn’t have done it without your help.


#15

Glad you got it going. Sometimes the box will keep the last date it was shut down for some reason and that causes issues.

The bare bones recovery really normally works, you just have to follow specific steps.

WD should provide hash files


#16

Has anyone tried the HDMI output from a usb hub eg

if this is able to display the video it could be useful


#17

The dx does not have usb c so that would not work. This might but it does not list server has supported but does support win 7

but you have to boot to windows and load the drivers before it will work

HP made a headless server for a while but it had some pins on the mb that folks made a video cable for. Never seen any pins or method to this this on the WD box


#18

Thanks Gramps


#19

USB-C hub . . .you can get a USB C 3.1 FEMALE to USB A 3.0 MALE adapter (that supports not just power, but data/sync as well) and plug into the DX4000. Am getting the adapter from Tripp-lite to go with the Tripp-Lite USB-C hub similar to previous post. IF it works, I will have up to 4K HDMI, 64Gb micro-sd, ethernet, 2 USB 3.0 ports for keyboard/mouse. Have tried this and works with other equipment and with Windows 10, Android, ios, (had built in drivers that fired up immediately). Will try this against the existing windows 2008 Storage Server r2 as shipped, however trying after lost drive, reinserted drive(until getting replacement drive), repairing …, got the web login up - veeeery slow - couldn’t login, restarted and now loading OS please wait… status. If no go, looking to try windows 2012 Server Essentials, Windows 2012 Storage Server, Ubuntu 18.04 as possible OS based on insights from GREAT previous postings…


#20

Please let us know what happens and part numbers if it works !!