Duplicate files created after latest my cloud January firmware release

I have two my cloud 4TB drives in different buildings, that are not linked in any way, that since the January firmware release have developed an annoying problem. Both drives have 2TB my passport drives physically attached by the 4TB my cloud USB port. I stress this to ensure that it is clear that the problem is with the WD firmware update, and not with my equipment or set up (2 separate configurations both have the same problem).

When I access the two 2TB my passport drives, there are duplicate files shown. Each time I reconnect the 2TB drives, another duplicate file is created. I cannot delete these duplicates. So, to spell it out clearly, the file list on the 2TB my passport nearest to me at the moment has the following in the list:

My_Passport (original file, but now not accessible or deletable)
My_Passport_2 (created after firmware update. Empty and undeletable)
My_Passport_3 (ditto to above)
My_Passport_4 (latest file created, which hold all my files).

next time I diconnect and reconnect, number _5 will be created. It is manageable but annoying now, but obviously I need to stop this happening and clean up the existing mess, but I cannot delete these files, nor open them (contain 0 bytes). Can someone in WD sort this out please.

FYI, there are several other current threads that discuss this issue with external USB drives…



Ok, thanks. Read lots of messages and responses, and I assume that ‘safepoints’ are the files being referred to. Mine are not safepoints, but are files that are stored on the extention drive that are there because there is not room on the 4TB my cloud (not really relevant, except that I am saying they are not back up files). It seems other users can delete or rename these files, I cannot do anything with them. Any tips appreciated, thanks.

Safepoint is how one can backup their My Cloud to another device (external USB drive or network location). and restore that content back to their My Cloud if something happens to one’s My Cloud. Safepoint is a backup program one can launch from the My Cloud Dashboard. When run, Safepoint creates a folder at the backup location to hold the backed up My Cloud contents. The issue with Safepoint was the changing name of the external USB drive was causing the Safepoint app on the Dashboard to fail to find the previously created Safepoint backup file.

If you look at your /etc/samba/overall_share file you should see entries for each of these shares.


thanks very much, but I don’t do any backups as my files collection is too large. I have another identical set of equipment, in the same configuration in another house that I use to backup both the 4TB and 2TB discs (that configuration now has the same problems). I could cure the problem if I could find a way to delete the duplicated files (see original post), and change the file names, but I cannot open, change or delete any of the duplicated files on My Passport 2TB disc. That’s what I need to resolve. Even with plugging the 2TB directly into my computer USB port I cannot do it, but then of course when I plug it back into the 4TB My Cloud, it will create one more duplicate file which I really don’t want to do. It seems that the problem is within the 2TB My Passport (x 2), but it was casued by the My Cloud upgrade in January.

Does anybody from WD actually read this forum, or even do anything to help people? I brought WD storage because it seemed to be the most innovatve kit available, but it gives me plenty of problems. I spent around 1000€ altogether , but I won’t be spending any more with WD if it can’t even get it’s pre-release testing right AND won’t deal with the resulting problems afterwards.


We have passed this along to support.

The real question is? Does anybody at WD understand the code that they are releasing?


I agree with that! Too many issues for the common featured functionality of these units. Every firmware release send “shivers down my back”.

Another question is? Why did they switch from a real version of Debian to the mini version of Debian with busybox? Generally the reason for this is space. The busybox version is a lot smaller.



Thank you for contacting Western Digital Customer Support my name is XXXX and I am one of the WD Support Agents.

First and foremost, we would like to thank you for taking the time to contact us in regards to the issue with the item.

I apologize for the inconvenient, but actually, from the description, I cannot understand the issue with your device.

Can you please specify step by step all the issue, from when did it start on your device, if you modify some configuration?

More, can you please send me a screenshot of the desktop to better check it?

Waiting for your answer,


Did you provide a link to this thread when you contacted WD Support?

Please note that this is primarily a user to user support forum. As such chances are low/slim that WD Support is actively trolling this subforum looking to help people or that they can link your contacting them to a specific name or thread in this subforum.

I didn’t need to provide a link, as you can see from the comment above, someone from WD did trawl the forum and identified my posting and referred it to WD support. User forums are great for discussion, tips, and to save WD dealing with questions already answered elsewhere … but when WD release new firmware that has bugs due to inefective pre-release testing, there should be a direct route to report these to WD. Anyway all the info is here that WD need, and it would have been better for tech support to read it here rather than ask for it all over again.

Anyway, thanks to Hamlet for picking it up, even though it seems to be a back door approach.

Rickys, Have you gotten a reply/fix for this? I am having the same problem. See screenshot below…

Bill (WRH)

Per one of the links posted above there is a workaround of sorts to this issue for some people.


Thanks for the reply Bennor. I really do appreciate you looking at my problem. However,… I’m not really looking for “a workaround of sorts”. I’m looking for a definite fix from WD. I have 15,000+ pictures on MyCloud and if I accidently lost them my wife would probably find a place in the curb to sleep! Do you know if WD is working on the problem? As far as I can tell most of my duplicate shares have no files in them. I can’t even get into them… Really looking for some solid help here before I make a mistake…

Bottom line is there is NO official fix from WD nor anything other than a possible acknowledgments of an issue, as of now. Perhaps if one calls Tech Support they’ll get an official answer but here on this mostly user to user support forum there are only workarounds to the various issues that are found with the firmware.

As the threads above explain they are not duplicates of folders or files, what they are is the firmware incorrectly naming the Share for the attached USB hard drive then failing to remove that Share name when My Cloud is rebooted/restarted or the external USB hard drive being disconnected then reconnected. The solution, workaround or what ever you want to call it is to figure out which one of those Shares currently contains the files, then use the My Cloud Dashboard to remove the other Shares (“HenicyStuff”, “HenicyStuff_2”, “HenicyStuff_3”, “HenicyStuff_4”, etc) that are empty, then use the Dashboard to rename the remaining Share back to “HenicyStuff” (in your case).

The other possible workaround (that worked for me) was to do a System Only Restore via the Dashboard > Settings > Utilities > System Factory Restore > Factory Restore > System Only. After doing that I rarely get the duplicating Share names for external USB hard drive. I still get them from time to time just not every single time the device was rebooted/restarted or the drive removed and reattached. YMMV

the latest file created contains the date / files, for me at least. I am accessing dashboard through google chrome via http://(MyCloudName), but I cannot see how to delete or rename files from those menus Bennor. The black shortcut I have for the black dashboard doesn’t seem to work much of the time, but are the two the same?

A fix I don’t have yet WRH, but every couple of days I get an email saying that it has been escalated / they are working on it / asking questions / asking for sytem log files (that I sent a couple of weeks ago).

I should point out that I am not using the auxilary drives nor the My Cloud 4TB drives for Safepoint, purely as additional storage.

I will copy any solution I get here, if one ever arrives, but I suspect that as this happened immediately after the January firmware update, that any permanent solution will come in the form of another firmware update … and hence it may be a long wait. I would settle for a temporary solution right now as I cannot open / amend / delete any duplicated files, and the list just gets longer.