Doesn't stay connected long enough to transfer files

I just bought this 5 days ago. Here’s an example of my problem…

I log in with my browser, I select 14 files. They are about 1.5 GB each. I drag and drop them into the Video folder. I walk away. I come back say 20-30 minutes later and I’m greeted by the MyCloud login screen. I’ve been disconnected and the transfer has stopped. the one time it didn’t happen. I transferred 8 files and sat there watching it for the hour or so that it took.

I’m not concerned about the transfer speed or time it takes. I just want the ■■■■ thing to stay connected and finish the transfer. As it is i have 100s of files to upload to it and this is unacceptable.

If i have to reset it, If I have to SSH into it and configure stuff, then let me know so I can return it. I bought this to simplify my life.

@plshelpme
Are you transferring content using the Web Browser or WD Discovery mounted Network Drive?
Have you opened a support case with us? If so, please provide the case number
Do you have PIP enabled? If not please do so


I have the same problem.
As an amateur photographer I often have several photos after a shoot.
I too have dragged and dropped the folder over and then placed the laptop to the side (because it takes hours) and then suddenly presented with the log in screen. At first I thought the download was continuing in the back ground but no.
And if you drag and drop the files again, it doesn’t recognise the previous files and copies them again.
Would love a fix for this, as this is about the last thing I can take with system.

Billynxn, If you are doing the transfer via browser, don’t. I switched to using a mapped/mounted network drive and then the transfers were lightning fast and I didn’t have to worry about staying connected.

Hi,
Thanks for the prompt reply.
Going to have to own up to not being that computer savvy though.
I tried to map a network drive but can’t locate the my cloud drive to select it.
If you could point me to a site that gives instructions that would be brilliant.
I initially tried to transfer files by connecting the computer direct to the drive but it wouldn’t let me, instead I had to copy to an external SSD drive then plug that into the cloud drive.
Cheers in advance
Billy