Lose connection a few minutes after setup

I just recieved my 3TB WD My Cloud yesterday and have yet to get it to work for more then a few minutes at a time.

When I run the setup software the mycloud seems to work for a few minutes. I can transfer files to it, I can start a file on the my cloud streaming on my bluray player through the DLNA. . After only a few minutes I lose the connection to it, files cease transferring, opening the desktop app gives an error message “Can’t connect to this device”, opening the dashboard says “This webpage is not available”

If I unplug the my cloud for a few minutes then plug it back in and rerun the setup software then it works again, for a few minutes. Then goes back to the above condition.

Check your router and find out the IP address of mycloud.

reserve this address in the router (check DHCP reservation or similar)

configure  mycloud for static P address: mycloud static  with the same IP address as above.

Thanks for replying so quick.

It took me some time and googleing to figure out how to do this (I’m not terribly tech savvy), but I got it done. I thought for a few minutes it had worked, but again the file transfers slowed to a stop. …

I only just noticed that while I can only access the mycloud from my computer for a few minutes after each time i unplug and rerun the setup program I can still watch the few video files I managed to tranfer onto it through my bluray player’s DLNA access after the computer access to it craps out.

best to reboot to make sure the setting get hold. Be patient and wait for the blue ligh on the front of the drive.

Go to dashbboard and confirm the IP address settings and also check with router.

Ping the IP address to make sure , ex: ping

How are you copying? over wireless or wired?

Try using file explorer, much more reliable than WD apps. Post a screenshot of the transfer.

either reserve the IP in the router and leave the mycloud on DHCP

or find an IP address outside of the routers DHCP pool and set this as a static IP in the mycloud

also take your time and be patient, it can get very slow well uploading media files and could be temporarily unresponsive

Again, thank you for your responses.

rebooted the mycloud(had to first unplug it and rerun the setup software for to regain access to the dashboard)… ip is reserved by the router and set to static with the mycloud.

It stopped working again before i got around to attempting another transfer

Screenshot (8).png

again unplug… and it turns out running the setup again isn’t neccesary, just happened to be that coincidentally the drive wasnt up and running properly til about the time i had the setup run on previous attempts…  just needed to unplug, replug, and wait…

I am copying files over a wired connection. 

When I try to use file explorer i get a little red circle with a line through it as i drag the files over

 Using the WD app to transfer works until it suddenly stops and I can no longer open the dashboard and if i close and reopen the desktop app it can’t connect again.

And again I’m back to no access unless i unplug it again. Can’t even reboot it cause i cant do that without opening the dashboard which won’t open.

I wouldn’t recommend repeatedly unplugging.  It ought to survive, but there are good reasons why it might not.

If you need to reboot it, use the reset button; either a 4 second press with the power on, or, if you’ve unplugged it, use the 40-second ‘system restore’:

press & hold reset button

connect power

continue to press reset button for 40 seconds

release reset button

allow MyCloud to boot

When you say that you have transferred some data, how much data is this?  How many media files?

One problem with the MyCloud is that it does rather a lot of media indexing and thumbnail generation, which can take a lot of its CPU, making it unresponsive.  And this process can take a long time if you have a lot of media.

Ideally, there would be a Dashboard option to disable these services.  But there isn’t. [another Idea to submit]

If you can access via the Dashboard, you might turn off the iTunes Server, Media Sharing and the TimeMachine.  This might reduce some of the CPU load whilst you’re transferring files.

Ahh, yes, ty. I was a bit concerned about unplugging, but with no access to the dashboard, and no power button on the thing i didnt see another option, found the reset button now.

On the last attempt I managed to get three 25 minute MP4 files transfered onto it, about 440 MB. It’s not freezing up from trying to transfer too many files at once because it is losing connection even if i don’t transfer anything. Planning on sticking about 110 gigabytes of media files on there then setting it up to backup my computers, but thus far I believe I have a total of 11 video files on it spread across 4 transfer attempts.

itunes was already off, just turned off time machine. If by media sharing you mean DLNA streaming, thats half the reason I bought the thing… Or do you mean to shut it down temporarily while trying to load files onto it?

ok… reset button doesn’t seem to do anything when i press it while it’s turned on. Blue light stays on, and still cant open the dashboard or desktop app.

I unplugged, pressed the reset, plugged it in and held it for about 40 seconds and reset everything. and now after transfering about a dozen files it doesnt seem to want to tranfer any more, but I can still open the dashboard and desktop app… Not sure if thats an improvement or not.

Yes, I meant temporarily disabling streaming/sharing whilst you’re transferring data.  But since you’ve transferred so little, I can’t see that any of my suggestions would be the problem…

4 sec reset does nothing?  At all?  I’m sure the front panel LED ought t do something, but I’d have to check the manual. You’ve read the user manual, I take it?

I guess it’s time to try the 40 sec system restore reset, and see if that helps.  And a router reset.

You’re not the first with connection issues:

http://community.wd.com/t5/WD-My-Cloud/Can-t-access-MyCloud-or-Dashboard/td-p/865957

http://community.wd.com/t5/WD-My-Cloud/Can-t-access-dashboard/td-p/611281

http://community.wd.com/t5/WD-My-Cloud/Auto-network-restart-or-reboot-after-network-loss/td-p/865761

http://community.wd.com/t5/WD-My-Cloud/Ethernet-connections-interruptions-and-restarts/td-p/864698

http://community.wd.com/t5/WD-My-Cloud/Cannot-reconnect-to-My-Cloud/td-p/863984

http://community.wd.com/t5/WD-My-Cloud/Drives-disappears-from-SmartWare-randomly/td-p/864225

And that’s just a few recent threads…

OK, so the 40 second hard reset seems to have fixed me becoming unable to access either the dashboard or the desktop app, been about an hour and they are both still accessible, thats a first, the file transfers through the app still **bleep** though…

but OMG, I just figured out how to set a drive letter to a share in the myshare, so now I can transfer files directly through file explorer and bypass the desktop app entirely.(tried that earlier per the first response, but I didnt know about setting a drive letter to it) It’s working much faster, and working far more consistently. Now it’s working just like dragging and dropping onto a usb external hardrive normally does. The WD App was stalling after a few files, giving me errors and making me cancel and restart transfers, just all twitchy. 

Thank you very much, every one who responded. My problems seem to be fixed now. I was really worried for a while there I was gonna have to return this thing. 

Generally speaking the WD apps are the better choice for remote access but not for local use

1 Like

Yes, it’s a shame that all the setup instructions stress the installation of apps for setup and access, when the more ‘natural’ way of communicating with the thing is treated more as a ‘well, if you must…’ footnote.

I take it you’ve found the manual?  The sections on setting up using the Dashboard aren’t bad.

Glad to hear you seem to be sorted.