Docker and apps


#1

Hi all,

Does the PR4100 use docker? I see there are lots of docker apps that can be installed. I also noticed that someone had created them into the correct format to be installed as apps on the PR4100.

Those didn’t work when I tried them on this model, I would love to use NZBGet and sonarr on here, if anyone’s knows if docker works and if apps can be made that would be great.

Thanks


[APP] NZBGet various versions for firmware V4+ (02/2016)
#2

Hello,

I haven’t try this yet. Let’s see if any of the users on the community can share some information about it.


#3

I was able to get docker apps from the linuxserver.io team to work(here). So far just deluge, sonarr, and couchpotato.


#4

Would you might giving a brief explanation of what to do in order to do this?

Do the apps work after a reboot? Do you have any knowledge on how to turn the docker apps into those that work within the WD apps?


#5

Sure first you have to enable ssh on the WD settings page, and then login to the mycloud directly through SSH using a program like putty. Then I just followed the instructions on the docker pages to run the installs. I had to set up some directories where the programs could be binded to, but then it all seems to work fine. You may be able to get some added tutorial information from the linuxserver.io page as well.

I haven’t rebooted yet to see if they would stay up an running, but I could probably just run the same 3 start scripts in an init.d script to get them going if I need to. I have no knowledge on how to integrate these apps into the WD apps sorry.


#6

Thanks for the reply,

Update,

I have sonarr working properly and nzbget but I can’t get the NZBGET plugin Videosort to work, once it has renamed the file I want it to put it in my Movies folder, however NZBGET won’t see any files outside of its main install directory

I can’t figure out how to get it to go up a level and have access to the Movies folder?

When it tries to move the file it fails and I get this error in NZBGET;

VideoSort: [Errno 13] Permission denied

Figured it out I needed to create the mount in the docker install so that it could be accessed afterwards


#7

If you want to see your Share “Movies” inside of a docker app, you gotta bind it when you create your container, something like
docker run -v /local path to your shares/Movies:/virtualpath inside docker/Movies
also , add --restart=always as a parameter when you create it, so that it starts at boot time, and restart after crash

cheers


#8

do i need to install dacker api on my pr4100 or the docker SDK to also get it running o is it allready installed on the new mycloud pr4100 with firmware v2.11.11


#9

It comes preinstalled , just login over SSH and you can use the Docker
binary.

Cheers


#10

thnx i didnt know it


#11

Hi Carnaged,

I’ve VERY new to all of this - just bought a PR2100 and am really stumped as to how I go about setting up Sonarr.

I have used Putty in the past, but I’m not at all experienced and am really confused. Do you have any guide or step-by-steps about how I go about doing this??

Thanks!


#12

Carnaged i had the same problem on my PR4100 after i put on NZBGET with SSH

i was looking around and trying things and this did solve it

is did give the share map in SSH chmod -R 777 Nzbget and chown -R nzbget:nzbget Nzbget

i hope its the same problem with you


Docker Version Update
#13

I too am able to get deluge, sickrage, and others setup using Docker. I am having a problem with any changes I make to the apps being lost when my nas reboots. Does anyone have a solution for this?


#14

I hope this thread isnt dead, has anyone cared to install OMBI?
I got the arm version installed but it seems the webpage doesnt start up.


#15

Has anyone found a simple walkthrough of how to get started with Docker and 3rd party apps? Struggling to figure out how to install Homebridge on my PR4100.


#16

I don’t have such device, but have you tried

docker volume create hbvol
docker run --net=host --name=homebridge -v hbvol:/homebridge oznu/homebridge

It prints a QR code to sync with an app
Finally, stop it (ctrl-C) and run in the background

docker start homebridge

EDIT: if you want a web interface (on http://nasipaddress:4566), add something like this

docker run --name=homebridge \
  --net=host
  -v hbvol:/homebridge \
  -e HOMEBRIDGE_CONFIG_UI=1 \
  -e HOMEBRIDGE_CONFIG_UI_PORT=4566 \      
  --restart=unless-stopped \
  oznu/homebridge

EDIT: it’s better --net=host as this container uses multiple ports (e.g. web UI and homebridge protocol).


#17

Wow, thanks for the help! I’m close - I can feel it. I tried that last command and got this response:

docker: Error response from daemon: Conflict. The container name “/homebridge” is already in use by container. You have to remove (or rename) that container to be able to reuse that name.

What am I missing? Wow, whoever does a quick walkthrough on YouTube would be a God. Feel like such a noob. Thanks for the help!


#18

Do what the error says: remove the container to reuse that name.

docker rm homebridge