DL4100 does not appear under Network Computers

My DL4100 does not appear in File Explorer under Network Computers.
I select \DL4100 in file explorer it and opens and shows the shares, however the DL4100 is not displayed under Computers. I have 8 computers and DL4100 only displays under Computers on one machine. I was wondering if anyone
has any clues if this is a bug or a configuration problem? Is there any further information I can send you.

Thankyou

Well, I will tell you what I see regarding my DL2100 on my Win 8.1 and Win 7 laptops and WDTV media players, as well as on mobile devices I have, and you can draw your own conclusions.

The EX/DL series NAS can be both a Media Server (with DLNA setting ON) and a Network Share. The best place to see this right away is on a WDTV, which can show it as both, depending upon menu viewed. Under the WDTV’s Media Servers, I can see my computers (which act as servers) and the DL2100. I see Media folders/files such as music, photos and video folder categories. Under the Network Shares I see a file structure as I do on a PC Both are handled differently by the WDTV, since the same file is served (pushed) from the NAS to the WDTV, whereas the Shares are pulled from the server for playing. Same file either way, but handled differently.

Now, how does this play out on a PC? In the the Win8’s File Explorer, under Computer, I see the NAS and the display shows folders for Music, Photos and Video – no other file structure, so this is where the NAS is seen as a server. Under Network I see the nice and familiar folder and file structure and can see anything on NAS. In this case the NAS is seen as a share.

On my Win 7 PC, the NAS is only seen as a share for some reason. No matter, all works fine this way. I don’t see this as a problem, since as shares is my preferred way to see things, because I can see it all.

On my iGadgets (phone and Pad) I have apps that see it either way, and most of them only see it one way, but not both. Same with my Kindle tablets’ – apps see it one way or the other. Very few apps see it both ways. The Infuse video app is one that sees it (and other devices) both ways.

OK, that’s the gist of this, so based upon what you are seeing on your PCs and other devices, draw your conclusions,

I have the problem of a DL4100 not appearing under Network Computers on my workstations.

I had the problem of Windows Server 2012 computer not appearing under Network Computers on my PC’s. I enabled a few services then the Windows Server 2012 computer would appear on the PC’s.

I was wondering if there is a setting on DL4100 to do the same?

Hi engmavin

within Web UI -> Settings:

have you set the Workgroup to the same name as used your clients (default WORKGROUP)?
Have you enabled SMBv3 (default SMB v2)?
Have you enabled LLTD Link Layer Topology Discovery (default OFF)?

Having same issue. got to use UNC to access and can’t navigate from Network folder to any other NAS. I have two other WD NAS’s and they don’t show-up either. Just show up as UPnP devices and if enabled, media servers.

Using SMBv3 and LLTD is enabled.

Yes have named Workgroup, SMBv3, LLTD. Still the DL4100 does not appear, but can call it up using \DL4100 in the address bar.
Is this to prevent accidental navigation, or a configuration issue?

I think it is a configuration issue within your Windows. All My Cloud should appear as members within the “network” part of your file explorer, similar to this German screenshot from a Win 10 system:

“Speicher”, the headline of the block, means “Storage”. By right clicking the Icon, you should also get more details like “Open” opens the file explorer or the bold line opens the web interface.

Normally the My Clouds appear at least there even if they are in another workgroup. If the My Cloud does not appear anyway. then something seems to block the network scan of your Windows machine itself, the so called Network discovery.

Sometimes this behaviour can be related to router or firewall when the SPI Statefull Paket Inspection is set too strong or the router/firewall blocks the internal discovery.

Some links:

Network discovery service not running in services
NAS device not recognized by Windows 7 Professional

An issue with BT HomeHub

Statefull Paket Insepction on the router

Micosoft Troubleshooter Step-by-Step

Hello,
I meant under Network->Computer. Devices under Computers can be navigated.
The device under Storage is for configuration. My computer appears under Storage but not under Computers.

Yep. Exactly the same here. My DL4100 es the elected master browser as shown,.

           NetBIOS Remote Machine Name Table

       Name               Type         Status
    ---------------------------------------------
    ZEUS           <00>  UNIQUE      Registered
    ZEUS           <03>  UNIQUE      Registered
    ZEUS           <20>  UNIQUE      Registered
    ☺☻__MSBROWSE__☻<01>  GROUP       Registered
    BABYLON        <00>  GROUP       Registered
    BABYLON        <1D>  UNIQUE      Registered
    BABYLON        <1E>  GROUP       Registered

Because I’m a clever clogs I’ve configured the other two WS NASs I’ve got so the Samba daemons don’t even try to elect themselves as a local master browser so only DL4100 will do that task and unlike the other two NASs, it even has the option to turn Samba’s local master browser feature on and off.

Only my computer shows up under Computers and neither of the NASs, so I’m also a little bit stumped with this.

All three NASs should appear as well as the computer I’m using.

Hi Myron,
Thank you for reporting this. Have you tried the following steps to see if that would resolve the issue?

KBA 13180: Error: ‘Cannot access NAS Drives’ occurs when accessing a My Cloud on Windows 10

After some deep diving into Google, this seems to be related with “Local Master Browser”. Yet I don’t know what need to be done but during the day I will do some testings and come back with my results.

@Joerg_A, I’ve been looking at this. Having three NAS’s on my network I configured the two lower CPU powered NAS’s Samba servers not to be local master browsers. The DL4100 is the local master browser and set the computer not to try be a local master. That didn’t help.

I’m seeing many people are stating that since a recent Windows 10 update, NASs don’t appear under Computers in the network browser window. I think people with other NASs are also having the same problem.

I’ve also got the SMB1/CIFS feature enabled and that’s now worked.

I would strongly advise against using netcfg -d without creating a system restore point first as that command trashed my computer’s networking configuration. A system restore point saved me from having to so a major repair to the Windows 10 operating system.

Hi Myron

this is a bit of an understatement :wink: The net is full of similar postings, even other NAS forums are discussing the same.
Yet it seems that IPv6 is related to this. I found some articles about routers causing stateless IPv6. Still searching for a solution…

Similar issues are now popping up even in Spiceworks. It seems to be related to Windows.

I still have IPv6 disabled on my network so it can’t be that.

Yesterday my Windows 10 PC received a major update, see what happens afterwards!

Before the update, under “Computer”:

Now, after the update:

I swear, i didn’t do anything! So the issue seems to be related to others than WD :wink:

What’s the full title of the last major update?

The Master Browser has been an issue for me in the past; causing all sorts of problems. It first began when I added a WDTV to my gadget collection. I would lose network shares, and as it turned out, lots of others did too. I found an explanation about master browser at link below, as well as a handy dandy free program called LanScan that shows you what Win PC or device is the master browser (If any). I have recommended this in all sorts of forums here. http://scottiestech.info/2009/02/14/how-to-determine-the-master-browser-in-a-windows-workgroup/
A year or so later I connected an HD to my Asus router, and I had to turn on Samba share in router controls, and lo and behold, I found that my router had become the master browser – and it is a permanent Master Browser as long as the router is always on (and it is) and my WDTV MB issues disappeared. My Win 7 or a later Win 8 never became a MB again.

Later on I added the MPW to my gadget collection, and to my surprise, when I put it onto my network, the MPW also became a MB (according to the LanScan program). It turned out it was of no consequence as there were no issues with two MBs on the network.

Now, I have a DL2100, and it has a switch to make it the MB; handy for those without a MB. Needless to say, the MB switch on this unit is not on.

Anyway, LanScan can tell you a lot about your network, so install it and use it when necessary.

Hi Mike27oct

I have read the same article during my research for this thread but in my personal case, i didn’t do anything regarding the Master Browser settings. Even all the demo units in the network are not set to act as Master Browser. Funny to see that this issue popped up in several other forums at the same time with same results like “no clue what happened” everywhere. It wouldn’t be a surprise for me if some code inside Windows 10 caused this. As I wrote above, after installing the latest updates, the units (re)appear immediately after “restart and update” the system.

Hi Joerg,

I think we will agree that a Win network needs a consistent and always-on MB, and ideally only one, That’s what I have going for me and life is a lot smoother regarding my PC-related life because of this.

I agree, it could be a bug in Win 10 code; maybe more than one bug, too.

Speaking of bugs: The first year of having my WDTV, I could have screamed every time the device told me “there is no media in this folder” when my laptop was chock full of mp3 files. It was when I would access the folder using Media Server mode of WDTV. It took me a year to figure out the problem. Something was going on with sharing the PC folder and the shared media would often disappear and WDTV could not see it anymore. It turned out that when I shared the folder, Windows would say it was shared within a minute or so, but it wasn’t yet. It was rebuilding its list of all the shared music files (for its media server) again, and that could take 20-30 minutes. A couple of years later the problem was finally gone, and I attributed it to a Win update (code fix) that fixed the Windows media server problem. Other problems with Windows have come and gone after MS fixed “something” that had gone haywire,

Anyway, Joerg, I am glad you can find time to check on us forum members’ issues and concerns and lend an assist. I wish more folks in your high position were doing the same. Thanks, Mike

1 Like