My WD Router does not recognize my DL4100 as NAS

My DL4100, 16TB, RAID 5 is up and running.  I can access it from my PC and from my Android device.

I have begun experimenting with setting it up as movie server.  My first problem seems to be that my Router (WD MyNetN900 circa 2008) does not recognize the DL4100 as network “attached storage.”  It seems, if I understand it correctly, that it wants the DL4100 to be attached as a USB device.  I’m not sure I want to do that since I believe my CAT6 connection to a gigabyte switch will be faster.

My second problem is that I tried to “discover” the DL4100 as a DLNA media server on my home network from my theater room TV.  The TV did not recognize the existence of a DLNA server.

Does anyone have any advice?


The DL4100 should be connected via Ethernet only. The USB ports are for expansion storage.

WD Router is junk. Get something decent.

rodmichael wrote:

Does anyone have any advice?


Maybe a dumb question, but did you enable the Media Server in the DL4100?

Does it appear as a Media Server from any other device/DLNA client?

Good thoughts!  I should have mentioned.

Yes, I did enable the DL4100 as a media server. And, no, my home theater TV (a DLNA client on the network) does not recognize the presence of the DL4100.


Did you tried to access Twonky over web UI?

IP.addreess.of.dl4100 :9000/

Also it should show on PC under thr Network as Media Server and Storage.

Also when acceesed over Dashboard you can check what media players are on the network

Are all devices in the same WORKGROUP?  If not, that could cause things not to be seen/found.

Thanks for your thoughts.  I had already checked all those issues at the time of my original query.

However, beginning Thursday evening, after no particular action on my part, two of my TVs began to recognize the DL4100 as a DLNA media streaming device.  I had only stored one movie (*.mkv) in the Public/Shared Videos folder.  One of the TVs (a 2011 Sharp Aquos) is apparently unable to recognize an MKV file.  The other (a 2011 Panasonic Viera) does recognize the MKV file and plays the movie.  My PC also finds the MKV file

I have since stored 3 additional movies (as MP4 files) in the Shared Video File. None of the TVs nor my PC recognize the new MP4 files.  Any suggestions?

15 MINUTES LATER:  I found the answer to my issue.  I rebuilt the DLNA database in the “Settings” section of the DL4100 dashboard.  The answer was provided in the WD FAQ database.

Thanks everyone for responding to my question(s).  I’m not sure what happened but I seem to be moving forward again.