Dl2100 not updating os

my dl2100 will not update os.
it start the process by downloading the new Os 5
when starting to upgrade it comes out with -1 and update fails
so I give up on this

I’m assuming you tried to get the DL2100 to update itself from the web UI? Have you tried a manual update?

What is the firmware version in your DL2100 right now?

You can try download the firmware files from WD’s web site and manually install.

See: https://support-en.wd.com/app/products/product-detail/p/127

If you want to update to OS5 you must first make sure your DL2100 is updated to OS3 Firmware Release 2.41.116 (12/08/2020). Once done download the OS5 update and manually update to OS5.

My OS now is OS3 and i use the update button within Dl2100

Sendt fra Jørn’s iPhone 6S

Try download OS5 firmware file from Western Digital’s web-page and apply manually.

My version is 2.41.116 Os3

Sendt fra Jørn’s iPhone 6S

What happens if you download the OS5 firmware file from here:

… but before you try and install it select the Knowledge Base link below and read the information there to prepare for the upgrade.

**Some features and apps from My Cloud OS 3 will not be available with My Cloud OS 5. Before upgrading, please review this Knowledge Base article for more details

You manually update the firmware by selecting Settings then Firmware Update and then use the Update From File option.

Maybe that will will work. If it does not then I suggest you contact Western Digital technical support.

Thank you Myron for trying to help me but it did nok work the upload of this bin file did fail to.
This update to os5 is not important for me. My nas works for me, and if I need improvement I will by me another Nas.
But thank you for trying to help me.
Have a nice day

Sendt fra Jørn’s iPhone 6S

Hi, I have exact the same problem.
My version is 2.41.116 Os3 and I cannot update to OS5 by web update or manually.
Status is -1 and after this the update stop.
Anyone can help me?

My dl2100 has 2x8 gb intern hd total 16gb spanned. This might be the problem that it will not work.

Sendt fra Jørn’s iPhone 6S

I use only 2x 2TB, also Reset the item but same Problem

Sorry for the picture, is only in german

I have 6gb free space so i do not think that my hd are the reason but my NAS is working Ok exept from this Os updating problem.

Sendt fra Jørn’s iPhone 6S