Disk capacity dropped to 1.3Gb, how to restore it?

I have lost my shares. I think it was due to an acidental power down during an update or so.
All hints I could find in this community did not help to restore them. I also tried system restore without success. I eventually admitted to lose my personal data and tried the full restore.
After many attempts MyCloud is now running but showing only 1.3Gb free disk capacity on the home dashboard. In the shares I can see only the default ones but not the ones with my data. Obviously the disk space used by my old shares wasn’t recovered and is lost.

How could I recover the full 2Tb capacity?
I think if you could provide an empty image of functioning disk, this might help.What do you think?
Many thanks for your help.

@Nidal What type of device and operating system are you using? If Windows 10 and you remember any of the file names have you tried searching the My Cloud using File Explorer?

Are you able to provide an image of what is showing on your Dashboard?

It should be noted that the actual capacity of a hard drive is always different than the advertised capacity. For example a 2TB advertised hard drive actually has around 1.8TB of actual free space. On the My Cloud, since the firmware/OS is stored on the hard drive the size may be slightly less.

A System Only restore (via the My Cloud Dashboard > Settings > Utilities) does not remove user data. It only resets the My Cloud Dashboard settings. User data should still be accessible. A Quick Restore should remove all user data. A Full Restore is supposed to securely wipe user data and may take many hours to perform.

Use System only to restore system data to the originial factory settings.
Quick Restore erases content and system info but can be recovered with recovery software;
Full Restore permanently deletes all content and system info, and cannot be recovered.

Having a power loss/or manually rebooting the My Cloud during a firmware update can cause unexpected actions up to and including data loss. There are a number of methods to attempt data recover (for example using Linux data recovery programs) on a My Cloud hard drive. One may have to remove (shuck) the internal My Cloud hard drive and connect it to a computer to recover data.

If one has previously used WD Sync it is possible the hidden WD Sync folder on the My Cloud which stores copies of synced files for recovery may be consuming the free space on the hard drive to account for the 1.3TB of free space rather than 1.8TB for example.

One can enable SSH within the My Cloud Dashboard then SSH into the drive using Putty or WinSCP and review the contents of the My Cloud hard drive. From there one can see which directories (using standard Linux commands) are taking up space on the hard drive.

Hello @cat0w
I’m using WDMyCloud 2TB, is connected to the home network and not directly to the PC, so because shares were lost, there’s nothing I could connect to from my PC.
Using SSH to recover files remotely didn’t help.

Last chance step, if nothing else works, would be to open the device, extract the hard drive and connect it directly to the PC as a secondary drive.

I’m using a dual boot Windows10/Ubuntu as a main computer, in addition to other laptops and Android devices.