Dashboard (web interface) is inaccessible

I purchased the EX2 last week and received it Monday. Setup went smoothly, but soon after I lost access to the Dashboard (webview) and I’ve been trying to get it back.

It’s strange because I have full access to the drives on the network and can read/write without a problem. Both the MyCloud QuickView software and the WD MyCloud software can find the drive on the network, but when I try accessing it from the My Cloud software, I get the error “Failed to connect to the device”

When I try to access the Dashboard (using either the IP address or the http://wdmycloudex2/) I receive an error “Unable to connect”. I’ve tried from multiple computers (Windows 7, Windows 8.1), on Wifi and hardwired, on multiple browsers (Chrome/Firefox) and a Tablet. Some of the machines had the software installed, others didn’t. In all cases, the result was the same “Unable to connect”.

The device itself is showing a solid blue power light. I’ve tried rebooting and reseting to factory default. In both cases, the result is the same and the Web interface is still unavailable.

I’ve though about trying to update the firmware, but you need access to the Dashboard to do that, which I don’t have.

I’ve looked through the forums and I think my problem is unique. Or at least, I haven’t found anyone with the same problem.

Please help! I’m out of ideas and want to avoid the hassle of returning the drives.

Thank you in advance

Hello and welcome to the WD Community.

Were the unit setup with a static ip or by DHCP? If it was DHCP, the ip might be different.

Have you tried a different browser?

Thank you for your reply.

The IP hasn’t changed. I’m able to ping it from the cmd prompt and read the drives on the network. Only the dashboard is unavailable.

I have tried multiple browsers and multiple computers.

Any other ideas?

Bump

Pinging doesn’t guarantee that the ping back is coming from the EX2…ping could be from another device in your network if that has taken up the EX2’s old IP.

Not sure how exactly you are accessing the drives via network, but assuming you are using Windows, can you open a Windows Explorer (not IE) window and in the address bar put in \\ and press Enter. If that shows you all your EX2 shares then yes, the IP that you think is assigned to the EX2 is indeed the IP. If not, then looks like that is not the IP of EX2 anymore (it would be static only if you assigned a static IP in the router settings). Alternately, you can simply login to your router’s web admin interface and look for all IPs of devices connected to your router. EX2’s IP should be listed there. Once you are sure about EX2’s IP, only then can you try that IP in a browser to reach the dashboard.

The IP hasn’t changed.

I’m able to see the drives, including read and write to them. I’ve confirmed both with the router and WD Quick View that the IP has not changed.

I’m not able to access the Dashboard (web interface). I get a message saying “unable to connect”. It finds the IP, but the dashboard just isn’t there. Any ideas?

I’ve tried a number of other things, but still haven’t found a way to access the dashboard.

  • Tried connecting the device directly to a computer using a cross over cable, and received the same result (no access to the dashboard)
  • Tried Port Forwarding ports 80 and 443 on the router, and received the same result (no access to the dashboard)
  • Tried to TelNet into the device but it was unaccessible
  • I have no trouble reading it as a network device on the network
  • The program, “WD QuickView” has no trouble locating the device on the network, but cannot open the dashboard
  • I removed the drives (while the unit was unplugged) and tried accessing the dashboard, but received the same result (no access)

I’m wondering if it’s possible:

Is there a way to reset the device to it’s manufacturing defaults without the dashboard?

Is there a way to update the firmware without the dashboard?

I’m getting to a point where I think my only solution will be to exchange the thing

I have the exact same problem, however i have seen it manifests itself only when i have an external USB drive plugged in, if  i remove the external usb drive and reboot i can once again access the dashboard. Its very frustating.

I believe a reset is in order here. Try holding the reset button for about 10 seconds.

If that doesn’t work, there is another reset method. Unplug everything from the NAS, hold the reset button, plugin the powercord and ethernet cable and keep holding  the button for 40s

I recently purchased the My Cloud EX2 and I’m experiencing the EXACT issues that both of you had talked about. This thread is the top internet search result for this issue but no real resolution or help from WD?

Has anyone found a solution? What good is a NAS if it does not have the capability of handling an external USB hard drive for backup – or in my case, trying to use the USB drive to “restore” my 1 TB of data from my previous NAS to this new one?

Is this the new EX2 Ultra or the older EX2?
Have you opened a case with support? <-- Highly Recommended