Error 404 on Ex2 Dashboard after firmware update

Hi community,

as many of you i ran into major problems after firmware update 1.04.05.

Thanks to this thread

i could manually upgrade the ex2 using firefox portable.

Now i ran into another problem. After the update the Ex2 shows up in network and in quickview. WD Cloud Software is working as far as i use the networkbase connection because:

The Admin interface will not show up! Dashboard is unreachable in firefox (only firefox portable will show the login, but shows wd anthrazite page with nothing on it after login).

I alread did another reset. But it did not help. Any suggestions?

Thanks a lot!


I think it will be better if you contact WD Support directly for futher assistance.

WD Contact info:

Hi ERmorel,

i did and did not receive a solution for it. Like a miracle my ex 2 is now working again - only users missing.

So if the support did this - than its scary - but who would ever think that nobody can access my drive … i mean without my permission.

Hm never the less i am happy.

Hi, I have the same issue. I can access my shares via laptop and phone app. However, can not connect to dashboard via IP address (have tried using firefox and chrome) For others that find this post, will share steps if it gets resolved.


this helped me. I’m still looking to see how to manage my torrent when im away (seems unable to do it so far), but at least that allowed me to access dashboard over internet.