Caviar Green WD20EADS-00S2B0 - Extremely Slow transfer rates? Fix? Patch? RMA?


#1

I’ve built a few systems with WD drives and had no problems until I installed two 2TB GP drives a few months back. These are internal SATA drives in an Intel system where they serve mainly as file archive storage drives. Typically any file transfers are unattended so I did not notice the problem until recently.

The transfer rate seems is always around 1.5-1.8MB/s. Swap the drive out and put in an older 1TB drive and the transfer rate jumps back up to the high 40s. Everything else is the same. And it happens with both 2TB drives. All diagnostics show nothing wrong with the drives (LCC count seems normal for about 3 months of usage? A couple of hundreds?) They are just slow at transferring files to and from these drives.  Try two file transfers to the same 2TB drive and the TOTAL transfer rate is still 1.5-1.8MB/s. There seems to be a transfer rate cap on the drives. Other operations like formatting/etc also take an abnormally long time, 12 hours to format a 2TB drive versus a few hours for a drive, half the size?

Frankly, I can live with this issue. Turns out the customer just wants to store his anime, home video/etc, but I’m rather worried as to other issues. The last time I had a drive this slow was when it was a floppy disk drive. I’ve googled and search this board as well and found quite a few threads regarding slow transfer rates on the newer WD 1.5-2TB drives, and in some cases where the drives were RMA’d, the problem seem fixed so I’ve put in a support ticket to see if I can get a RMA or hopefully some firmware patches.

Now these drives are just a pair that I bought to help fix up a mate’s system but I also help made decisions as to hardware purchases for a data center. The CEO would shoot me if I recommended Caviar GP/RE drives that turn out to be this slow so I went back to the shop I bought these drives from and they have had an earful regarding this issue as well. I believe most people who bought Caviar GP drives did so for the low temp/low noise aspect with the understanding that the low 5400 RPM would mean <50MB/s or less but 1.5-1.8MB/s? I sincerely hope this is an isolated issue, perhaps affecting batches of drives.

Does anyone have a clue as to the possible problem? I’ve dealt with a lot of HDD problems before but this one will stump me if WD doesn’t have a fix. I’d hate to have to make my next purchases from somewhere else.


#2

Caviar Green is very very slow.

Initially I though it was green and saved power, so I decided to purchase WD15 EARS.

Now  I regret to have this useless harddisk.

It is totally ■■■■ and even increase my electricity bill by letting my PC to standby longer than per usual with slow processing time and decreased productivity.


#3

Found other similar topics on this ■■■■ WD15 EARS, sigh :angry: :


#4

Sorry to say that Tech Support wasn’t much help as they basically just told me to zero out the drive and if that didn’t work (it didn’t) to RMA it. I assume this is because they did not know what had happened and would like to get their hands on the actual hardware.

To recap, I had a pair of WD20EADS that posted < 2MB/s transfers whenever either of them were involved. Problem goes away if I swap in other drives. Problem persists if I move the drives to other systems. Open and shut case?

WD20EADS - [SATA cable] - SATA controller. (JMEchipset)

From above, I had swapped the drive and the controller, but I did not swap the cable or in my case, type of cables. Why would I? It works fine with a WD10EADS, why would it be any different? And yet it is. The original cable used is a custom-made 75cm* long SATA data cable with right-angled connectors. When I used the more typical 24cm length cables, the transfer rate went back to the ‘normal’ 30-55mb/s.

So… I went back and tried the other drive with a short cable. Worked.

Right-angled connector PLUS 75cm* length = <2mb/s

Right-angled connector PLUS < 50cm length = normal transfer speeds

Straight connector PLUS 90cm length = normal transfer speeds IF connected to the onboard Intel SATA ports.

We’re getting in some WD20EARS within the week, so I’m ordering some more of the 90cm cables just in case. In the meantime, I have all drives that are connected to the add-on JME ports using <50cm cables, Intel Sata ports with the 90cm ones.

So Intel SATA ports are somehow more sensitive/etc? Or are the cables just very badly made (I checked, they are not from Foxconn). Either way, I seem to have solved my problems for now.

*Why 75 cm or 90cm? The casing’s very large with the HDD cage set quite a distance away from the motherboard. Drives at the top of the cage can be reached with a 35cm cable, drives at the bottom need 20cm more. Also due to the configuration of the SATA ports on the motherboard, using right-angled connectors meant an additional 10-20cm length. Using straight connectors meant chanelling the cables along a longer route of almost 85cm.


#5

Having the same problem with my WD15EADS  I had never seen this problem and (unfortunately) upgraded several things at the same time including OS (to Win7)  the system would be slow to boot, and frequently freeze then continue as if nothing was wrong. 

Is there a firmware update for these?  Its currently taking 45 min to transfer 13GB off the disk now that I bought a different drive for the system to run on!

HR


#6

Well it’s been a week, and not only are the original two WD20EARS drives working fine, but another twenty WD20EARS work fine too. With so many drives, I tried some of them with the ‘problem’ cables and about half were ok, the rest were both intermittent or had the < 2MB/s problem.

Also had a new problem crop up, that of abnormally prolonged System Interrupts/DPC high CPU usage but I traced that to an IRQ ‘conflict’ (which is supposed to be near impossible with Win2K and later OS but then how reliable was Plug and Play right?). Drives are ok for now.


#7

If you can run Xperf, maybe that might help you out. I found an IRQ conflict between a sound card (IRQ 18) and the onboard Realtek NIC (IRQ 16). Yeah i know it doesn’t make sense, but either removing the sound card or moving the sound card to a free PCI slot (which did change the IRQ assigned) got rid of the high CPU usage problem. It was actually cutting down my disk I/O speeds but about 75-85% every time the sound card was in use (to sound an alert in the datacenter and playing MP3s but the latter was strenously denied.) Xperf showed that when both the Multimedia and Ethernet controllers were enabled, the System Interrupt/DPC would spike CPU usage. This issue cropped up when I realised the servers with sound cards were always taking longer to do their daily SQL backups. The only clue at that point was the Windows Explorer process hitting 100% on a single CPU core. Ubuntu running on identical hardware was problem free, thank you M$.

I’m not saying this is your problem, but just to illustrate how something from out of left field could be causing you grief.


#8

dear All

same problem for me .

Very low tranfer rates, PC stacks  for minutes , etc …

Problem seems like no cache is working for this disk. I check it with Sis of SANDRA , and no cache appears.

I have every thing unti now but is is useless.Aligment did not help at all, as well as  jumper to 7-8 pins. DISK IS VERY SLOW . I tried contact WD but no answer. It is very bad roumore for the company these kind of drives … GREEN HORSES … 


#9

Hello,

Also here WD  WD20EARS  I check it with Sis of SANDRA also , and no cache appears.

System : Win7 E8400 mem 3GB

Other 3 hard drives ( 1TB)  give in the summery cache size. 32 MB

Perhaps also Windows quilty?

I am not happy  with a rate of 1.2MB/s.


#10

I have 4 1TB WD10EADS drives with 32MB cache on each, 3 manufacutured on Jan 22, 2009 and the 4th on June 23, 2009. I had orignally bought the 4 drives from TigerDirect and had paging errors on one of the drives so I RMAed the drive. Now, I’m experiencing the same slow transfer issues that others have mentioned in this blog. Drive to drive transfers (5GB file) as low as 13MB/sec…same drive copy (<1MB/sec)! I have swapped cables, performed a clean install of Windows 7 x64, installed the latest drivers, updated mobo BIOS, and everything else that WD tech support has suggested all with no improvement. I have ran the write zeros test several times with no errors, so WD’s stance is the problem is not their fault. On the flip side, I have two identical WD Caviar Blue 640GB drives with 16MB cache and these drives flat out out-perform my 4 Green Drives by a huge margin. I understand the Green Drives would be slower, but the official WD spec sheet for both Blue & Green drives are almost identical as far as performance (controller to cache, cache to disk), with the Green Drives being marginally slower. I am extremely frusturated with WD’s unwillingness to even take the drives back and perform extensive testing on their own. Like other users who have already posted, I have encountered plenty of issues with HDDs, but this one just takes the cake.


#11

I have recently purchased a WD7500EADS drive Caviar green I too am having the same very low drive transfer spped issue.  I called Western Digital and tey said the issue was with my Motherboard or my windows installation, I cannot beleive the actually want me to reformat and reinstall windows to supposidly fix a hard drive error this is just a huge cover-up for this failed green tech drive they are trying to pawn off on everyone I should have got the black drive.  Even with a 16 mb cache it has always been faster than this horrible green drive.


#12

Same drive WD20EADS-00S2B0, same issue.

58,000 disk and NTFS errors in 7 days :smiley:

I was away for 4 of them.

Slowly moving everything off now. 1.8tb @ 1mb/s = ~18days of copying.

Yay.

Has anyone from WD acknowledged this issue yet?

I’ve had a look and failed to see any official response.


#13

Anyone heard about Seagate’s 2tb drives?

I’ve probably bought 15 or so WD in the last 10 years, but I’m thinking that if they cant be bothered acknowledging an obviously fairly common issue, I’ll RMA and change suppliers.

Lets see if I can remember… 3x40gb, 2x80gb, 1x120gb 2x 180gb 3x200gb, 2x320gb, 1x1tb 1x2tb.

Heh not a bad guess 15 drives for me personally.

This is by far the worst performing of the lot of them.

WD, please acknowledge the **bleep** issue or we’ll all vote with our wallets and our mouths in the coming years.

This is not a threat. It’s business.


#14

I would like to share my experience. I bought WD5000AADS (Caviar Green 500G) last month and having the same issue (transfer rate ~2-3MB/s on my SATA pci add on card (using VIA6421A chip).

Since I ditch the card and use Sil3114 (by Silicon Image) pci SATA card AND use short SATA cable (<40cm) AND make sure the SATA BIOS is exactly v5.3.14, the issue resolved. My average transfer rate back up to 70-80MB/s by HD Tune. :smiley:

I guess there is an issue with chipset compatibility with WD Green HD. There is a list of compatibility in pdf by WD online (although none of the Caviar Green models are listed).

http://www.wdc.com/en/library/sata/2579-701239.pdf?wdc_lang=en

Only time will tell if these Green HD worths their money.


#15

my WD20EADS drive is starting this ■■■■ also.  i had a similar issue with my 1.5TB WD drive, i RMA-ed it to fix it a few months ago.  i think it will happen again

i guess i end up with an endless cycle of RMA-ing drives every 3 months.  this 2tb drive is only a few months old


#16

Two problems seem to be responsible. These drives are fussy about cables and noise and may generate errors. If you get too many errors then Windows Xp will switch and stay switched to a slower data transfer mode. Even if you change the cable it stays slow.

Solution is to

  1. Get decent short cable - suggest SATA 3 compatible to ensure best quality

  2. Ensure that the fast DMA mode is enabled - see solution on this forum.

http://community.wdc.com/t5/Desktop/recommendation-to-WD-hdd-for-sudden-drop-of-low-speed/td-p/19150

This worked for me.

If you get a new SATA controller card this will force windows to redetect, which is why that has worked for others. Good luck,  hope this helps.


#17

I am using 90cm cables but have started using 120cm ones, again on WD20EADS/EARS drives. No problem so far provided I connect them to Intel SATA ports. JMicron SATA ports (from motherboards that were made in 2008 up to April 2010) seem to have something different in them as I cannot use cables longer than 50cm before having the <2mb/s transfer rate problem reoccurring eventually (within a week at most). I tried VIA chipset add-in cards and got the same issue as well. Since I am not the OEM concerned and really do not want to run a lab for this issue, I cannot give you hard numbers. Basically, Intel SATA ports + average quality cable up to 120cm = good, non-Intel + any quality cable > 50cm = bad. A bit off-topic but AHCI mode on the JMiron SATA controllers seems to induce a buffer/queueing issue in the driver that eventually causes a spike in DPC CPU usage. You would only notice this during video or audio playback but this issue will ‘kill’ any multimedia workstation’s usefulness. Switching the controller to IDE mode cures this (but of course, no RAID or AHCI/etc) for me. I only get this issue for Windows ver 6(vista/7/2008), XP seems fine somehow. Also forcing DMA mode/etc as listed in various links on the 'net and here does not work that well for me. You might not see a data error very often but it will occur eventually. I had a few 2-3TB files show up with a few bits worth of errors. Granted the drives are not the RAID/Extended version but that still means the error rate has to be quite high to get past ECC and give me 1 or 2 bits of errors in a TB size file. Not an issue if this is your anime or movie file… but not so good if this is the payroll file. A better way is just to disable the relevant controller, then reenable it. You can do this within Windows without having to touch the BIOS at all. If the DMA mode is still not correct, then you know you have an issue.


#18

I have solved the problem by installing Win7 upgrade with the original programm. Now transfer rates between 80 and 115 MB p/s.


#19

lol one of my drives with windows 3.11 is more quick that your results of 1.8 Mbs loool

how is that possible :stuck_out_tongue:

manufactured in december 1994

270 mb hard disk

98 Kb cache

just for fun :stuck_out_tongue:


#20

I would do a full disk check using WD tools off off the bootable cd.

I had the same problems and I assumed it was because this was a “green” drive.

Although it is a little slower than a normal drive it shouldn’t be noticeable slow.

The problem in my case was “bad sectors”. The WD diagnostic utility showed that the drive was starting to get bad sectors all over the place and that caused the drive to slow down so I RMA’d it.

New one I got seems to be working fine now.