WD Caviar (Green) 1 TB new failed, replaced twice, third sitting on my desk, dead


#1

Hello Fellow Readers, I’ve bought a WD Caviar (Green) 1 TB HD to replace my aging drive thinking they all die with time. I am running my HP pc with the Windows XP, so far so good. Ok, put the new drive in the pc, format, started to transfer data from the old disk, ok for about half way, then ERROR, lost connection. What? Ok, try again, did the same, again? Yes, it did the same. Ok, take it out from the pc put my old back, put the WD on an outside USB box and try the data transfer that way. So, it goes again, and the data transfer stops after a while. Well, that is no good, downloaded from the WD support site the diagnostic program, ran it, reported lots of dead sectors. What? Yes…that was it. Ok, it is time to check out service and guarantee stuff, so I ran through the official return and got the RAN, so it went back. I have to tell the WD service is lightening fast and reliable with excellent communication. Whoo hoo, I got back a new one in a very short time, go through the same process as I did with the 1st one, guess what, same results. I did not believe it first, but thinking that I never win on the lotto – despite buying tickets regularly – I thought, well statistically I can strike my unlucky chance with this, so I put the old drive back to the pc (still runs charmingly a Maxtor 160 GB), went through RAN again. Service excellent again, but so far the postage costed me an other AUD50. First I looked the drive and I’ve put on a rubber glove, just in case. Ok, pc opened, old drive out, new in, runs, whoo hoo, that looks good so far, I thought, and after formatting, partitioning I’ve started data transfer. Yes, it did go fine. Ok I thought it is solved, thanks to all involved at WD. Next day, I switched on my trusted HP and ……NO DRIVE RECOGNIZED. I thought that’s it, that is not possible…Ok, ran my trusted Paragon partition program, it may be some magic in the air and probably can be formatted again, guess what it came back that the disk, the WD 1 TB is now an unformatted 2 TB. Entertaining? NOOOOOOOO !!! So, old disk back, try to connect as an external via a USB port, yes it reports as an unformatted 2 TB disk and when I want to format, it can not do it. So my data is sitting on it, I cannot even send it back any more for a replacement. DO NOT BUY THAT DISK!!! However I have to tell to the world the WD Service is excellent, but hey what can I do with an excellent service when the product is as describe above ( I do not use words, that describes it fittingly) Thanks reading it, any constructive suggestions?


#2

Please understand that I’m not out to take WD’s side on this, but have you checked your partition and file structure to make sure that your system drive’s partition isn’t corrupted?  I would run XP’s Scandisk and error checking to make sure there’s nothing wrong with your partition.