Caviar Green WD20EADS-00S2B0 - Extremely Slow transfer rates? Fix? Patch? RMA?

If zero’d my two WD green drives out 5 times. Set them as Raid 1 via Sata controller,mirrored them via the Win7 drive manager, formatted them with 512, 4K, 16K blocks, MBR and GUID, basic and dynamic. Doesnt seem to matter at all starts of 68mps when coping large amounts of data on or off of them but within 2 min it drops, and keeps dropping. Moving 50G of data shouldn’t take hours!

I just bought a WD20EARS and was getting the <1MB/s transfer speeds.  Full disk check would have taken >7 days (extrapolated; I stopped after day 2 at 27%).

My problem is solved:  I did (2) things, so I can’t tell which one worked.  But here they are:

  1. I moved the drive from a JMicro SATA controller port to a different mfg controller port (I saw problems with Jmicro compatibility elsewhere in this forum, but I didn’t save the link; other posts suggest a sensitivity to SATA cable length).

  2. I deleted the registry keys as suggested in this post:

I totally understand everyone’s frustrations with the slow drive performance… (paper weight… garbage… etc…)  However, with a little TLC and patience, this one seems to be now working like a champ.



I’ve had the same problem while assembling a new pc. The problem is that after installing Windows XP SP2 and also after installing all the updates the throughput from the WD GP disks (in my case they were  WD5000AADS as system disk and  WD10EARS data disk with  jumper between pins 7 and 8 set before formatting) was very under 12 MBps instead of the about 100 MBps expected.

After several test I understood that the problem is due to a “missing communication” between the hard disk and the operative system that make use of the wrong driver for the disks.

Two possible solution:

  1. change the SATA port:

a) switch off the computer

b) connect the HD to another SATA port on the MoBo

c) if needed change the boot setting on the BIOS

d) turn on the pc

e) at this point the ‘found new hardware’ message should appear on the bottom left of the screen and the “new” disk is installed, from now on the disk shall work perfectly

f) move everything back to the original configuration (not necessary, but I did)

  1. ask the O.S. To use the right driver

I did not test this procedure, but it should work and is faster and easier, it should be enough to start the “scan for hardware change” procedure in the device management. I guess that shall force the O.S. To use the right driver (no installation required).

For sake of clarity the computer is  composed by:

  • ASUS P7131H
  • BD LG
  • WD5000AADS (system disk)
  • WD10EARS (data disk, jumper set before formatting)

and it is connected via the HDMI directly to a 46" Panasonic plasma TV G10 series and via the optical output to the home theater amplifier

Y have a WD20EADS but mi issue is not Reading/Writing average speed (Read 90mbs and write 70mbs aprox). My problema is in Acces Time. I have 113ms… When the NORMAL is about 13/15ms. 

Anyone know how fix this?. With a Low Level Format? Regenrating Sectors?.. Is a torture decompress or copy a big file with this acces time :S

PD: Sorry for my Bad English.Greetings from Argentina