Can't update Plex Media server

I have version Version that I installed from WD’s store. I tried to manually update and even install from scratch using WDMyCloudDL4100_plexmediaserver_09146.1620-e0b7243.bin.

the file downloads into the DL4100, “Updating” briefly shows on the dashboard UI and then absolutely nothing else happens.

Anyone got a solution?

Hi there Myron.

I believe you can get the latest version of Plex from their website, you can try to download it front here and see if this way you can have it work.

That’s exactly what I did. downloaded it from their web-site. Used this to install it . . .

Then this shows after the update file uploads . . .

Then it goes back to the Add an App options. Cancel is enabled and Install grayed out. So I click cancel.

I go back to the server options on Plex server to be yet again greeted with . . .

I’ve gone step-by step as I’ve written this. It seems to be impossible for me to install the Plex Media server update.

I’ve tried to uninstall Plex server and use the update file from Plex as a new install, same thing. Won’t install.

I’m just going round and round in circles. Monumental bug when it comes to manual installs and updates?

this might help as the UI shows no errors:

root@ZEUS / # /usr/local/modules/script/ install /shares/Volume_1/AV_media/WDMyCloudDL4100_plexmediaserver_09146.1620-e0b7243.bin
{"BgTaskID":"6826785f-73ce-45fa-bad6-5d1cce2dfe15"} STATUS 200 CONTENT_TYPE application/json
HTTP Status: 200
CONTENT-TYPE: application/json
Background Task ID: 6826785f-73ce-45fa-bad6-5d1cce2dfe15
HTTP Status: 200
CONTENT-TYPE: application/json
App installation failed
root@ZEUS / #

Can you or @SD001 assist?

Can’t Western Digital grab the BIN file from Plex and put this on your app repository? Why is WD hosting an out-of-date app?

1 Like

Myron, a few months ago I saw this thread in the DL forum, and it worked for me, so look near the end of thread for info about updating PLEX:

You will look for this part in the thread:


Jul 17

Found the anser for Updating Plex , (a hot link in thread to P:LEX forum; click on it.) it works perfectly:

  1. Download the update for your WD NAS to your computer(a *.bin file).

  2. Open your My Cloud User Interface.

  3. Navigate to the Apps Page.

  4. Select “Add a new App” (the small box with a “+” on the lower left.)

  5. Select “Manually add a new App.”

  6. Navigate to where you downloaded the update file (*.bin).

  7. Select the *.bin update.

  8. Follow instructions from there.


That’s one of the things I tried. It didn’t work. I knew this would happen. Thank-you for assisting me, but people are telling me things I’ve done many times over. It’s like the DL4100 is rejecting the .bin file and not telling me that it’s been rejected.

People. Read carefully. I download the file file from Plex. I go to the area on the UI to manually install/update, the DL4100’s tells me “Updating …” and then after that nothing. Nada. Zilch.

Regarding (from the Plex forum) …

This will allow you to search for the downloaded bin file and select it.
Then follow the prompts to get the app installed. You may get a dialog
box asking whether you want to replace the existing app… choose yes. I
found all my settings are preserved and that Plex is updated.

the DL4100 didn’t get to even ask me if I wished to replace the Plex application.

I’ve turned off Twonky. I’m using Plex because it’s making my Chromecast useful even with video file formats that the Chromecast can’t play directly because it’s got a limited set of codecs in it. (Which makes, for me., the Android app localcast useless.)

EDIT: Now why didn’t I think of that! Bud in the Web UI. I tried to the update with Internet Explorer on Windows 10. it worked. On Chrome and Firefox it didn’t work. (Sigh…)

@SD001, an issue identified is when I updated the Plex app manually the DL4100 is then telling me that there is an update on the WD’s app store. Obviously that’s wrong because if I do that it downgrades Plex to the older version on the WD app store. This needs to be communicated up to the product engineers. It would be easer to lift the Plex .bin update file from Plex’s web site put it on the WD app store? For you lot it’s got the be that easy?

Now I’ve had to put a rule on my e-mailbox to delete the “please update Plex” e-mails being sent from the DL4100.

So, summary:

At the moment when Plex is updated manually the NAS will bug you to update the Plex media server from the WD store, which will actually be a downgrade from the upgrade.

Awesome! :slight_smile:

Hmmm, have you thought to just remove PLEX from server, reinstall it and start over?

No. I didn’t. I’ll just ignore the NAS’s UI insisting there is an upgrade available. I may try later. to fully uninstall it and then re-install from the .bin supplied by Plex and see what happens. when I do I’ll report my finding here.

exactly, please update your database! it is not very professional to store old files.

just installed plex too and saw it is outdated.

1 Like

I can’t update, uninstall, turn off, or access the configuration anymore. After attempting to “update” the app it just got all hosed up. As i said, I can’t stop it, uninstall etc… Completely hosed up…

WD My Cloud EX2
Current Version 2.11.153

Plex Media Server
Version: 091211.1406
Installed on: Thursday, September 03, 2015 7:33:05 PM

OK, so try re-installing it again, maybe the install got bunged up somehow.


Anyone able to shorty explain how to fix this issue?
I removed and reinstalled plex and the server isn’t available.

Also can anybody tell me where the app is installed on the file system via WD my cloud?
Else I could delete the entire file location where plex is installed

I found a workaround that works for me. I have Plex installed on a MyCloud EX2 Ultra NAS. Plex indicated an update was available but needed to be manually installed. I downloaded the update.

Trying to install the update using Chrome failed.
Trying to install the update using Firefox failed.
I read another thread that indicated it was a browser issue and that Internet explorer should work.
I’m on Win 10 and no longer have Internet Explorer so …
I tried to install using Microsoft Edge and the install worked just fine!!

Apparently install has some sort of incompability with non-Microsoft browsers???

The updated plex server (config) works just fine in Chrome after it’s installed, it’s just the install process that isn’t working in Chrome or Firefox.