Can't connect to U-verse HELP

I hope someone can help me. I’ve been at this for almost 15 hours on the phone the past 4 days!
I switched from TWC to U-verse. For some reason, I can’t get my WD MyCloud to connect to my network…it’s stuck on a blinking (yellow??) light.
I also had gotten a new MacBook the same day the U-verse was installed and I spent over 2 hours on the phone with Apple to get it to connect to the network. It was something with the settings.
Is there ANYONE that can help me get my WD MyCloud to be seen on my network.
WD blames U-verse…U-verse blames WD.
Thank you in advance for ANY help you can offer.


Purchase a cheap GigE Switch from Amazon or your favorite electronics shop.
Plug the switch into the Uverse Gateway Router
Plug the My Cloud into the switch and power on


1 Like

As noted by the previous poster, use a switch between the U-verse router/gateway and the My Cloud. This issue and current suggesed workaround has been discussed previously in the following thread.

1 Like

Well that’s interesting. Can I use a Cisco router I have here at home? Will it do the same thing?
Thank you!

I’m sorry if this issue was posted in an earlier post. I DID look for almost 30 min to find my problem & solution and didn’t see it. I also do not have 1Gig Fiber Service, so I didn’t think that applied to me.

Thank you again.

OK…I connected an old Linksys router and the blue light IMMEDIATELY came on!!! YAY!!!

HOWEVER…I run the scan and it can’t find my device. I’m assuming I have to install the router, but I don’t have the installation disk and being the warranty expired in 2008, they won’t help me unless I pay! UGH!!
I did try going to “”, but safari says it can’t open.
Any ideas on what I’m to do??
Thanks again!!!

If you want to use a router as a switch on a local network that already has a router providing DHCP services, you will need to log into the second router (to be used as a switch) and disable that router’s DHCP server. Then connect one Ethernet cable from the main router’s networking port to the second router networking port. Do not connect the Ethernet cable to the second router’s Internet/WAN port, only to one of the four local network ports on the second router.

1 Like

THANK YOU for answering so quickly!!
Do you have any idea as to HOW I disable the DHCP on the router?
As I said, trying to go to the “” without any luck.

Do a Google search for your old Linksys router model and you should be able to find the instructions on how to access the old Linksys administration page so you can disable the DHCP server.

Here is one such link for older Linksys routers:

You may have to connect your computer direct to the old Linksys router prior to connecting that router to the main router in order to gain access to the old Linksys router’s administration page. You may also want to perform a reset on the old Linksys router by pressing and holding in the reset button on the back of the old Linksys router for at least 30 seconds.

1 Like

That link worked!! All the other ones I had googled didn’t work.
I was able to get to the setup page and disabled the DHCP.

I ran another “Find my WD MyCloud” and guess what??? IT HAS CONNECTED!!

I can’t thank you enough for ALL your help!! Seriously, you save my sanity!!!
Blessings sent your way!!

Glad it worked.

1 Like

In addition to connecting via the network switch, WD support told me that AT&T needs to enable UPNP and open ports 80 & 443 for both UDP & TCP protocols.
They said this is a known issue with AT&T Pace & Motorola Routers and they are working to fix the issue.
When I talked to AT&T the tech said UPNP is enabled as a default on all their routers and he asked if I wanted port 88 opened as well, since they usually open it for cloud servers. I said, OK.
This tech knew I was having an issue with a WD device.
Be sure to reboot the router after making the changes.
After rebooting everything I had a little trouble resolving IP addresses between the router and MyCloud but I ran a quick restore on the MyCloud and that reset the IP address to the one the router had for the MyCloud. Everything is working fine now.

It makes me CRAZY that some techs seem to know what to do and others don’t. If it’s a KNOW issue, WHY isn’t it in the spec/problem sheets that these techs us?

Right now I’m going to leave it as it is. I’m not thrilled I have to use an additional piece of equipment, but it’s working and that’s all I care about right now. It would have been NICE to have the company tell me what to do.

Now, I’m having another issue. When I go to finder, i can see the WD Cloud with the little eject button next to it under the heading of “DEVICES”. It is also under the heading of “SHARED”. If I click on the device one, which I have always done in the past, it opens, reinstalls the program that is on my desktop. AND I can’t delete it.
Now the one under SHARED? That works like it used to under devices, only it doesn’t have an eject button.

Any ideas on this one? Should I bring it to a different thread? I’m still new and don’t know the protocol.
Thanks again for ALL your help!!!

Update. The WD Drive and the router subsequently stopped reconciling IP addresses. The drive had a different IP address than the router. At that point I was able to get to level 2 support who suggested I configure the drive and router for static IP but wasn’t willing to help beyond that. I felt the level 1 support was far more helpful. So, I gave up and turned off the WiFi on the pace router, connected my Apple Airport Extreme via ethernetto the router and connected the WD MyCloud to the Airport Extreme. It’s working much better now. I should have done this a lot sooner. So much for the WD “fix”.