Can't connect My Cloud Using ATT Uverse 1Gig Fiber Service

Okay, I’m perplexed. I recently upgraded my Uverse High Speed Internet to the UVerse Gigapower (1 gig fiber service) and now my 3TB My Cloud will not connect (flashing white light). I called support and they told me I could send it back but of course I don’t want to loose the data. On a hunch I took the unit to my daughter’s house and it is now connected (Blue light) I think she has 6 meg service and I had 12 meg service before I upgraded. Any ideas why I it won’t connect at my house? I know it’s not a bad port on the Gateway because I have other devices plugged in and they work.

Flashing white is likely to be disk doing fsck; did you shut it down from the dashboard, or just pull the power?

Flashing yellow is failure to find network; what are the Ethernet LEDs doing? Have you tried all ports on the router?

@cpt_paranoia I couldn’t shut it down from the dashboard due to no connectivity so I just pulled the power. I’ve tried most of the ports on the router. I’ve disconnected devices off of ports that were actively working and connected it to that one. Sorry, but what is fsck? I didn’t know there was a yellow light.

fsck - File System Check. If, on power up, it detects an unexpected power down, it runs a disk check to make sure the file system is not corrupt.

LED status: pp10-11 of the User Manual.

I am currently dealing with the exact same problem. I have spent hours on the phone with AT&T customer service and WD customer service. No one seems to know what is going on. When I connect the My Cloud 3TB directly to my computer via ethernet cable, device is recognized. As soon as I connect it to the modem, there are no lights on ethernet ports and I cannot find the device on my network (or through internet access). I have opened specific ports that WDC said where used by the My Cloud drive and I have even completely disabled the modem firewall (for a period of time) to see if that worked. Nothing! This is a brand new modem from AT&T (I even had a service man come out and replace the modem - still no connectivity). Any ideas from anyone would be greatly appreciated. I hate the fact that I have very fast network speeds now, but I cannot access My Cloud at all on my network. HELP!!!

I have seen reports that some routers fail to negotiate a connection with the MyCloud ; lack of lights on the network connector suggest this, but should also cause a flashing yellow on the front.

I assume you’ve tried a different cable?

One other test is to put an Ethernet switch between MyCloud and router; this might overcome incompatibilities.

[edit 18/09/16: auto-negotiation failure is confirmed]

cpt_paranoia -
Thanks for the advice. I had not thought of the switch between the two - hey, democrats and republicans typically need a mediator - maybe this will be mine!!!

Just some food for thought - light on the front was blinking yellow when connected to the modem directly - solid blue when connected directly to my laptop. Also, used 4 different cords in different ports, all with the same negative result.

Hopefully the switch idea works - I will come back and sing your praises if it does! Take care.

AT& T is sending new gateway (but I really don’t think that is the problem) and I’d rather go the path of least resistance if possible. I’ll be interested RBI_13 if you put a Ethernet switch in and it works and what kind you use. Please let me know. I’ve changed cables and ports on the back of the router to no avail. This is driving me nuts! It works fine at my daughters house who doesn’t have giga power but that’s a different router than what I’m using.

hey, democrats and republicans typically need a mediator

That’s the idea, yes…

The switch idea was to test if it appears to be an Ethernet port compatibility problem, rather than a suggested fix. If you had a switch lying around. Even an old router ought to do, I think; just connect your AT&T router to one port (not the ADSL/fibre, obviously…) and the MyCloud to the other.

But if a switch fixes it, and is cheap, it might be less trouble than fighting with AT&T & WD to find out why their products won’t talk to each other…

There may be some obscure setting in the router to control the auto-configuration protocol. Some discussion of possible problems here:

Awesome! It worked. Thanks so much! You rock!

What worked: switch or old router? If old router, it may be 100Mb, which will slug your MyCloud’s performance.

At least it does suggest some autonegotiation issue is the problem here; maybe worth investigating the router settings.

I put a switch between the router and MyCloud. I may have to talk to ATT about it to see if what setting should change. I just don’t think they know and I don’t have the know how to tinker with it without their help. The gateway does a lot of things for me including Voice (don’t judge…I work for a phone company), Video and data so I may mess something up and have nothing. :grin:

Having same issue after being “upgraded” to a new ATT gateway. It’s like the eth port is dead, but it connects fine to old gateway and laptop. Spent days with WD support, they say its the gateway’s issue. Spent hours with 4 ATT techs and all they can is scratch their head. I also tried all ports with diff cables. I did also try to set the gateway port from autodetect to a static value and rebooted gateway, but still no response, though I did see a single port LED blip both on shutdown and startup of the gateway, so it was trying.

I will try an old router/switch as mentioned and report back

One thing you could do is connect your laptop to a port. Verify that your laptop works thru that port. Then move the laptop to another port and verify that port. Now connect your My Cloud to the first port you tried. You also should use two different cables during the laptop testing. At this point you know that you have two good cables and two good ports. If this does not work. Try the switch in between the My Cloud and the router.


PS what is the model of the router.

Router-as-Switch worked!

So I had 2 routers not in use as guinea pigs. I took the newest one (D-Link DIL-655), disabled the wifi and DHCP, wired it in between the gateway and drive and voila! The drive status light turned blue and all the access tools work!

I was thinking of purchasing one of these but as I have U-verse Gigapower I’m not sure I want to. My gateway is the NVG599 what model are people using whereby they can’t connect?

I had the same issue. Used the suggested work around and now I’m up and running.

This works! I reset my old router to factory settings, then configured the router as a second access point according to the directions for the router. I have since replaced the router with a TP-LINK TL-SF1005D 5-port 10/100Mbps Desktop Switch for ten bucks from Amazon. Thank you all.

I’m having the same problem. Just switched from Comcast to ATT. I did have a netgear router plugged in to the Comcast router/modem. When I plug my WDcloud directly into the ATT, it doesn’t work. I plug in the netgear router into the ATT, then it works again when I plug it into the Netgear. No one at ATT or WD seems to have a solution. I believe it’s an issue with how the firewall id set up with the ATT router.

I don’t think it is; if there are no lights on the Ethernet connector on the MyCloud, then it has not established any connection with the router. If it was a firewall problem, it would establish an ethernet connection (so the lights would come on), but block traffic.

The fact that it is sorted by sticking a dumb switch in between (which has no intelligence, so looks like a piece of cable, as far as the firewall is concerned) shows that it is a problem of Ethernet link rate autonegotiation between the MyCloud and the router. Each device on its own can establish a connection with other routers or switch (so a switch can successfully act as intermediary between the two), but there’s some problem with the particular combination of MyCloud and AT&T router; thus it’s up to the two companies to work together to sort it out.

Anyone having this problem should report it to WD and AT&T.