Can't connect to mycloud

I can’t get connected to my mycloud. The activity light on the front is solid red. The link lights on the back are showing green and yellow. I have tried the following steps so far (in no particular order):

-Add DHCP reservation for MAC address
-Switched out ethernet cable and router port to known working cable and port
-Tried the 4 sec and 40 sec reset, but nothing happens
-Cannot ping the IP address
-Removed from previously connected WD Mycloud shortcut and added back using WDMyCloud login
-Completely reset my router
-Checked my DHCP logs and it doesn’t show the MAC even trying to connect
-Router port shows green in router setup
-Moved it off a power strip to a wall plug

I’m not sure if it is relevant, but when I go into the WD MyCloud shortcut, it shows my IP as, but in the dashboard is shows

You can get to the Dashboard, then?

That means your device is connected to your router, and basically running.

Try running the drive diagnostics from the Dashboard.

And, yes, it does matter that the shortcut is pointing to the wrong address: it should point to the address of the MyCloud, however that is set up. I’m assuming the MyCloud is set to use DHCP? It will be, after a 4-second reset, unless you have set it to static.

I’m sorry. I wasn’t specific about the dashboard part. When I try to go to the dashboard, the ip address in the web bar shows .109. It does not let me connect to the dashboard either. I have always used .119 to access the mycloud.