Can't access WD My Cloud

Hi, first post here and apologies for lack of knowledge.
I have been using my WD device for a year now with no problems. I have it connected to my router via ethernet and use it to store pictures and music on which i then access through my laptop or phone. I use a Sonos music system and so this plays music from it too.
Yesterday, i updated my laptop from Windows 7 to 10. I tried to access the files and couldn’t. I googled and saw there were issues with this so I restored my laptop to W7 and tried again - no joy.
I can access music and photos through the WD app on my laptop (so they exist!) but no other way. If i go through the files on the laptop (my computer - network - wd my cloud) it brings the folders up but states they’re empty. My phone reports the same and also shows around 20 different IP address folders wen i look on my local network. SOnos will simply not play anything and states “the share //WDmycloud/xxxx does not exist”.
If i click the WD dashboard shortcut it goes to an IP address of http://192.168.1.75/ and won’t load. If i type mycloud in the browser it will load, but with a different IP.
I have tried restarting my laptop, router and WD (4 and 40 secs).
Any advice please? in simple terms.
Thanks, D

Your router has probably changed the IP address assigned to your mycloud. Use the new address; delete any old shortcuts and use the new one. You may have to re-map network drives (see p23 of the user manual).

Sonos probably uses DLNA to access media. You may need to check that the Twonky media server is still running, and that it is looking in the right place for media. Go to the Twonky UI:

<IP address>:9000.

The fact that you cannot see named devices, but can see IP addressed devices suggests a problem with DNS.

Because I don’t have more exact details I can only very roughly summarise.

the update to Windows 10 from Windows 7 has broken (I know, quite obvious deduction) some software component on the laptop. The upgrade reversal back to Windows 7 has not reverted what Windows 10 adjusted.

Question. If you have another computer, if you shared at least one directory, could you access this other network share located on another computer?

Can you computer access any network share on another device acting as a server on your local area network? Is the problem on the My Cloud or on your computer. That’s what I’m trying to determine.

Thanks for your reply.
I have deleted my old dashboard shortcut and used a new one. I can see the files on here and am performing a diagnostic test as i speak.
i have re-mapped network drives so that when i click on the folder icon on the laptop these shortcuts are there - unfortunately they are still showing up as “folder is empty”.
I don’t understand the Twonky thing. I ave looked at it and followed the guide, ensuring i have all the relevant folders ticked etc. as shown below.
still not working.

hi.
the issue appears to be access to the wd mycloud. I don’t have another pc in the house, but i can’t access the WD mycloud from my pone or ipad for example - previously i could.

The WD app on the laptop still accesses the pics and music as before (not that i ever used it - i used to just go in through the files).

First thing to do to, as you have access to your filed using the MyCloud application is to make sure you have a copy of your Music, Photos and other wanted files before you do anything else. Once you have a copy of what you want to save then you can continue trying to determine what’s gone wrong.

What you got there is the web UI for the Twonky media server. That’s not what you’re after. This is used by the likes of televisions to stream media from your NAS.

So once i have copied everything what can i do/try next?

Can you access your files through your Phone? What happens when you do?

There seem to be too many variable with the problems you’re experiencing and I’m trying to find it difficult to determine if it’s your computer, if it is the My Cloud NAS or both, so one of the probable problems need to be eliminated.

Do you have a friend with a network of their own? Can you take your My Cloud NAS to their home, connect it to their network and use their computer to access the Web UI and shared files? If yes then it is highly likely it is your computer that is the problem. If no then it’s highly likely that the problem is with the My Cloud NAS.

If it is a problem with the My Cloud NAS and a system restore start-up (keep reset button pressed while powering on NAS and keep the button depressed for a minimum of 40 seconds.) will not cure the problem then if the My Cloud NAS is under warranty, arrange an RMA with Western Digital to have it replaced.

Have you used the services of Western Digital support as maybe the WD support technician can suggest options no-one’s thought of?

While you have access to your files using the My Cloud application on your computer, before you do anything else, take a copy of your data.

Hi. When i go through my phone it shows up the wd my cloud folder then my folfer and public folder etc. But then shows nothing when i click on them - as if nothing is in there.

Thanks, i have sent a support request and am waiting. The fact it won’t work from my phone, ipad or laptop makes me think it’s the wd my cloud/connectivity.

… but your MyCloud apps can actually access the My Cloud NAS. Just can’t see the files. Let’s see what WD Support can do for you.

Thanks for all the help. Managed to resolve it via support - basically there were two folders with the same name and the system was getting "confused " all sorted now though :slight_smile:

You mean two shares with the same name? Out of curiosity and to help everyone else who may read this, can you write-up what you did in detail to get this issue fixed?

Yep, same name, 1 with capital first letter and full of files, 1 without capital or files. Simply deleted the other folder (empty one) via the WD mycloud app to fix it.

Linux does not ignore case in file names. So Temp and temp are two different files or folders.

RAC

Seem to be having some sudden problems with my mycloud device. I can access the drive from my mac - but can’t seem to access the drive from the app on my iPhone. I even removed the drive from the app on the phone, deleted the app and reinstalled everything and started from scratch - its says “connection timed out” before it can even find my drive. I believe i’m on the right network although I have a 2.4 G and 5G network available - any advice from mycloud users? have some crucial photos that need to be backedup soon!

This sort of worked for me, it opened up a new path of investigation!

Windows 10, WDMyCloud 3TB single drive OS2

Everything was fine, I could see it in Network “Neighbourhood” in the computer, Storage, Media sections. When I clicked on the storage icon for WDMyCloud, it opened the browser fine. Media device it opened Twonky, clicking on the icon in the computer section it opened up the drives.

Then I obviously must have done something, but clicking on the Computer section Icon it came back with Error 0x80070035.

Everything was still working fine on the other laptop, so had to be my laptop settings somewhere.

Hunting high and low, altering reg entries as per one forum, switching off all security, playing with settings in “Network & Internet”, reinstalling network adapters, doing this, doing that…

Then came across this thread Windows Forum WDCloud about “Windows Credentials”. Looked in there and on the “Faulty” laptop, there was an entry for WDMyCloud. On the “Working” laptop, there was no such entry.

I edited the faulty one and entered the correct password as the setting had a short password. Tried the connection again - no joy (Error 0x80070035).

Then decided to simply delete the entry. Tried the connection WORKING!!! YEAH HAAAAAAAA!!! Only taken 18 hours to fix it!

I’m posting another answer here, to help other users in the future as this is the page I found, but the current answers didn’t solve the problem.

I had very similar symptoms - I could previously access wdmycloud using Windows file explorer, but on a new Windows10 laptop I could no longer access it. I could use the WD My Cloud application in Windows to access the files, but when I tried to load the drive in file explorer it would just say that the location could not be reached. I could successfully ping the mycloud device both by name and IP address, but connecting by file explorer didn’t work (going to \wdmycloud). I had another Windows 10 laptop on the network that was able to open \wdmycloud in file explorer without any problem.

It turned out the problem was caused by by new Windows 10 laptop being attached to an Azure domain.

To enable access to the device via file explorer I did this:

  • Opened Windows Credential Manager (You can find it in the control panel).
  • Added a new credential with the name of the device as the server (wdmycloud)
  • Most importantly instead of just using my user name (josh) as the user name I had to add the device name and a backslash first: wdmycloud\josh (If you don’t do this, then Windows actually tries to login with your computer’s domain in front of the user name).

As soon as I saved those credentials I was able to access the drive through file explorer.

Hope this helps.