Cannot install WD Sync - fail at sign in mycloud.com account

Did you try downloading the app gain in case the downloaded file was corrupted?

I have downloaded it several times. the problem isn’t with the install app it completes but fail in finding my WD device and in connecting to MyCloud.com. Even the link of forgot password don’t do nothing.

What computer are you using? PC, Mac, etc?
What operating system?
What is the firmware version of your MyCloud?
What is the status of the front panel LED?
Can you access the Dashboard?
Can you access the shares using a file browser?
Do you have a firewall that might be blocking access to the Sync program or to mycloud.com?
Have you set up the MyCloud device, and established a mycloud.com login for your user (you)?

From the instructions above, at step 4, you should see any MyCloud devices on your local network. Do you see any? If not, and you are trying to access a MyCloud on your local network, there is a problem with your local network setup that is preventing access to the device.

The mycloud.com login is an optional step to allow you to connect Sync to any remote MyCloud devices that you may have access to. You do not need to log in to mycloud.com to connect Sync to a local MyCloud device.

The problem is with PC Laptop running Windows 10.
the Firmware of the MyCloud device is 4.4.4
the panel led is blue (there is nothing wrong with the device my android phone and other computers works well even with WD Sync)
I can access the dashboard. I can access the shares using the file browser. I can access myCloud.com and see all files and access them. I even can access WD My Cloud app.
I’m using windows firewall but it isn’t blocking the access. I’m using WD Access app with no problem.
I have setup MyCloud device few month ago and also the tried to setup it again but because I already done it, I can’t complete the process with the same account.

I see the My Device on my local network and can access it.

Okay, that is weird…

You can use other backup/sync programs… Not all support remote sync, though.

I do all my setups via the Dashboard, so don’t have the repeated account problem (you can skip the step).

Sorry, but I am not sure I understood.
What other backup/sync program?

I bought WD mycloud to use WD programs not other programs that I don’t know and I have to pay for them. and I need remote sync all time.

I need a solution not a bypass!

It seem to me that the uninstall did not remove every piece of program or registry and this is the reason it fail on the install process.

I bought 3 My Cloud devices with 6TB each and you tell me I can’t used them?

I tried to install wd sync. It didn’t complete the install because it could not find the My Cloud. My system when it boots up stops several scripts. I then ran WD My Cloud and it couldn’t find any devices. So I started to restart scripts until I could run WD My Cloud and it found my MC. It turns out that for the WD My Cloud. The /etc/rc2.d/S60mDNSResponder script need to be started.

How do I run this script? it seems this is Linux script. my system is windows 10

I should have mentioned that I have a gen1 with firmware 4.xx. That script is in the /etc/rc2.d directory. Not sure how it is run on the gen2 firmware 2.xx.

Sorry, but I really don’t know anything about what you are talking on.

I need a solution for installing WD Sync on my Win 10 Laptop.

Please, Anyone know why I can’t install the WD Sync. When I run WD Sync Setup.exe, It seems as it is installing but actually it do not install anything.

Try installing the WD Sync program as an Administrator. Or change to an administrator account if the current account is not an administrator account.

Or if one doesn’t need to sync remotely dump WD Sync and use a third party program like Free File Sync (http://www.freefilesync.org/).

I have tried to install as Administrator and it the same.

I need remote sync otherwise I will use Windows offline files and it is better then Free File Sync.

Still looking for a solution for WD Sync. It does not install it self even tough it look like it does.

It appears something on your PC is blocking the installation of WD Sync. Try temporarily disabling any third party security software (anti virus, firewall, maleware, etc.) and see if WD Sync will install. I supposed you could try booting Windows 10 into Windows Safe Mode and see if you can install WD Sync from there.

We’re customers, not WD employees. We can suggest things to look at in your local network or computer settings, or the device settings, or offer suggestions for replacements for the (frankly, not brilliant) WD software, but we can’t fix bugs in WD’s programs or firmware.

If you need a solution, rather than a workaround, then it may be time to ask WD Support themselves.

The MyCloud is a Linux box, running various file server, media server and other communications protocols. Sometimes these services stop working, and sometimes users disable them. It is possible to login to the Linux OS and run Linux commands to optimise the behaviour of the device, or to fix problems. This is done using a secure login using the SSH protocol. If none of this makes any sense to you, you are well advised not to attempt it; it requires some reasonable knowledge of Linux and how services run on Linux.

The problem is not with my Mycloud device it works well. I even try to install WD Sync in other local network which I have other mycloud device and I get the same problem. In this local network there are 2 Windows 10 PC the works well with WD Sync. just on my Laptop I can’t install WD Sync.

The problem is with my PC and not with the Device. Something prevent it from install.

Anyway I want to thank you all who tried to help me. I really appropriate your effort.

It helps if useful information like this is provided in the initial query… Yes, it certainly sounds like some problem with Windows or network configuration of the laptop. Can you access the Dashboard from it?

I can access the Dashboard from it. even WD access works with this laptop. only WD SYNC don’t work at all

Can you map network drives to the MyCloud on the laptop?

If you can do this, then there is no network issue, and it is most probably a Windows configuration issue.

Is the laptop running the same vupdate version of Windows 10?

I can map MyCloud on the laptop.
for the Windows 10 version the answer is YES.

I am sure its windows 10 configuration problem. It works before. I uninstall is and now I can’t install it back.

Maybe see this post made by someone else yesterday to another discussion thread. It appears if one’s Windows PC was configured to access an Azure domain it may cause problems trying to access the My Cloud.

https://community.wd.com/t/cant-access-wd-my-cloud/141269/20