Occasionally can't access MyCloud even though WiFi on

I have had no problems for almost a year but in the last month I keep finding I can’t access my My Cloud device. (noticed it first because my music is kept on it and my Sonos system can’t play anything - then, when I try to open it on my laptop it also cannot find it). I switch off and on my router/ network hub/My Cloud device in a generally random way and eventually I get it working, but on another day it can be back to square one. Do you think it could be a problem with my BT router? When I have the problem the WiFi is working but could it have previously dropped off the network for a moment and mess up the connection with the WD My Cloud?

Hello,
Have you tried a direct connection instead of wireless to see how that works out for a while?
Did you recently changed your router or ISP provider?
Have you tried setting a static IP con the drive?

https://support.wdc.com/instructions/?ID=11384&lang=en

Whether you have a PC or mac this can happen; it does not appear in either File Explorer or Finder. You need to learn how to refresh your view of the contents of the Network; there is a refresh “button” in the browser in either that can give you a fresh view of the PC or Mac Network contents.

Hi Mike
I notice the problem in particular when occasionally I am trying to play music from my wireless Sonos music system. That should be able to read the music stored on the hard drive whether the computer is on or not - I can select music it from apps on my phone or ipad. In those instances the app says it cannot access the My Cloud.

Hello

I could see if it makes a difference connecting directly although I don’t think that would not make any difference to the problem I encounter trying to play the music stored on it from my wireless Sonos music system which should work whether the laptop is on or not. (can control it with an app on my phone)

No, same router & provider (BT) they did a check and said the connection was fine!

Have no idea what your final question is! I will follow the link.

Thanks

If the problem is confined to the Sonos system, you may also want to do a subforum search if you haven’t done so already, via the magnifying glass icon upper right, for Sonos. It seems that others with the Sonos system have had various issues with the My Cloud. Perhaps there are suggestions in those threads/discussions that may help with your issue.