Help! Cannot access anything on My Cloud! Nothing works!


#1

OK, let me start from the beginning and give a play-by-play here. I need to retrieve files from My Cloud, as I no longer have access to them elsewhere. Problem is, it stopped working…

  • Suddenly, without warning, I was unable to get a blue light - only solid or flashing white-yellow light
  • I was unable to see the device on my computer
  • I did several soft resets (unplugging, waiting, replugging etc), but that did not work
  • I tried a different network cable, but that did not work either
  • I attached it to a different network. Still didn’t work
  • Attached the network cable directly into a PC - Still nothing
  • I performed several 40-second resets - Finally a blue light!
  • Now I can see the device under Network>Storage.
  • I can also see the device under Network>Media Devices
  • However, the WD app says ‘No supported WD devices found’

- When I click on the device in Network>Storage it brings me to http://192.168.2.237/UI/ which tells me the device has 0KB of data… WHAT!!! Where is all my stuff??

  • I wonder if a firmware update will fix the issue… Yes, an update is available, but I keep getting an error saying there is insufficient space (There is plenty of available space - and if this page is to be believed, the device is empty!), so I cannot perform the update (either from a file or via Internet).
  • I have added back my user account and given full access to both me and the admin account, yet I still see no files
  • I have performed several reboots from the Utilities section of this site, but none has made a difference
  • AT NO POINT HAVE I PERFORMED A FACTORY RESTORE

- When I click on the device in Network>Media Devices it brings me to the Twonky Server page

  • What is this??? How does this differ from the WD page? Will making changes there complicate things?
  • I set up a new Server name, and a new username and password under Advanced settings.
  • I have since removed these settings, as it seemed to be complicating things.
  • What, if anything, should I do on the Twonky Server page?

When I click on WD MyCloud from my PC’s Quick Access menu it shows my private folder, but none of the other public ones that used to be there.

  • When I try to open the private folder, it asks me for my Windows credentials
  • I used the same username and password as I had entered on the Twonky server, but ACCESS DENIED
  • In Control Panel> Network and Internet>Network and Sharing Centre>Advanced Sharing Settings>All Networks I switched password protected sharing OFF, but it is still asking me for my credentials!!
  • I went to the Credential Manager and carefully checked that the credentials under WDMYCLOUD matched what I was entering, yet still I get an ACCESS DENIED alert.
  • I removed the credential from the list completely, yet STILL it prompts me for my credentials when I try to open the folder!

PLEASE HELP ME!!! I have spent hours on this, and I seem to be no closer to being able to access my files! Time is ticking, as I am leaving the country in a few days for 3 months and need to access the files before then.

I hope I have given enough information here for you to understand exactly what I have done, and where I stand now. If you have any suggestions on how to fix this, please give them to me in layman’s terms! I am not used to back-end stuff, so the simpler the better.

Thank you in advance!!
Scott


#2

Have you read through the User Manual for your generation of My Cloud?

To learn more about WD devices visit the Learning Center.
http://learn.mycloud.com/


#3

Do you see the My Cloud icon under Network in Windows File Explorer? The icon should look something like the following:
MyCloudFileServer

If you do not see that icon and are using Windows 10, see the following post for various troubleshooting steps to try as there are several Windows settings that can cause problems with properly seeing the My Cloud on the local network. In particular see Windows 10 Specific Method 1 through Windows 10 Specific Method 5.


#4

A 40-second reset is a factory restore. Basically the equivalent of the Quick Restore option from the UI.

Twonky has NOTHING to do with your devices share credentials. Twonky is a DLNA media server – that’s all. Setting credentials there only limits access to Twonky’s configuration UI.


#5

I did when I set it up. I do not have access to it anymore. I have been
trying to fix it by following others’ forum posts, but nothing is working.
I just hope all the files are still there, as this is my backup device!

http://www.avg.com/email-signature?utm_medium=email&utm_source=link&utm_campaign=sig-email&utm_content=webmail
Virus-free.


http://www.avg.com/email-signature?utm_medium=email&utm_source=link&utm_campaign=sig-email&utm_content=webmail
<#DAB4FAD8-2DD7-40BB-A1B8-4E2AA1F9FDF2>


#6

But it shouldn’t delete data.

The OP should use Windows file explorer, and use the ‘map network drive’, using his MyCloud user credentials for each mapped share.


#7

Exactly. It should keep the data and delete everything else: https://support.wdc.com/knowledgebase/answer.aspx?ID=13986


#8

Are you able to explain what this means, and how I do it?


#9

Read the user manual. Or use Google.

https://www.google.co.uk/search?q=mycloud+map+network+drive


#10

Thanks for this. It’s quite an overwhelming amount of technical info!
I do not see the device under Network>Computer on my Windows 10 PC, so there is obviously some sort of bug there (although it was working just a month ago). I have used a friend’s Windows 7 PC which has a port for a network cable. The Mycloud IS visible under Network>Computer from this PC, both through Wifi and with the network cable attached directly. I can open the Mycloud and see only the private folder named Scott. However, this is as far as I get!
Either hardwired or over Wifi, the private folder will not open, and diagnostics ask me if I have spelled the name of the folder correctly!
I’m getting so frustrated with this… Surely there is something very simple that I need to do and all will be fine, but what??


#11

Thanks for the directions on how to use Google. Invaluable. All you have said is that I should do this but, but have not explained what it is or why I should do it. I have spent the past several days scouring Google and various forum sites looking for answers, and have finally posted here in order to get focused and direct answers to these issues, not just more Google searches and more questions. This forum was not my first stop. It was a last resort.


#12

Did you follow the Google search I posted? It takes you to the WD article on how to map a drive.

Really, read the user manual. It will tell you how to use your device, including how to map drives.


#13

Yeah, that’s where it’s confusing even me – the user manual says that the 40-second reset DOES delete the data. The 4-second doesn’t.

The 4-second is like a System-Only restore, the 40-second is like a Quick Restore (which definitely deletes the data).


#14

According to that Web page, no: .

[image: STOP] Critical:* The following process is Not Data
Destructive and will not impact user data on the device.*


#15

System Only: Changes all settings back to the factory default values, makes private shares public, and returns the administrator password to none. Your content remains untouched and intact. Note: You can also do a system restore physically. See “Resetting the My Cloud Device” on page 90.


#16

Right! That’s what I’m saying! :joy:
4 second is system only, 40 seconds is not. I read above he did several 40 second resets.

Either the docs are wrong or I am. I can live with either. :upside_down_face:


#17

Tony, I think you’re missing the part in bold:
*Your content remains untouched and intact *
So, while all other settings are reset, your content/data/files/whatever
should still be there

http://www.avg.com/email-signature?utm_medium=email&utm_source=link&utm_campaign=sig-email&utm_content=webmail
Virus-free.


http://www.avg.com/email-signature?utm_medium=email&utm_source=link&utm_campaign=sig-email&utm_content=webmail
<#DAB4FAD8-2DD7-40BB-A1B8-4E2AA1F9FDF2>


#18

Resetting with Power Off
At the same time as you plug power into the My Cloud device, press the Reset button and hold for about 40 seconds. The device undergoes a system restore and powers on

You are thinking of a Quick Restore; that can only be issued from the Dashboard.