Cannot access My Cloud after system restore

Went away for a few days and on return could not access my cloud and noticed red light on front. Did a 4 second reset which did not work and then a 40 second system restore which after about 10-20mins we got a blue light.

However we are still unable to access my cloud, cannot get dashboard to open, have used the ip address in the browser but after loading for about 10 seconds it just hangs up with just a WD icon showing on the screen.

We have also tried using a different network cable and router but to no avail. Can see WD My Cloud on network but it will not let me open it.

Should I try another reset or do i need to unistall the WD software on our computer and re-install.

I presume that the 40 second restore is not data destructive so our data should still be on there somewhere.

Help would be appreciated as I am not very tech savvy.

Many thanks

If you are on Windows PC, is this under Computer, Media Devices, or Storage? If under Storage have you tried a right click on it and then click on View device webpage.


Thanks for the reply, when I view the device webpage the twonky page comes up and says, activity status not streaming and rescan content folders in progress.

Nothing has changed in 20 mins but will keep page open to see if anything changes

You’re looking at Media Devices under Network. You need to look at Storage devices.

The MyCloud can be sluggish after a reboot, as it will re-index and thumbnail files, which gobbles CPU.

I have viewed the device web page on the wd my cloud storage device and the page comes up with connecting to my cloud for a few seconds and then just goes to a white blank page with a wd logo in the corner.