MyCloud vanished - HELP


I am new to the forum as I am at my wit’s end.

I rebooted my 4TB MyCloud and it went offline for 24 hours (white LED).

I then did the 40-second reset and got it back to the blue LED but nothing else. Mycloud set up cannot detect it but this is the weird thing, it appears as a working media server for all PC’s but that was it.

I followed the instructions like “SMB 1.0/CIFS File Sharing Support” and Network & Sharing with multiple PC reboots and the same for my router (A Huawai HG659) and Mycloud.

On my main laptop I managed to get WD to appear in storage but it was not accessible.

On another restart, I got MyCloud back as a computer. I even got into the dashboard, managed to register then it times out and became inaccessible.

Yet another full reboot of everything did not help.

I then did another reboot this morning and managed to get MyCloud and the dashboard to appear (Firmware was up to date). I even had folder access. Happy days.

Checked my W10 tablet upstairs after rebooting it and all I had was MyCloud in storage and nothing in My Computers. Went for a shower and came downstairs to find it had vanished yet again.

This has never happened before and I use Avast on my main PC and Kaspersky on my tablet. On my main PC I have added every variation as an exception in Avast includng the IP address too.

I cannot access wdmycloud or the IP address (all I get is a “waiting for MyCloud” and a spinning circle.

Right now I have a working hard drive NAS I can no longer access and cannot rely upon.

What am I doing wrong and as its six years old, it’s well out of warranty. All ideas welcome.

BTW I checked my drivers in device manager and they date from 2013. Online updates did not find anything newer. Surely they cannot be 7-years old!

Is this a 1st or 2nd generation My Cloud, Firmware 04.xx.xx or 02.xx.xx? You haven’t mentioned what the LED’s on the rear of your My Cloud are doing where the Ethernet cable plugs in or what is showing where it plugs into your router?

Has anything changed on your local network? New broadband provider? New router?

Couple of troubleshooting suggestions. Make sure all Windows PC’s have their Network Neighborhood Type set to Private. Disable all security/anti virus programs and see if the issue persists. Try putting a network switch between the My Cloud and the router. Check the router settings to ensure all devices are within the same IP subnet and that those devices connecting via WiFi do not have “client isolation” enabled.

Thanks for replying. It is a first gen and Ethernet lights are working normally. I can not figure how it works flawlessly as a media server but not as a NAS.

Thank you for replying. The router has been the same for several years. I’ll try the trouble shooting again but cannot figure how it is visible and working as a media server but nothing else!

For some strange reason today the shared folders appeared.

BUT… there is still no UI and I have tried the IP address.

In desperation I even tried setup that could not detect the MyCloud despite it appearing under storage and my computer!

I am stumped.

Have you tried (to access the dashboard) or (to access the twonky interface)?

Yes I have the mycloud link and there is no connection whatsoever (circles in browser before timing out). Twonky is fully accessible but only for media files. This is why it’s so weird. How can I have a fully functioning media server, no Nas access for other files while WD set up tells me there’s no Mycloud?