Can't find MyCloud on the network


Last Sunday I bought a new MyCloud 4TB device.

Updated firmware correctly, and saved files in it, everything ok.

Yet when I tried to access it on the morning on the day after - it disappeared from the network!

Entered into my router - and DHCP couldn’t find it while other devices were connected as regular.

I guessed the Device did not “speak” with the router the whole night, so I reconnected the power supply try telling the router “Im here” - then the router did found the cloud and gave it it’s internal IP.

Guys, I don’t want to find myself connecting the power supply on everyday basis, If you call it a cloud - make it act as a cloud.



Since this is your first post please tell us how many times you have had to do this?


If your lights are all on, on your My Cloud, and correct colors, another way to correct this is to unplug the power to your router at the router for about one minute and then plug it back in. It should show your My Cloud on the network after this.


Posted by,
cat0w (USA)


Several users are reporting their cloud disconnect from the network. WD says they are investigating.

Several users also report they solved the issue by assigning a fixed IP address to their NAS, choosing an IP address outside of the DHCP range of the router. It is easier and less risky to assign this fixed IP address from the UI of the router, instead of the UI of the NAS.

1 Like

Ok, now unfortunately I had to do it again…so now it’s the third time i’m doing this.

All lights are ON. The blue LED is ON, and also the input port lights behind both router and MyCloud are green.

I’ll try a fixed IP to see what happens…