Can't see MyCloud drive on my network anymore

Just recently my windows 7 machine doesn’t see my WD drive on the network and can’t seem to get it back. It can be accessed vid the WD MyCloud app but I need to use it to auto backup on the network from some other programs.

I did do a reboot from the WD My Cloud dashboard and that seems to have solved the problem for now. I’ll see how it stands up!

Are you using a fixed IP address for your NAS on your local network? This is better for several reasons. If you don’t, preferably use your router to set up its DHCP server to give your NAS’ MAC address the address of your choice. Then reboot your NAS and test/adjust whatever shortcut/mapped drive you have.

Sorry Etupes, don’t have a clue as to what you are talking about. All I want is to have an external drive as per my old Freecom one that I can back up files to and which worked faultlessly.

The drive has dissapeared again this morning so I’m not getting my backups once again :grumpycat:

 Did you upgrade to version 4 Firmware where that might be the propblem ? 

If Not,  Try turing OFF then back ON the Network Discovery in WIndows 7 Under Netowrk and Sharing. 


Then Open Network in Windows Explorer and then right click and “Refresh”


Then browse to your My Cloud via Windows Explorer. I usually map a Network Drive to each folder I use and this problem has not reappeard.