Can't get to my data!

I’ve been struggling for some time now. I bought a 4T MyCloud really simply to use as an external drive for storing a bunch of saved home movies. It was far too complicated for what I really wanted but I thought I could get it to work. Had it working …sort of, but then one day it disappeared. I tried everything, many reboots, router reboots, computer reboots, new cables, wiring directly to router, directly to a computer etc. etc. Nothing worked. Then it was suggested that I do a reset on the WD MyCloud using a paperclip. I was assured that my data would not be affected. So I proceeded! I did a clean setup with the software and all looked good. BUT, I can’t see the data! I’m not real sure I I am supposed to get to the data…the software is quite strange. I have always just treated it as another drive in “My Computer” (Win 7) and double clicked it and it would open and show my files. I could then easily move things back and forth. But now when I double click it says “This Folder is Empty”…yet it shows 2.36TB free of 3.6 TB. I know the data must be there…but I can’t get to it! Can anyone help?

Hi there,

In order to better assist you could you please provide more details on this issue like, operating system and how you try to access the files form the operating system?

Hey, thanks for getting back to me. Believe me I’m happy to provide any and all details to get this resolved. Clearly I’m a novice at this…just want it simple. I’m not sure why the operating system matters, but,…I use Windows 7, 10, and XP to access the drive. As I said, I really just want an additional drive on the network that I can use to move data around manually…though I would ultimately like to be able to stream movies from it. I don’t need or want (I don’t think) any of the software that comes with the MyCloud. I just want it to show up as a drive, just like plugging in a USB thumb drive on the computer…but show up on the network. I’ve always accessed drives by going to “My Computer” or “This PC” and under “Network” on the left double clicked the drive and it would open and give me access to the files. Simple! I just tried it again on my W10 machine and it opens the “WD MyCloud” software…but that doesn’t give me any access to anything…it provides some info ( Under “Diagnosis” I see the temp is OK, the status is OK, contents is mounted, and I have 67.6% free space) but how do I get to my data? I don’t see a path. Now on my W7 machine I just ran into a new situation…it wants a network username and password What? I don’t even know that. But, if I go to the ip address on any machine it brings up the WD software which has tons of stuff, Users, Shares, Safe points, etc (what do I want with any of that?)…But I don’t see a path to my Data. This used to work. I could bypass all this software by just clicking on the drive…not sure what changed. So, what is the best way to access my data? (assuming it’s still there after my paperclip reset). Thanks.

how did you do the paper clip reset? there are 2 versions

forget Windows 10 for now as it has its own issues with the mycloud, stick with 7 until it works ok then try 10 and see other threads on it.

sign into you router to find the IP address of the mycloud, then in file explorer enter \ipaddress, what do you see?

if you don’t see any shares or files download the WD mycloud desktop app and try it, it has a completely different access method

when you went to the IP address above it sounds like you were in a web browser and got to the control panel.

How did you originally have this setup? user, shares etc

Paperclip method…2 versions?? oops. While it was running with a blue light, stuck the paperclip in and held it in for about 10 seconds and then released. As I recall, the lights changed to white…I gave it some time to come back to blue, and then did a power reboot to be sure it took.

I did try searching through file explorer…a list the same as going to “My Computer” shows up on the left…and sometimes (I’ve done it about 20 times now) just sometimes, the MyCloud is listed under the network and I can get to it just as before and actually add and remove files and actually play a movie. But it only shows up occasionally…maybe 15% of the time…if that.

I did download the WD MyCloud app (I now have WD apps all over the place and I don’t know what’s supposed to do what). When I try to go through the app I can see all the files in some strange format but I can’t seem to do anything with them (can’t open or play, see file size etc.) …not sure what to do with this.

I also have an app?..WD MyCloud public share. When I try to go through this it asks me for my network password…huh? I know I have a Homegroup password, a Wifi password, a computer password…but I don’t know what my “Network Password” is.

I really like the file explorer or my computer method…just what I want. But it rarely is available. I just want it to show up as a normal drive…forget the software! What now?..Thanks.

For your network password, when you set up your router and home network what user name and password did you give it? See example image below.

Click, tap or activate image to enlarge it.

For a search of your My Cloud using Windows 10 I suggest you use This PC>Network>WDMyCloud and use the search box. If you remember the share you placed everything under search for that. See example image below.

Click, tap or activate image to enlarge it.


I would do a system only restore, not the other restores.

this leaves the data and shares and everything else is like new so you need to re-setup user, permissions, remote access etc.

Once it is working I also suggest setting a static IP address.

A system only restore can be performed from a web browser with http://ipaddress/ui or see the manual for details but I believe you shut it down and remove power, press the reset button in and hold it while you connect power and continue to hold it for 40 seconds.

windows ad hock networks don’t always like finding resources by browsing or name, at least for trouble shooting us the IP address

It’s not my WiFi network it wants the login for. Like I said, “WD MyCloud public share” desktop app: When I try to go through this it asks me for my network password…huh? I know I have a Homegroup password, a Wifi password, a computer password…but I don’t know what my “Network Password” is. I’ve never seen this popup before…it’s actually a Windows popup. I tried to do a screenshot but haven’t been able to make it attach.
Actually I finally did get that to work…in spite of it being a windows popup, it took my WD id & password. It was confusing as I’ve tried this so many times now I’ve created numerous passwords with my password generator…I finally figured out one that worked.
But, now all that changed as I did go in and set a fixed ip address…but, that app now won’t work because it is set to a different ip address and I don’t see how to change that in the app. I’m not sure why that would be as the WD would normally get assigned a different ip each time. I guess just delete the app…not sure what it does anyway. That’s kind of the problem…all these “APPS”…all I want to do is get to my data!
I did try your access method through windows 10 (pretty much the same as W7) and I did access my data…once! After doing some reboots though it disappeared and I haven’t been able to get it back.
But, I do have an app on my W7 machine that I downloaded from WD (one of several) that I tried and seems to work (for now anyway) it’s the “WD MyCloud Public” It’s shaped like a file folder. When I click on that I do get to my files and seem to be able to work with them! This is great news…but, I still don’t get it. Why can’t I just see this as a network drive. That’s really all I want. I’d like to buy another but don’t want to go through all this again. I just want network drives to show up on my network (I know it’s there after all) as a drive…just like plugging in a USB drive or sd card…it shows up in your list of drives! I don’t want or even understand all the software…in fact the primary software, the dashboard, doesn’t do a thing that I can see…it shows some info and you maybe even can see some files, but I don’t see anyway to do anything with them. Very frustrating!

the dashboard is for configuration and management, not working with files

as I stated a couple of times do the system only restore

Thanks…the “System only Restore” is tempting…What kind of restore DID I do by just holding down the reset button? Hmmm. At this point though, I’m afraid to do a Restore and start over yet again…After the many hours of trying to get it to work, I’ve got things working…sort of. I set a fixed ip and reserved that address within my router and it seems I can get to my files by using “\WdMyCloud” in Windows Explorer. I just kind of expected to be able to get directly to my files from the ip address…no, it takes me to the dashboard which seems a bit worthless…it gives some minimal info, but you can’t get to anything from there…this seems very strange. Also, from the network map in “My Computer” (7) or “This PC” (10) I can see the MyCloud drive…but again, when I click on it it takes me to the worthless dashboard and not to my files. Any other drive in my networks will go right to the files. This has always been my way to get to my different drives, whether a sd card, usb thumb drive, or external hard drive on the network. I’m not sure why this is different. I’ll have to write down my access path so I won’t forget! Thanks for your help.

Have you tried to mount the My Cloud. Just go into the file explorer and map the drive. From then on you shluld be able to get to the files using the file explorer.


Yes, I think I’ve got it now…thanks… to everyone for their help. I’ve even created desktop shortcuts to get to my files (even my Windows 10!) and it appears all is good. Still bugs me though about the UI…seems strange to go to the ip and just get the UI and no access to the files…seems there would at least be a link to the associated files. Oh well, I can live with this. Thanks!

It is not weird, this is not a http file server. Http is only for management.
To access files it has to be done via SMB/NFS/Apps.

You have to remember you are dealing with a NAS device, most NAS devices are the same way regardless of the vendor/software.

It is weird! I have other external drives (NAS) that take me directly to my files…no software…no problem. But, OK at least I’ve got a roundabout method. Thanks