Can't access share after setting password

I have a share set up on the cloud.
In My Cloud Control Panel:
In USERS:
I select that user name and select that user in Share Access and set it to FULL ACCESS
I set Password to ON
In SHARES:
I select the user on the left and select that share on the right and set FULL ACCESS

When I go to that folder in exlporer on MyCloud and select it I get “[folder] is not accessible. You might not have permission to use this network resource.”

What is going on with this? Why is this not working with the supplied password? I have tried this several times with the same user and the same password.

Even after setting Password to OFF, I still the the prompt and same message ?!!

Been working on this for an hour now

On that Windows computer, have you accessed any Private Shares or have any Private Shares mapped on the My Cloud using a different User and password? If so that might be the problem. Windows generally only allows one to use one set of credentials when accessing the My Cloud (or other NAS devices). You may be able to access the Windows Credentials Manager and remove any My Cloud credentials listed there as well as unmap any mapped Shares and try again. Sometimes one has to reboot the Windows PC after removing the credentials and unmapping the Shares.

Actually the problem was…
I was seeing strange things after deleting the user and share and starting again. I was getting 2 shown even after deleting the first one.
So…I rebooted the My Cloud and the first thing I noticed was the display on the control panel was different on the Home tab. Upgrade? It showed colors and icons for the capacity which i never noticed before. Red for videos , yellow for photos, green for music tracks, and blue for other.
Then after going back to Windows explorer and clicking on the cloud and the share (this was not mapped) it worked!

SHEESH. WDC ever consider putting “REBOOT” instructions in their help docs about shares not allowing logins??

Well I thought i had it figured out but its still doing things that don’t make sense.
I created a new user called “alan” gave it a password and even after a reboot it won’t let me in.
The other one that started working is not prompting for a password even though I have a password set for the user.!!

And, my main login account has a share and I can’t get into that. Even with the password I login to the control panel with.

My gosh can this be anymore confusing?

This is making no sense.

Now the one i have a password on is not prompting for a password. !!!

By the way , why are passwords set on the “User” screen and not set on the “Share” screen. This makes no sense. The share folder is the one that should be password protected right?

I have set up users and passwords on microsoft networks, on web site folders, and even programmed secure key access for websites. This software and the way it works is the most confusing I have ever seen.

Something else stupid it is doing. I go to another computer in the house, login to the new folder “alan” i created with the password and it works. If I try it from the computer I created the user and the password on using the WD Dashboard, it doesn’t work!!! AAAAAAAAHH

None of this makes any sense!!
The one that lets me access it with no password, If I set it to NO ACCESS, it still lets me access it and still doesn’t prompt with a password.

Can someone please direct me to some documentation or a WDC help number I can call to get this taken care of? I am desparately needing to set things up for my home and family and its taking hours.

I now have something even more different occurring while accessing one of the shares. It says "Windows cannot access \MYCLOUD[share] You do not have permission to access…

It doesn’t even prompt for a password!!!

More strangeness
IF I go to mycloud.com I am able to access all shares with no password prompt, but, one share doesn’t even show up. ???

You really should read the My Cloud User Manual (http://support.wdc.com/product.aspx?ID=904) or read the My Cloud Dashboard Help if you haven’t already. Both will explain how to setup and configure various features of the My Cloud.

If you are not being required to enter a password to access the My Cloud Dashboard then make sure to enter a password for the administrator account. The administrator account is generally indicated by a green check mark on the User name in the Dashboard > Users page. Then log out of the My Cloud Dashboard and close ALL instances/open web browser windows. Then open a new browser window and try to access the Dashboard to see if you are now prompted for a password.

If you continue to have strange issues or unexpected behaviors, you can perform a 40 second reset using the reset button on the back of the My Cloud and setup the My Cloud again from scratch.

http://support.wdc.com/KnowledgeBase/answer.aspx?ID=13986

I’m not talking about the dashboard, I’m talking about logging into folders on the mycloud across a home network.
I am always able to login to the dashboard with my password.
One thing I don’t understand about the dashboard is how to change the user login for that.
I have a user name of “al” and want to change it to “alan”, how do I do that?

The help I am accessing in the cloud drive is hard to read because it opens in a small window and you have to scroll constantly to just read a few words it is so mall.

Also, if I go to the home screen it says there are 5 users but if i go to the users tab it only shows 4 users, what’s that all about?

You can change User names including the Administrator account name by accessing the Dashboard > Users page. From there select the User from the left column then change the Username to the desired new user name. Then click the Save button to the right of the Username field.

As to your other issue about not being prompted for a password. Did you see my first post? If you previously logged into a private share on the My Cloud using a different user name you will have trouble trying to access a private share using a second (different) user name. This is a limitation of Windows. See my post above for suggestions on how to resolve that issue (if that is your problem).

Right, that works for changing the user name, didn’t see that.

But as for logging into one and then not being able to login to others, how do you log out of a share once you are logged in? ANd is this even explained in the help?

ALso, this does not explain why, when turning off passwords, it still prompts for passwords. And why passwords are assigned to users and not to shares, which are the things you want to secure.

Or when you have a user with out a password, and then turn password to ON, it doesn’t prompt you.

THere is no rhyme or reason to any of this.

And I defy anyone to find anything in the help or support that explains any of this.

This section explaining that exact thing doesn’t even work:

Generally if you have not “mapped” the Share in Windows File Explorer you generally cannot “log out” of a Share. This is a Windows issue. As explained above Windows generally limits a person to using ONE login for all My Cloud Private Shares. You may be able to find what credentials have been used to access the My Cloud Shares via the Windows Credentials Manager. Do Windows Start > Run then type in “Manage Windows Credentials” to find the credentials manager. Then select Windows Credentials to see if there are any credentials saved for accessing the My Cloud. If so you can remove/delete them. Reboot the computer when finished.

Generally if there are no My Cloud credentials listed in the Windows Credentials Manager a reboot of the computer should clear the login information and (hopefully) you should then be prompted for a user name and password when accessing a Private Share. For Public Shares you do not need to enter in a user name or password. When in doubt double check the My Cloud Dashboard > Shares page and select each Share and ensure Public Access is set to Off if you want the Share set to Private where a user has to enter a username/password to gain access. Also double check that you have at least one User configured for either Full Access or Read Access to that Private Share.

‘Logged in to a folder’? What do you mean?

Do you mean you have mapped a share as a network drive unders Windows? If so, unmap ALL network drives, and re-map them using THE SAME MYCLOUD USER CREDENTIALS for all shares. This is a Windows feature, not the MyCloud’s.

Users/Shares: they’re different; you can have lots of shares, but only one user. So user password is set in the Users tab, and user access to shares in the Shares tab.

As Bennor says, go and read the user manual.

Go and complain to WD, then…

Please do a search on page for “was not mapped”

Thanks for that info.
I do have some set to public and understand those do not need passwords.

The other ones are not mapped, I am just clicking on Computer - Networked and selecting MYCLOUD for the drive.

So you are saying if they are mapped they will log out when closing the windows explorer? If so this would have been great info to get in help also.

I will check the MS Credentials info but this is becoming quite complicated which I would not have expected as the interface does seem like it was made to be easy and for novices, not Windows Life Hackers.

I would have thought this would be as easy as either selecting the USERS and setting permissions for SHARES list on the right,
Or
Selecting SHARES and setting permissions for USERS list on the right.
But it appears I need to investigate the world of MS Credentials and Windows Limitations.

No. I’m saying if they are NOT mapped you cannot “log out” of the Share. If you have mapped a Share you can right click on that mapped Share and select Disconnect to disconnect the Share mapping.

Generally if you have entered in a User and password to access a Share, Windows will sometimes/often times remember that login information and use it automatically the next time you open up a Private unmapped Share using Windows File Explorer. Its why you have to check the Windows Credentials Manager to see what if any credentials are being saved. And if there are My Cloud credentials listed in the Windows Credentials Manager, to remove them, then reboot the PC and try to access the Private Share again.

This all assumes the Share you are trying to access has been configured to Private through the My Cloud Dashboard > Shares page (Public Access = OFF).