WD My Cloud Mirror - Can't access folder of one of the users

I’ve one WD MyCloud Mirror since last year and it would be great if someone could help me with a problem I’m having with it which occurred yesterday.

The situation is the following one:

  1. I am the administrator and have, as well, a “share” of the disk. I haven’t set a password for it
  2. Yesterday, for the first time, when I was trying to acess the disk’s folders through the windows explorer, each time I tried to access my folder I got a request to enter my password. Since I don’t have a password for it I simply didn’t fill the password field and pushed enter. Each time I get a message that the password is wrong.
  3. To make things worse, using the WD My Could app in the desktop, I see that my folder doesn’t show.
    What can I do to solve this and have access to my folder and its files?
    Thank you in advance.

Best regards

You don’t set passwords on the shares (folders) but only on the users for logging into the MCM (and thus identified the MCM knows what you should be able to access by what rights that particular user has been allocated to each share on the NAS).

So when you’re asked for a password, it is asking you to log into the MCM with your username/password. If you’re not putting in valid user/password credentials, then it won’t let you access anything that is non-public.

If your stored credentials on your local machine are wrong or have become corrupted, go to “User Accounts” under control panel, and then select “Manage your credentials” (this is on WIndows 7, but the other versions should be somewhere similar). There you can see and modify stored credential linked to your WIndows log-in.

The log-in credentials for the MCM could be your admin account or any other user account that you have set up on it, depending on your wishes and what you want to access on the mCM.

Hi DarrenHill,
Thank you for your help.
Maybe I did’t explain correctly. The question is related to the user’s password. I haven’t set it (it’s an MCM option to remain with no password) but MCM is now asking for it, preventing access to the share and its folders.
It’s even more strange because in the WD My Cloud desktop app (connected by Wi-Fi) I can’t even see the share of the user, but if I use the iPhone My Cloud app (connected by cellular data), I have no problem in accessing the share and open the folders and files it contains. I’m not sure whether I could/should do a “system restore”. I haven’t fully understood yet whether that keeps all your shares (and what to do to make sure that you can access them afterwards).
Any other thoughts on this would be helpful.

I presume this is your admin share that you are talking about, or is it a general user share?

A few other questions:

  • If you connect to the MCM web interface, can you log into the MCM correctly with the affected account, and see the relevant share correctly via the web file viewer in the dashboard?
  • Can you try resetting the stored credentials on your PC (see my previous post) and then entering your username again and see if access is restored?
  • If you try logging in with a different username and password (presuming you have other users created on the MCM) does that work?

Hi DarrenHill,
Thank you for your reply.
Since my previous post things have changed (for the better, fortunately!), but some issues remain.
I haven’t applied the passwords change you were recommending, because before receiving your reply I had already started a “full test” (an option under “system diagnostics”). It took a long time (all night, in  fact) and next morning I found out that although the report was that it hadn’t found any problems to correct, the connection between my laptops and the affected user’s share had been restored (if done using the Explorer) and I could “see” and modify the folders and files in it, without any issues re the previous problem with the password request.
The remaining issue is now related to the WD My Cloud app (both the desktop version and the iPhone’s one). Something strange is occurring here. In one of my laptops when I use the WD My Cloud desktop app I can “see” the user’s share (the one that had been affected) and all its folders, files, etc.
On a second laptop I’m using, each time I launch the WD My Cloud desktop app, that user is still missing (the public and other users folders are there but not the one that was affected before).
Something similar is happening on my iPhone and iPad. When I try to acess the MCM using the WD My Cloud app through my iPad everything is fine. If I do it through my iPhone, that specific user’s data doesn’t appear. 
Any thought on what you think is happening here and what should be done to correct this situation?
Best regards

I would try uninstalling and reinstalling the apps on the affected Apple kit, and double-check that the user names and passwords are entirely correct (including case). Maybe something has gone out of synch or got itself stuck, and usually a clear-out and reinstall is good to sort that kind of thing out. I don’t personally have any iKit so I can’t comment in detail, but as a general rule the above is a good game-plan to try in such cases.

Glad to hear you’re making progress anyway overall.

Cannot Access MyCloudMirror Share - Access Denied/Invalid Password

This is what worked for me when I had a similar problem:

  1. Create a user and password on your MyCloudMirror that matches your username and password on your computer.
  2. Delete all network connections or mapped drives to your My Cloud
  3. Open the Credential Manager and delete the credential you find for your My Cloud
  4. Restart Your Computer
  5. Create a mapped drive or network connection (whichever you want) to a non-public share on the My Cloud. After that all connections will use those credentials.

Done this way, when you try to access your MyCloudMirror, it will present your credentials from Windows automatically to the MyCloudMirror and, since the username and password are the same as your windows credentials, you will not be prompted again to log in.

In a similar situation it helped me to restart the MCM. My message before was that password for user “nobody” is wrong.

Greetings, Wein-Franke

I’ve established new connections for all the apps (WD My Cloud and WD Photos) on all the devices and it worked! Now everythings seems to be working properly.

Thank you for your help.

Best regards

Thank you. Reestablishing new connections for all devices solved it.

Best regards

I had tried that but it didn’t work. Reestablishing all connections was the solution.

Thank you anyway.

Best regards

Not sure if anyone is still monitoring this thread.

I believe I have figured this out definitely.

The WD My Cloud Mirror’s share permission system is such once you turn off PUBLIC ACCESS switch of a share the way to grant a user access to that share is to do BOTH THE FOLLOWINGS:
(1) Enable the user access for that share.
(2) Enable the user group that user belong to access for that share.

If you only enable one of the above it does not work.

Try it.


This is the solution, thanks! Group policy overrides user policy. When I removed the user from the group he can login to his folders. I wanted to have a group with read-only access to each others folder which did not work.