Can't access MyCloud on my local network

I have just set up a new PC running Windows 11 Home. I can see WDMyCloud on my home network but cannot open it to access my files. (I can access it remotely via the web).
On my other PC which I am running I can see it on the local network and open it easily by right clicking and choosing ‘open’. I do not get that option when I right click on the newly set up PC.
Why is this happening please…

Two things to check because its a new Windows PC.
Make sure SMB1.0 is enabled in Windows. Microsoft typically disables it through patch updates or new Windows installations.

How to Enable SMB 1.0/CIFS File Sharing Support on Windows 10

Also check that the Local Area Network Profile is set to Private and not Public. Not sure if Windows 11 still retains this setting but one should check anyway.

Thanks - done that; but no luck…

I’m having a problem with my 1st generation WDMYCLOUD too. It shows under Network as Media and Storage, but I have to use WD Access if I want to open my shares and see what’s in them. I have Windows 11 Pro and just bought a new router, Linksys AXE6600 MR7500.


Few other things to check. Make sure the My Cloud (in the My Cloud Dashboard > Settings > Network section) has the same “workgroup” name as the Windows 11 computer. If you are using any third party security/firewall software, temporarily disable them as a troubleshooting step to see if they are interfering with local network device access.

Also this video (from July 2021) may have some additional things to check in Windows 11.

Another troubleshooting step. Enable SMB1 in the My Cloud Dashboard > Settings > Network section.

And one person (elsewhere) indicated that one may have to modify the Lanman Workstation setting if it is present in Windows 11.

gpedit → Computer Configuration-> Administrative Templates → Network → Lanman Workstation → Enable insecure guest logon → Enable

Thanks i was trying to solve that and this post help me a lot keep supporting.