Can't access my mycloud drive, blue blinking light

P/N: WDBCTL0040HWT-10. Tried the 4 & 40 second resets, can’t get to the dashboard or access the drive from my PC. I am able to log in via SSH into the linux terminal, but not sure what to do from there to troubleshoot. Any idea or help would be greatly appreciated.

A subforum search (magnifying glass icon to right) yields a number of past discussions on blinking blue LED on OS5:

For the second generation single bay/single drive My Cloud running OS5 one can, at their own risk, try the following two commands via SSH. This assumes one previously enabled SSH within the My Cloud Dashboard.

e2fsck /dev/sda3
reboot -f

Thanks sir!! worked like a champ!

Good to hear it may have fixed your blue blinking light issue.

1 Like

After the last update the Blue led is constantly blinking and I’m having trouble but I can’t login to Mycloud control panel to follow the instructions. I can only see it on the network as mycloud and when I want to connect to the clipboard via IP unfortunately it does not connect. I have been able to connect with both desktop windows 10, macbook pro, ipad pro and iphone for the last 3 years without any problems. but with the latest update the device is not working normally. I made a call to support and followed the instructions but no solution. I did a reset and nothing changed.

Can you access the My Cloud Dashboard?

My Cloud OS 5: How to access the Dashboard

Do you have (or previously had) SSH enabled in the My Cloud Dashboard? If so you can try, at your own risk, using a program like Putty or WinSCP to issue the two Linux commands mentioned in my earlier post above.

1 Like

I can’t access the Dashboard. It seems to show up as WDMYCLOUD on the network. I can’t type IP address and enter it in dashboard login. I am currently trying this method.

first I formatted an empty usb flash drive as fat 32. then I plugged it into the usb memory socket on the mycloud back panel. I plugged in the ethernet cable and then plugged in the power cable. now the yellow and red leds are flashing. so far everything is ok.

I downloaded putty and WinSCP programs on my windows 10 computer. I don’t know how to use which one. I found a video explaining this and I’m watching it, but I think there is something missing somewhere.

I wrote the ipconfig command with the command prompt, but the system still does not see the IP number belonging to mycloud. I know the IP number of Mycloud, but the system does not see this IP in the network.

I still have the connection problem. I’ve read the following solution from a few people, that when the device waits like this for 1 week and 10 days, it returns to normal when the indexing is finished. I guess we have no choice but to wait. Actually, I can do the boot event, but mycloud is not visible on the network, so the dashboard cannot be logged. After plugging in the usb, it flashed red and yellow, but I could not enter commands via telnet or ssh. (putty and WinSCP installed) I’m looking for an article or video that explains all command operations in order.

If using Windows you will need to check if Telnet is installed in the Windows Features section. One may need to restart the computer after installing Telnet.


With Telnet installed on Windows, connect the USB flash drive (formatted for FAT32) to the unpowered second gen single bay My Cloud. Power on the My Cloud and wait for front LED on the My Cloud to blink yellow-red. Then try to connect Telnet to the My Cloud using the My Cloud IP address. If you don’t know the My Cloud’s IP address check the network router’s DHCP server to see what IP address it is handing out to the My Cloud and use that IP address. Example: telnet

If connected to the My Cloud using Telnet, try running the following two commands:

e2fsck /dev/sda3
reboot -f

Edit to add: If one hasn’t tried a 4 second or 40 second reset, they may need to try that. A reset sometimes fixes strange My Cloud issues.

My Cloud OS 5: How to Reset a My Cloud OS 5 Device

Hi Bennor, you seem to be infinitely more knowledgeable than the WD techs. If I didn’t have SSH enabled prior, am I toast? Or is telnet the workaround to that? On a mac I had to install telnet but I still can’t connect to run your commands. Just says connection refused. Any other thoughts, maybe try a different port? I’ve reset the unit a million times, both long and short.

One can try the following that is part of a second generation single bay My Cloud unbrick directions. It will require a USB flash drive and the following file.

1. Use any USB Flash drive, format it to FAT32 (Important!)
2. Unpack usbrecovery.tar.gz to this drive (You will get "boot" folder and 4 files inside)
3. Plug this USB drive to WD MyCloud, turn on power. Wait yellow-red (blinking) light.
4. Connect via Telnet (Search IP in your router, unde DHCP section.)

If one can connect successfully using Telnet then one can try running the code:

e2fsck /dev/sda3
reboot -f

If Telnet or SSH do not work. Another option, if one has a single bay/single drive My Cloud, is to remove the My Cloud hard drive from it’s enclosure and connect it to a computer that is running Linux or is running a Linux boot disc/USB flash drive. One can use a powered USB to SATA adapter or similar to connect that hard drive to the computer. Once connected to the computer running Linux one could then run the ‘e2fsck’ command (adjusted to the correct mount point) previously mentioned up thread on the hard drive to see if it can fix the problem(s) with the drive.

I managed to use telnet & performed e2fsck /dev/sda3 and reboot -f and it rebooted but then nothing happens. What should I do afterwards?

My WD MyCloud Gen2 is not discoverable on the network by any means. Only when I plugged in the motherboard without the HDD, I could see it on the network. Should I do this with the HDD disconnected?