Cannot get to work through Windows

Hi there,

So I have had the drive for a day and have it installed.

I can add files to the drive through the my cloud desktop app and I have the iphone app connected and working.

What I am struggling with is getting access through windows.

When I click on ‘network’ and then ‘wdmycloud’ it brings up the folders but when i try to open i get a network error saying ‘Windows cannot access \wdmycloud\ben’

I also used the tool to map the folders in my computer and the 4 folders show up such as Ben (\wdmycloud) (Z:) but when i click on it i get ‘z:\ is not accessible. Access is denied’.

I have searched the forum and the web and tried tweaking lots of things but to no avail.

I may be doing something completed wrong or it may be my laptop (Asus A52F - Win 7) but if anyone can point me in the right direction I would be very pleased!

Please let me know if you may need any further details.

Thank you


what “tool” are you using to map the shares? for most local usage just use file explorer, not the WD apps

are the shares public? or private? I suspect it is private and you have a conection as public before you tried to connect here. didconect all connections and you may need to clear credentials and reboot. then connect to the private share 1st

WIndows only allows 1 windows user on a PC to connect to a remote computer as 1 user, when you connect to a public share you are set as that user. if you connect to a private share 1st you also have access to the public shares