Unable to access shares in Windows file explorer

I used to use My Cloud with public access, and this worked fine so far. I was able to access it on my Windows 8.1 and Windows 10.

After adding private share, I cannot access the share. When I click, Windows Security dialog pops up for password. I’ve tried my user name and password - WDMYCLOUD{user name} , but that didn’t work.

WD My cloud windows app and iPhone app work fine, though.

I found this and tried, but didn’t help.


There are a couple of ways to access a troublesome private share. In the User Name field try one of the following.

\<user name> (example: “\wdmycloud\johnsmith”)


\<user name> (example: “\\johnsmith”)

Sometimes Windows users have better luck by rebooting their PC’s when they are having trouble with password protected network devices. Also note that Windows (often) has trouble when you attempt to log into a second private share under a second user name when you have already logged into the first private share under the first user name.

Others have had luck with creating User accounts in their WD My Cloud that use the same user name and password as their Windows login user name and password.