Unable to access shares in Windows file manager

Hi

I hope that someone can help as this is driving me mad!

I’ve setup MyCloud following the instructions and all worked fine to start with. I was able to acces shares through Windows (running 8.1) and through my smartphones . I could also play media via DLNA on my Sony TV. The problems started when I tried to share files with a friend.

I setup a user account for my friend but I noticed that all of my shares were set to public so I set the Public Access to Off on the shares that I did not want to be seen. I set up a user account for my fiend and changed the user permissions to full access for my friend on the shares I wanted him to be able to access and also to myself. Since then I have not been able to access these shares through Windows file manager.

When I click on the share a Windows security box pop up asking me to enter my network credentials. I enter the username and password that I setup in MyCloud dashboard but it says that the username / password is incorrect. Basically if Public access is set to onI can access the share but as soon as I set this to off Windows asks me to logon and I’m unable to.

I have also added a USB hard drive which I could access fine initially but also now when I try to connect to the USB devices via windows file manager it asks me for a username / password and this is actually has Public Access set to on. I just dont undertand why I am unable to access files on the attached USB device!

I thought I would try and set it up again from scratch so did quick factory restore but still no joy.

Can somebody tell me what I’m doing wrong!!

This is a screen grab of what I get when I try to access the share:-

p1.JPG

I enther the username and password I I setup but it dos not work and this is what I get:-

p2.JPG

Change your domain.  Put a backslash “” in front of your username.

doesnt let the latest FW fix some windows 8 related stuff with shares?

I’m assuming this post was never solved? I’m getting the same problem…any ideas?

I just purchased My Cloud and I’m having the same issue. I have no clue as to what to enter as username and password when it asks for my credentials. I’m stuck with all shares being set to public. I should also note that this happens with and without the latest firmware upgrade.

Based on this, how does one set up a pubic folder that a group of people can access (ie; my bandmates for charts) without then seeing my private folders?

In addition, I have only myself and my wife listed as users and we can see each others files. She doesn’t need and/or want to see my files. I ran into the above problem went trying to keep our folders (shares) seperate.

In Windows, each user can only use one set of credentials for access shares from the same computer/NAS. So you need to make sure that you don’t have some other credentials stored/used somewhere:

  • shut down any software (sync, backup, security) in which you might have entered some NAS access credentials,

  • unmount any share

  • go to the user and account countrol panel, open the windows credential manager and delete any line related to your My Cloud access,

  • from a command prompt, run net user * /delete That should return that the list was empty

  • restart the computer

  • if your My Cloud is called NICECLOUD on the network, and you have a Fred user, open your NAS in the network explorer and enter:

user: NICELOUD\Fred

password: can be left blank if you didn’t put a password in the My Cloud interface Otherwise enter the corresponding password.

If that doesn’t work, go to the My Cloud interface, do a “System Only” restore (first button the left in the System Factor Restore options, in the Utilities section of the UI). This will leave your share intacts, but will reset your users. Recreate the users/passwords that you want and try again.

***edited spelling

As it turns out, I had the username format wrong. Once entered into the Windows Network credentials box as you described below, everything was fine. I’ve now got my public/private shares set up the way I want and know how to set others up in the future.> Love when things work :slight_smile: Thanks so much! > - if you My Cloud is called NICECLOUD on the network, and you ahve a Fred user, open your NAS in the network explorere and:

user: NICELOUD\Fred

password: can be left blank if you didn’t put a password in the My Cloud interface Otherwise enter the corresponding password.