Cannot connect to private shares on My Cloud NAS using Windows Vista

I cannot connect to private shares created on my WD MyCloud 4TB NAS.from my Windows Vista computer via explorer. I can see my public shares without a problem. I can also see all the shares on my iphone without a problem (except the Smartware share which they recently removed access to). I setup multiple users without passwords and multiple shares with users assigned to their own shares with full access and no password.

I am also able to access the private shares and public shares via the MyCloud interface app on my Vista PC.

I have read many posts about this problem but nothing seems to directly address my issue especially with Windows Vista. The error I get when I tried to access the mapped drive is:

“An error occurred while reconnecting Q: to XXX.XXX.XXX.XXX\private share” (XXX is the IP of the drive and private share is the name of the share).

It proceeds to say
“Microsoft Windows Network: Multiple connections to a server or shared resource by the same user, using more than one user name are not allowed. Disconnect all previous connections to the server or shared resource and try again. The connection as not been restored.”

What is the permanent fix for this for Vista?

The error message indicates the possible problem. If you attempt to access multiple Shares using different User login name’s and passwords Windows (not just Vista) will have problems. Windows generally only allows one to use one User Name to access all password protected My Cloud Shares.

Some have had luck with similar access errors to Private Shares by deleting the relevant Windows Credential entries and rebooting their computer.

So How do I do this? How do I delete the relevant windows Credential entries in Vista?

One option is to use the My Cloud Dashboard to give one user (like the administrator account for the My Cloud) Full Access permission to all Private Shares, then use that User name/login when accessing Private Shares.

The following link gives general direction on how to access the network credentials under Windows Vista.

One way to do it is to unmap all MyCloud share drives under windows. You probably want to reboot as well.

Then map your shares as named drives under windows. But this time, make sure you use the ‘connect as other user’ option, and enter your mycloud user credentials. Tick the re-connect at logon box.
Repeat for each share you want to access/create a nmed drive for.

Note that windows does not let you use more than one set of user credentials to connect to network drives. That’s a windows feature. The problem you have is that connecting to your public drive, which does not need credentials, windows has connected using your windows user credentials. Thus, it won’t let you use your mycloud credentials to connect to a private share that does need your mycloud credentials.

Thanks. I have full access to all of my shares. I tried using user name/login and it did not work. I still see the public shares though.

I followed the link to access network credentials and there are none!

I did “reset” the guest account password. I now need to reboot to see if that helped.

Any other ideas on how to fix this?