Cannot access or ping DL4100, Recent firmware 5.22.133 update

HELP!!! All of a sudden I can no longer access my DL4100.

It does not seem to be assigned an IP address by a DHCP server. I tried two different routers. A few days earlier, the system automatically updated to 5.22.133 firmware. I don’t know that the firmware update has anything to do with it, but I received a system email notifying me of a successful firmware update on 5/19/2022 at 12:06:50. On the morning of the 5/23 my pc had not reconnected with the NAS. This is not uncommon after a sleep period or so with the pc. Usually rebooting the pc addresses this. It did not. I turned the DL4100 off using the power button, then restarted it, several times. No luck. I pulled everything off of the network except one router (no internet conection), my PC and the NAS. I could not get it to accept an IP. (It has been set to use a DHCP server for years!). I noticed that even when “shutdown” the unit was still awake at some level as the ethernet port indicated activity/connection at both the PC and the router. So I shut it down with the power button and unplugged it for several minutes (several times), then powered it up. No IP. I tried looking for it with a network scanner and the mac address with a ARP -a command in my PCs command prompt and not luck finding it. I tried this separately with both ethernet ports.

Can anyone give me guidance on how to recover this??

FYI - I have one 4TB Raid 1 pair and one 8TB Raid 1 pair of drives.

Another piece of information I just thought of. I have my DL4100 on a power schedule. I am pretty sure, this happened after the first scheduled power shutdown and startup since the firmware upgrade

Have you tried the “40 second reset” as documented in the manual?

As to activity when the DL4100 is shutdown, it’s possible to send a Wake-On-Lan packet to the DL4100 to remotely wake it up.


Thanks for your response. I could not find the “40 second reset” you referred to in the user manual I have. (WD My Cloud User Manual . . WD My Cloud DL4100 . . 4779-705140-A00 Feb 2015) Can you please specify exactly which manual you are referring to?



Hmm… Thought it was in the manual. I was wrong.

Information for the 40 second reset and what it does is here …


Thanks! I will try it and let you know how i make out.



Hope your enjoying the Holiday weekend.
I tried the 40 second reset with no luck.
A couple of other indications. There is NO light on the power button. And unfortunately my LCD stopped working a while back when I tried to install some additional RAM. I could not get that to work, and removed it but lost the LCD. This time I had it open I found a ribbon connector latch open. I closed it and there is some backlight, but nothing else, but I cannot remember if the LCD was turned off in the software or not.

In any event, any additional advice will be appreciated. If this ends up being dead. Can I access these drives from another unit. I have a backup, but it is a few weeks old and there are some files I would like to recover if possible.



On this one I’m not sure of what the problem may be. I thought that may be the configuration was corrupt and a full reset would restore this, but it seems like you have a genuine hardware problem and it may simply be coincidence that the NAS has stopped working after the firmware upgrade.

I’m still not 100% sure it is not a firmware issue, but if it is I see no way out of it. I even tried the 40 second reset while pushing the power button. The NAS powers up, all four drives have blue lights, the fan runs, and it seems to reboot itself every so often if I leave it on.

It appears that I will have to get a new NAS. This one was only 4 years old!

The question is:
1 - I have 2 4TB WD Red drives (WD40EFRX-68WT0N0) and 2 8TB WD Red Pro drives (WD8001FFWX-68J1UN0)
2 - Can these drives be used in a WD PR4100 NAS, and assuming they can be used, could they be used without losing the data. I do have a backup, but it is a few weeks old.
3 - How much longer will WD be selling the PR or EX series? It seems like they are starting to get rid of their NAS systems.
4 - Can these drives be used in another NAS like a Synology or QNAP and if so, is there a way to install them without losing data?



By the way, both drive pairs were set up as RAID 1.

Out of curiosity, is the NAS’s PSU healthy? If it’s supplying dirty DC power to the NAS then you will get malfunctions. Not sure how to test this without getting a replacement PSU to a NAS that could be probably dead.

I actually am using redundant power supplies. I have one off of a 1KVA UPS and one off of line power. When I was only using one PS off of the UPS, I would fairly routinely get power alerts and the unit would lock up. It may have happened 1-2 times a week, or less frequently. I do not know why, so I decided to run a 2nd PS directly off utility power and all of these problems went away.

I would expect that unit should automatically switch to which ever power is good, so I do not believe the PS is an issue.

This next bit is advanced. It’s trying to find out the pinouts of the 4 ping on the mainboard to discover which is GNT, TX and RX. Attach a USB 3.3V UART board to it and seeing what is happening during the boot process via a serial terminal. On Microsoft stuff you can use PuTTY.

I’m not 100% sure which one is GND, TX and RX. Plus the pin that is PWR which should never be connected.

I have a few questions.

  1. Which pin is the Power Pin?
  2. Exactly what is the signal? Is this an RS-232 or RS-485 signal with character strings? If it is, I can probably get the hardware I need to evaluate it. I deal with these signals for automation controls. If not, I need to know exactly what I am dealing with. I am not familiar with exactly where to get and connect a USB UART board.

In addition, I spoke to B&H and they said that if the drives were OK I should be able to read them with a drive enclosure, which I bought. They failed to explain that the drives are formatted with EXT4 (linux). I am running Win10 and VirtualBox to run other Windows VMs for various reasons. I seem to be having a problem with my Windows USB driver. When I first connected one of my drives it recognized 3 drive letters, and of course, asked if I wanted to format them, which I did NOT. I have since loaded a Ubuntu VM in Vbox and enabled WSL in windows. I can’t seem to get my system to consistently recognize the disk anymore. I was able to connect one time the Ubuntu in Vbox and it was able to see some Twonky files and I was able to review the drive and see, I believe 4 partitions, 3 noted as EXT4 and one as Microsoft data. Last night I tried installing Ubuntu from the MS store, but it failed.

Can you provide any guidance on how to properly setup software to read a drive? Very often VBox and MS builtin VMs conflict, and in trying to setup I ran into some. I have to run a Vbox VM for work, but can reconfigure to try to read these disks and change back. Any advice would be greatly appreciated.