Cannot Access MyCloud after router change

Had NBN installed, new Optus supplied modem/router replaced Netgear Nighthawk, now the only app that sees the MyCloud is the MyCloud app but it will not connect.

I use DLCP so IP addresses are not an issue.
Network lights on MyCloud, router are OK. Even tried via my Gigabit switch. I use the MyCloud connect app, it seems to see the device but will not connect.

Any help will be appreciated as this is my Movie store.

Are you trying to access a Remote My Cloud or a local network My Cloud?

If local access, can you access the My Cloud Dashboard from a local network computer or device?

Can you access the local network My Cloud using Windows File Explorer or Mac Finder?

Which My Cloud app on which computer or mobile device operating system?

What is the specific error message you are seeing when it fails to connect?

If accessing a remote My Cloud after a router change its possible the My Cloud needs to have remote access turned off, wait a few minutes, then turned back on. In certain instances the ISP may be blocking access to the My Cloud in which case one needs to reconfigure the My Cloud cloud access to manual and set alternative ports (ex: 8080 and 4443) then setup port forwarding to the My Cloud using those ports within the new ISP router.

Thanks for the quick response.
I am using the downloaded MyCloud app on a desktop PC.

The drive is connected directly to one of the router ports, as it was with the previous Nighthawk router, so is connected on a local LAN. I use it for file storage, not really as a cloud device, but not concerned either way. With the previous setup, Nighthawk/pre-NBN it worked first time and I have never had an issues.

When the NBN was installed, a new modem/router was required and that’s when I had all sorts of LAN connection issues. Most disappeared after a few hours but not this one.

The error message is “Failed to connect to this device.” It doesn’t show up in the network map in Netgear Genie.

I am wondering if I need to change the Cat5 to a Cat6 cable. There may be a speed issue, but that, to me, sounds like clutching at straws.

The RJ45 ports on both drive and modem show normal connection and activity lights, so the network part is working, seemingly correctly.

WOW!!! While writing this, I went back to Netgear Genie, found a “phantom/ghosted” drive with an IP address, went to File Explorer, did a Map Network Drive using the IP address and the Public directory and VOILA! it worked. This is the same technique I have tried a dozen times over that past few days with no success. Now it has worked.

Thanks for your help, even if it was just a prod to look again.

Which WD app did you download on your PC?

Note that the Windows WD Desktop program/app/software typically no longer works with the single bay/single drive My Cloud. It has been end of life since 2016.

My Cloud Desktop App No Longer Works with a My Cloud or Login Not Authorized

I just downloaded a WDMyCoud app from the Mycloud site. It doesn’t work I assume because it is for either another device type or for mobile stuff.

Anyway, I don’t need it any more because the network finally connected to my device. All is well.

Thanks for your concern