Changed ISP. Desktop connection works to MyCloud but Mobile does not

Hey Everyone,

I have the 4TB personal MyCloud device. Had it working from my desktop and I have the mobile app on my samsung Note 8 phone. Everything worked great. Then I changed internet service providers, got a new modem with the new company.

I can now only get into MyCloud from my desktop. The mobile app gives me an error ( Network Connection Error 906)

MyCloud device is connected to my modem via ethernet cable. Desktop is on a different floor of the house and connected via wifi. Cell phone connected via wifi as well.

Just not sure why both being on wifi, that it would only work on the one device? Any ideas?

Thanks in advance for any help.

Did you power down the My Cloud before moving it to the new ISP equipment?

Often turning off Cloud Access in the My Cloud Dashboard > Settings section, waiting a few minutes then renenabling Cloud Access will most issues related to unable to access remotely. It is also possible your new ISP is blocking the default ports used by the My Cloud for remote access. If this is the case you may have to set Cloud Access to Manual, change the two port values, then access the router and enable port forwarding to the My Cloud using the two new port values.

When I attempt to sign in to mycloud via web browser it let’s me login then immediately redirects me to another web access login and continues to redirect me everytime.

I dont think I can get to my dashboard.

Do you have a My Cloud or My Cloud Home? They are not the same device and have different features/options. The My Cloud Home does not have the “Dashboard” feature.

If you have a My Cloud device you can access the My Cloud Dashboard (using a web browser) while connected to the same local network as the My Cloud.

I have this one. 4tb my cloud Screenshot_20180926-090912_Samsung%20Internet

I looked at the process you attached to get I to dashboard. My question is how do I k own what the name of my device or its IP address is in order to get to the dashboard?

Okay I managed to get into my dashboard. Now you had said turn cloud access off? Then back on again?

Turned cloud access off. Then back on again. Still wont let me in via my smartphone with the phone on wifi or on data.
It shows me that port forwarding connection is established. 15379734894543728856148536129232

If it is showing that a port forwarding connection is established then you may need to check the network router to ensure the ports specified in the Cloud Access Remote Access Configure setting/option are being forwarded within the router’s port forwarding settings.

If the the Cloud Access Remote Access Configure setting/option is set to Auto is should indicate: Connected (Relay connection established).

Thanks for trying to help but this is beyond the scope of my knowledge or know how. I will just deal with it through desktop from now on.