No access from mobile network MyCloud Ex2

Sorry fo my English

No access from mobile network.
In the local network, everything works properly both from the application and through the browser.

What is done:
mycloud reset (40 sec)
redirected ports to 8080 and 8443 respectively in the cloud and router.
turned off the cloud, then the router and turned on the cloud first, after loading the cloud turned on the router.
Cloud Access deleted all the phones, on the phone removed the connection to the cloud and reinstalled the app
I also tried to log in from my phone through a browser, a security certificate error

After rebooting Connection Status “Connected”
after a couple of minutes switches to “Failed”
error code when entering from the phone 970 or 971
if you try to go into the cloud while the status is Connected, error 905/907
tried with 3 different phones

What else can you advise? Thx

Sounds like an issue with your network. I had a similar issue recently - I got a new DOCSIS 3.1 modem which was duplicating some of the UPNP settings of my router. As soon as I replaced it with the old modem, the problem went away.

Right. The problem was with the network. Now everything works, the correct settings of the router and the cloud in the topic