MyCloud accessible direct thru PC, but no connectivity on router

Hi
I can connect My Cloud to my pc LAN card without hassle, but for a while now it does not connect to the router at all. No LAN activity at the back of the NAS or on the router.

What should i do? Sorry if this is a repeated topic. Im new here.

Thanks!

Hi,

You may try a different LAN cable and/or use a different LAN port of the router for connection.

Hi!
I have the same problem. here is what i’ve observed and tried. i hope somebody here can help.

observations/current situation

  1. after transferring to a new modem/router isp provided, mycloud dashboard and content became inaccessible
  2. mycloud dashboard and content is accessible thru direct connection via ethernet port of laptop
  3. new modem/router is fiberhome modem/router AN5506_04F1A
  4. mycloud is detected on modem lan port.
  5. WD mynet view can detect mycloud when set to static IP and macbinding is on but cannot detect MAC address
  6. WDmynet view unable to detect mycloud when mycloud was set to DHCP
  7. MAC and IP is detected in arp -av but type is invalid
  8. unable to ping mycloud, results to request time out.

what i tried to make mycloud accessible thru new modem

  1. tried setting mycloud to static IP while modem is set to mac binding to mycloud - did not work
  2. mycloud set to dhcp while modem is set to mac binding to mycloud - did not work
  3. set both mycloud and modem to dhcp - did not work
  4. tried 4 second reset then retried items 1-3 - did not work
  5. tried 40 second reset then retried items 1-3 - did not work
  6. tried using different lan port and cable - still did not work
  7. enabled modem uPNP (as suggested by WD mynet view app) - still did not work
  8. reboot modem - still did not work

image
image
image

How is the PC connected to the AN5506_04F1A router? Wireless or wired Ethernet?

What color is the My Cloud front LED when it is connected to the AN5506_04F1A Router?

Can you access the My Cloud Dashboard when the unit is connect to the router?

As a troubleshooting step, have you tried connecting the My Cloud to a network switch first, then connecting that network switch to the router?

Have you checked the router’s administration page to see if there an option called “Client Isolation” and if so have you checked that it’s disabled or set to off?

If the problem is with remote access to the My Cloud, one may have to set the Cloud Access/Remote Access option from auto to manual in the My Cloud Dashboard > Settings. Then set alternate external ports (ex: 8080 and 4443). Then setup port forwarding rules for the new ports within the router’s administration page to point the external ports to the My Cloud.

Try running nmap from one of your devices to scan for mycloud on your LAN:
https://nmap.org/

Thanks @Bennor

  1. Tried both via wireless and wired. Cannot ping amd access wdmycloud on both.
  2. Front LED is steady blue
  3. I cannot access wdmycloud via router
  4. Using a switch, I’ll try this one and give you a feedback. (but i read in a different thread this is not the optimal solution)
  5. Client isolation, i explored my router and did not notice if it had this feature, or maybe i was not looking for it. Will try this also.
  6. Cloud/Remote access is the least of my concerna for now. But thanks for the tip.

Hi @torch1

Will try nmap and give feesback

Hi @Bennor, sorry it took me a while to try the switch setup.

when i try to connect both my laptop and wd mycloud to a switch which is connected to my modem/router, everything is ok. but if i move the laptop to my modem/router my problem comes back again.

for client isolation, it’s either not enabled here, or i do not know how to access it.

@torch1

i thought this nmap thing was simple, this is out of my league. sorry. i was not able to run it.

I hope there is something i can do to make this work? any body?

Well that gives you a starting point for troubleshooting since its working one way, both connected to a switch, but not another My Cloud connected to switch and laptop connected to the router. That would seem to imply some sort of networking problem or misconfigured setting in either the laptop or the router.

How is the laptop being connected to the router? Wired or WiFi?

@Bennor i tried both connecting via wifi and ethernet. i got the same result