Cannot Access Dashboard at http://wdmycloud

I can access the dashboard on two of my three WIN7 PCs. On the third, I get redirected to http://dnsrsearch.com.

However, using the IP address works fine. I use Firefox on all three computers.

If I ping wdmycloud on the working computer, I get the IP address back. On the non-working one I get wdmycloud.belkin [198.105.244.228] and request timeout.

Any clue why this particular PC has a problem? Also, how does PC translate wdmycloud to the IP? Where is the DNS entry?

flush your dns on the PC:

  1. open command prompt

  2. type:  ipconfig /release

  3. type: ipconfig /flushdns

  4. type: ipconfig /renew

1 Like

Thank you for your reply.

I had tried that before and I tried it again. Didn’t work :cry:

However, using the IP address works fine. I use Firefox on all three computers.

if it’s not broke don’t fix it:wink:

how does PC translate wdmycloud to the IP? Where is the DNS entry?

it probably in the hosts or lmhosts file

Pete,

I am using DHCP so I will not always know the IP address. Thus, I would need to access wdmycloud rather than the IP address as I may not always know what it is.

How would the host or Imhost file have any entry for wdmycloud as I have not installed any wdmyclod software? In any case, I checked the host file (I don’t have an lmhost file), and there was no entry for wdmycloud.

viking_erik wrote:

I can access the dashboard on two of my three WIN7 PCs. On the third, I get redirected to http://dnsrsearch.com.

 

However, using the IP address works fine. I use Firefox on all three computers.

 

If I ping wdmycloud on the working computer, I get the IP address back. On the non-working one I get wdmycloud.belkin [198.105.244.228] and request timeout.

 

Any clue why this particular PC has a problem? Also, how does PC translate wdmycloud to the IP? Where is the DNS entry?

Hi viking_erik

Widnows uses netbios to look up hosts. client connecting to Windows uses this protocol to advertise themselves.
(hosts file and lmhosts are used when you are using DNS server). Windows uses Netbios and does not need DNS server (this is how it can find all workgroup members)

This happened to one of my of my children’s PC (Windows 7 but this is applicable to all Windows version)

Do

ipconfig /all

and look at  “Windows IP Configuration”

my output:

Windows IP Configuration

   Host Name . . . . . . . . . . . . : lounge-pc
   Primary Dns Suffix  . . . . . . . :
   Node Type . . . . . . . . . . . . : Hybrid <----- What does this say?
   IP Routing Enabled. . . . . . . . : No
   WINS Proxy Enabled. . . . . . . . : No

There are several things you can do

But I find this the most helpful (barring any other messed up network configurations) ignore the fact it is for XP

http://support.microsoft.com/en-gb/kb/903267/en-us

DON’T use the automatic fix it. Scroll down to let me fix it myself

Follow the instructions.

This helped one of my machines.

1 Like

this is a common issue on Windows home networks and one more reason I strongly suggest using a static IP for all network resources such as NAS drives and printers

this is the easy way out for misconfiguration, dumb devices or badly written apps which do not understand/interact  well with Windows networking work. Do you think an IT admin will go round assigning static IP addresses to every device in his company?

I have 11 devices (2 NASes)  and mixed PCs and Game console. MY PS3 can find the DLNA NAS everytime never failed. and none has an IP static address.

Certain applications which do not interact well with Windows may ask for it. foreign networks needed it (like ftp port forwarding for example where you need to tell the router which machine by IP address since that is what only understands).  Foregin OSes might needed if they don’t understand netbios,canbe configured though like Samba.

Windows can find any PC or device connected to its local network, that is the whole point of Netbios and DHCP. Otherwise administrating devices would be a headache. Misconfiguration can happen though, and static can resolve it if you are not bothered finding out the real problme.

Heck, even my ipad can sync with my wdmycloud without static IP Address for years now.

this is the easy way out for misconfiguration, dumb devices or badly written apps which do not understand/interact  well with Windows networking work.

Agreed.

Do you think an IT admin will go round assigning static IP addresses to every device in his company?

But we’re not talking about an enterprise product.  We’re talking about a product aimed at home or SOHO networks.  Where the task of assigning a single static IP address isn’t exactly onerous.

Yes, in a perfect world, we wouldn’t have to muck about with static IP addresses.

BUT we don’t live in a perfect world…  And assigning a static IP address to the MyCloud is a simple, pragmatic workaround to the problem for a SOHO environment.  It’s a lot less hassle than dealing with the fallout from fully DHCP-allocated addresses, whilst waiting for someone to resolve the problem ‘properly’…

Jamalaya,

Thank you for your response.

Note that I can see WDMYCLOUD under Network in Windows Explorer. It is just that I can’t access the dashboard from a browser (on one PC).

  1. Running ipconfig/all, I see “Hybrid” (like you)

  2. I checked my registry per the article but I didnt have the entries listed:

  • NodeType
  • DhcpNodeType

so there was nothing to delete…

Good, that eliminates a common problem, have your tried to find out what is different on this PC (you said two others work fine).

What is the exact error you get?

timedout error.

Waht about Widnows Explorer? Firefox can be very funny about security.

Fro example it will never allow me to run java 8 as it consider it a threat.

Try deleting all cached info in the browser - browser, options and delete all browsing history.

temporary disable firewalls.

Try this as well (please at everystep keep a reocrd of what you are changing, so you can back to restore).

Make sure that NetBIOS over TCP/IP is enabled:  (mine is the default but enable the check and see if that make a different).

  1. Right-click the network connection and click Properties.
  2. Double-click Internet Protocol (TCP/IP).
  3. Click Advanced.
  4. Click WINS.
  5. Select Enable NetBIOS over TCP/IP.

From my original post:

I get redirected to http://dnsrsearch.com.
 
If I ping wdmycloud on the working computer, I get the IP address back. On the non-working one I get wdmycloud.belkin [198.105.244.228] and request timeout.

I changed the NetBios setting from default to NetBIOS over TCP/IP , but it made no difference (still get

redirected). Note that it is set to default on the working PCs.

I have tried to clear browser cache and history; it didn’t help. I have no firewall on this PC.

I have the same issue on IE as FF.

How do I use Windows Explorer to got to http://wdmyclod? If I try it, it just opens the browser

OK,  I installed firefox to try it and it will not see mycloud

but it will understand this

http://wdmycloud

or this

http://wdmycloud:80

or

http://wdmycloud/UI

all these work.

Try that

I edited my response above as I missed responding to some of your suggestions.

Yes, I have tried (in IE & FF)

http://wdmycloud
or this
http://wdmycloud:80
or
http://wdmycloud/UI

They are all redirected (but only on this PC)

You are still with me :smiley_cat:

You should know that are malicious malware which specialise in redirediretion. Try running antivirus (Full PC scan)  or malware removal  (some free such  malaware byte

In both browsers options/preferences internet connection make sure that it is not trying to use a proxy. There is an option to tick.

no proxy.

I doubt that it is due to malware as this is the only “legit” URL that gets redirected, and it gets redirected to my ISP (Time Warner DNS search). If I type in a nonsense URL (eg http://asdb38u7vcb), that is where I land.

Furthermore, I installed WIN 8.1 a few days ago on this PC (dual-boot with WIN7). I booted up in WIN8.1 to test this on WIN8.1; I have the same issue in WIN8.1 (FF and IE)!! Thus it seems to be hardware related!??

I switched back to WIN7, and changed the DNS server from Automatic to 4.2.2.2. Now http://wdmycloud works!

It is getting weirder, could be router configurations? Just guessing

Just yesterday I installed Windows 8.1 after i crashed Windows 10  :slight_smile:

I always set DNS to my router IP address (automatic actually via DHCP on the router).

Checking the router  which as usual negotiate its conenction with ISP and auto gets actual ISP DNS servers.

All my machines ~windows, Linux and FreeBSD are set to 192.168.0.1 (router as DNS). So could be there misconfigurations.

All least you have a better idea what is going on.

Here is mine.

ipconfig /all

Ethernet adapter Ethernet:

   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Realtek PCIe GBE Family Controller
   Physical Address. . . . . . . . . : E0-3F-49-83-A0-B7
   DHCP Enabled. . . . . . . . . . . : Yes
   Autoconfiguration Enabled . . . . : Yes
   Link-local IPv6 Address . . . . . : fe80::3df6:5bf0:7222:49c4%3(Preferred)
   IPv4 Address. . . . . . . . . . . : 192.168.0.2(Preferred)
   Subnet Mask . . . . . . . . . . . : 255.255.255.0
   Lease Obtained. . . . . . . . . . : 02 April 2015 15:31:20
   Lease Expires . . . . . . . . . . : 03 April 2015 21:41:17
   Default Gateway . . . . . . . . . : 192.168.0.1
   DHCP Server . . . . . . . . . . . : 192.168.0.1
   DHCPv6 IAID . . . . . . . . . . . : 266354505
   DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-1C-AD-75-E4-E0-3F-49-83-A0-B7
   DNS Servers . . . . . . . . . . . : 192.168.0.1
   NetBIOS over Tcpip. . . . . . . . : Enabled

 DNS and gateway always are my router, which should auto negotiate with my ISP modem.

 (maybe reset router and rconfigure?)

I edited my previous post above as I realized that I was not using My ISP’s DNS servers on the “working PC” (even though set to automatic DNS, it was using other DNS servers as I was using a VPN).

In any case, the issue has now been solved: It was the “fault” of my ISP. Here is how it apparently normally works when typing in the URL = http://wdmycloud in the browser:

  1. The URL is checked against the DNS server. If no entry exists then go to step 2

  2. If the local network finds the URL, go there (to wdmycloud dashboard); if not go to step 3

  3. Throw an error page.

That is how it works with most DNS servers. However, with Time Warner (my ISP), they think the users are confused if they type in a URL entry that doesn’t exist on their DNS server, thus:

  1. The URL is checked against the DNS server. If no entry exists then go to their search page ( www.dnsrsearch.com))

– Thus, the PC never have a chance to check the Local Network!

After many conversations with tech support level 1, 2 and 3,  they finally acknowledged the issue and turned off this “feature” on their end.

It now works fine getting the dashboard using http://wdmycloud and using the PC’s automatic DNS setting and thus the ISP’s DNS servers…

Bottom Line: If you try to access http://wdmycloud and get redirected to some search page, contact your ISP; In particular if you have Time Warner. Insist on level 3 tech support and that they turn of this “feature”

1 Like

Glad you solved it.  ISPs eh …

Enjoy.

1 Like