Can not backup to remote WD EX2Ultimate

Hi I’m using two EX2Ultra (#1 Home and #2 Remote), however while trying to backup via the remote connection does not work.
I can reach both devices via “MyCloud” on my smart phone.
I tried with PUTTY to connect to both systems, via the remote IP and that works (SSH)
I tried with a socket connector on all other ports that also works.

They were initially installed in one network, made a backup while in the #1 network.That worked. Nightly backup worked also.
I moved the #2 to a remote location. Both are connected via a public IP address. Both routers are in port forwarding made. And show:

Connection Status
Connected
Port forwarding connection established.

I use the following ports for external: 880 (for HTTP) 843 (for HTTPS); 822 (for SSH) and 873 (for remote)

In the backup when I use the option “MyCloud” I get to see the symbol and shows the ID (Gerxxxxxx96.wd2go.com). Nogo when I ask the destination folder I get the pop up “remote backup” and “please wait”
I tried to use “NAS server” and filled it in: no go, same results. And after some time I get a message:
Remote Backup cannot proceed for an unknown reason.

Remote Backup cannot proceed due to a failed RSYNC Test.

Any ideas how to proceed. I have been fighting for a week now. And feel “stupid”. I must be doing something wrong here.

Thanks in advance, Rob

The RSYNC error comes up due to ports closed on your Internet Router.

Moreover, You can refer the link given to check the configuration steps you are using to establish the remote backup on the EX2 ultra device.

Hi Tech_Wanderer
First of all many thanks for helping me out.I really appreciate it!
I’m afraid I followed the steps and set up the routing on both the Routers on both IP’s in correct formats. That is the strange part.
I can reach also the individual protocols and they work including the remote SSH etc. (using a protocol tester and seeing the actual devices.
E.G. when I conenct to the HTTPS port I get:


SSH is connecting to the Shell.: SSH-2.0-OpenSSH_7.5
HTTP is connecting: I can enter commands and get a web response
Remote is connecting: I see: @RSYNCD: 30.0

All are showing “port forwarding” on both IP location from a 3rd public system.
All steps are verified and setup correctly for the A1 … A5 and the Step B.
However when I try step C1 I get no shares visible in the remote connection.

What can I do to check the connection in the systems?
Is there any logging or tooling in the EX2 (in the Linux part?) that I can use / analyse.

I hope for a next step!

Best regards Rob.

The wd backup tool expects to reach the other device via ssh at port 22, not port 822.

It’s better not to expose the http/s ports. You only need ssh access to open a tunnel.

ssh -L 8080:localhost:80 root@publicIP

The interface is then available when you browse to localhost:8080

Hi Tfl. Also thanks for your remark. I do now understand why it does not work.
This really helps me out! Why oh why is this not in the documentation… or did I miss it?
OK I will investigate the tunnel setup.

Another solution is that I allow “22” only form a source IP to be forwarded. Both sides have a fixed IP address.
I do not care to use the WD App. I understand that that will not be available due to source IP setting.
Then I can test it and see how to proceed.

I’m not ready yet to go into the Linux and create a private VPN tunnel.
I will let you guys know the results!

However this allows me to make progress :slight_smile:

So I guess you followed this guide:

During server (destination) setup, step 5 in A3 shows port 22 forwarded to port 22
https://support.wdc.com/knowledgebase/answer.aspx?ID=11807#stepa3 shows port 22

During client (source) setup, there is no option for a custom ssh port… so the firmware expects port 22.

Finally, for the sake of completeness, if you’d forward SSH to another port (let’s say 8022), you can use rsync with

rsync --rsh 'ssh -p 8022' root@publicIP

Or even better is to add the remote host to the ~/.ssh/config

Host remote
    Hostname publicIP_or_hostname
    Port 8022
    User root

And then simply

rsync remote:
rsync -a remote:/some/path /some/local/path

Hi

You seem to be very expert. I’m not. I’m trying to do the same, using a Mac. I feel like I’ve exactly followed all the steps in How to Create a Remote Backup on a My Cloud Device](https://support.wdc.com/knowledgebase/answer.aspx?ID=11807#stepc1)
My brother-in-law is at the remote location and he’s able to setup a backup to my EX2 Ultra so the basic idea does work. He’s on PC. I’m on Mac.
I get the same messages about ‘unknown SSH’ and ‘RSYNC error’.
Will these terminal commands work on a Mac? And (sorry) but what is port forwarding anyway? And tunnel?
Many thanks
Paul

If he’s able to connect to your device, it means that he’s able to connect from the public internet to the My Cloud device in your personal network. Your router is forwarding port 22 of your device to the public internet.
Now he needs to do the same with his My Cloud device, so that you can connect to it.

You can check his IP address for open ports with https://www.canyouseeme.org/

It might be necessary to setup DynDNS if he doesn’t have a static IP.

Thanks. Have forwarded your answer to him. Will look into obtaining a static IP address (mine seems to change every few months). Paul

You can setup Dynamic DNS in the network tab of the WD UI.

Ah, that’s useful thanks. I’ll probably use no-ip

Paul