Remote Backup Failed RSYNC Test

Purchased 2 WD My Cloud Mirrors, one located at work the other at home; Updated the firmware on both to 2.10.310; Been struggling to get the remote back-up to work; Followed all instructions on the knowledge base; Can anyone more technical then me help?

Done the following:

  1. Both routers support UPnp and this is enabled.
  2. Enabled SSH and Remote server on both devices with a password.
  3. Applied port forwarding rules: TCP 873 for remote server; TCP 22 for SSH.
  4. Under Cloud Access it states “Connected (Relay Connection Established)” rather than “Port Forwarding Connection Established” so I changed the DCHP to Static IP. Cloud access ports changed to 8080 & 8443.
  5. When I setup Remote Backup I use My Cloud Account to locate the remote server successfully which brings in its IP address. When I browse for destination folder I eventually get the following:

Error: Remote Backup cannot proceed for an unknown reason. Remote Backup cannot proceed due to a failed RSYNC Test.

I can see both servers and access files through iPhone/iPad app and My Cloud webpage. Am I missing something here? Any guidance appreciated.

Hi there,

Does the same happen if you try to do the remote backup with your account? There is a drop down that lets you select how to do the remote backup either with its IP or WD account.

Tried both NAS Server and MyCloud account. Both show the same IP address.


A slight issue is the routers at each end are completely different, different models, different ISP. This meant finding the settings to open up the ports was tricky as they are called different things. But I managed to find on each router settings where I could open external & internal ports and added Remote Server 873 and SSH 22 for the server’s IP address.

I also reverted back the Cloud Access ports on the servers to HTTP 80 and HTTSP 443 and added these ports on each router for the server’s IP address as well. The Connection Status changed from “RELAY” to “Port Forwarding connection established.”

When I now set up a remote backup and choose MyCloud account, instead of getting the IP address it shows as a “…” link. I can now see the remote server’s files and the first backup test worked.

Hopes this helps others having similar problems.