Can Not Access Public Folder form my PC


#1

Hi

Help needed, I have had a MYCloud drive for a couple of years, I have just had to reinstall Windows 10 and I can not see the Public Folder. When I go to Share access I can not turn this on as it is greyed out

This is driving me nuts


#2

@MFC1986 Have you gone to the Share folder to see if it is off or on? Turning it off should give you the ability to choose what you want other users to be able to do. See images below. Click on, tap or activate images to enlarge them.

You may want to read the Help information provided in the Dashboard.


#3

So what happens when you try to connect?


#4

@TonyPh12345 Here is what I get if I turn Public off for my 2nd generation My Cloud and do not give myself some type of access.

image

Since I am the only user of my My Cloud, 2nd gen, I take it that if a person does not want a user to be able to see anything in the Public share, they can deny them access. None of my UNs/PWs would work to allow access.

Updated: This only happens if I leave Public off. With Public on, access is available


#5

MFC1986: cat0w is correct… I’d forgotten they changed the behavior for public shares.

You need to make sure that within the SHARE setup, you have the “Public” switch set the way you want.

It appears that you have it ON for the top three shares, which makes them Read/Write for anyone.

Still need to see what happens when you try to connect to Public.


#6

Hi thanks for everyone’s comments, however iv’e solved it, I had to do the following. Strange that i have never had to do this before

Open the Control Panel select Programs and Features then open Turn Windows features on or off
then make sure the following box is checked, SMB 1.0/CIFS File Sharing Support , your computer will have to reboot for it to take affect.


#7

Under SETTINGS / NETWORK, do you by chance have “Max SMB Protocol” set to 1 there?

If you’re using Win 10, it should work with SMB2 or 3. You shouldn’t have to change your PC settings if it’s set to 2 or 3 in the Cloud…