Remote sharing

I recently purchase a 4TB WD MyCloud. I successfully set up a couple Users with the intention for them to have access to files in a common folder named Projects. I made sure Public Access is OFF and that they have full access to the Projects folder. However, when any of the users remotely sign in, the Projects folder is not showing up for them. Could someone please tell me what I am doing wrong, or provide some instructions on what to do.


How have you turned off the actual Public share on your 4Tb WD MyCloud? The options to do that is prohibited on the MyCloud. Exactly model of NAS do do you have?

As to your question, what operating systems are accessing the My Cloud. For people to be able to assist effective you need to provide more detail of what equipment is accessing the MyCloud NAS and what versions of operating systems and if there are any firewalls, what those are? (ZoneAlarm, etc…)

Are you trying to access files using AFP, WebDAV, NFS, SMB, with the WD apps and utilities or a combination of the ones mentioned?

Need more input. :wink:

Go back and turn the projects folder back to Public Access and ask the others to sign in and see if it shows. Reading all the information provided in the Dashboard and the Help (?) info should help in setting up every thing.


While you can’t turn off Public Access to the Public Share you can turn Public Access off to individual shares and give each user read/write, read only or no access. See image below.


Thanks! I turned off/on Public access and verified that it responded to the change. I then followed your image as shown and it’s working fine for me now.
Perhaps the Public access switch was stuck and needed a jolt. Lol!

Much appreciated.

Ah! Right. You didn’t turn off the Public share and make it selective. Strangely, on the higher end NASs WD allows one to make the Public share private. It would be nice if that feature was carried down to lower end NASs.