WDMyCloud unreachable in Windows 10 (Build 2004)

I have just upgraded to Build 2004 of Windows 10 and have wholly lost my ability to view, copy or move any files to and from my MyCloud storage. I am unable to use Windows Explorer, but the MyCloud storage holds my Archives of 3 years work as well as backups of current works and I cannot access them. Does anyone have any suggestions? I bought the storage only 3 years ago Its PART NUMBER IS WDBCTL0080HWT but does not seem to have a Model Number unless it is 2817A.

Can you access the My Cloud Dashboard using a web browser?

Ensure SMB1.0/CIFS is enabled. Microsoft has, in the past, disabled it through patch updates.

How to Enable SMB 1.0/CIFS File Sharing Support on Windows 10 | WD Support
https://support-en.wd.com/app/answers/detail/a_id/4155

Ensure Network Type is set to Private and not Public.

Thank you SMB1.0/CIFS was disabled and is now enabled, but it does not appear to have made any difference. There appears no difference to before and after. BTW I am not that experienced and aged (76) so how do I Ensure the Network Type is set to Private?
Thank you for your suggestion.

One can use their favorite internet search engine to find a number of internet posts detailing how to change Windows 10 Network Type or Network Profile from Public to Private. One such example:

did you reboot everything after you re-enabled SMB1.0 ?

ie. everything includes, your Internet Router, Computer and the WD My Cloud.

changing a network protocol setting would require rebooting the entire network and systems connected to it to reflect the changed setting.

Are you sure you still have SMBv1 on your Windows devices? It may have uninstalled itself…

No I did not reboot everything. It is probably about time I rebooted everything so I will give it a go and hope I can get everything back.
Thank you for your help.

I have now rebooted everything (and wish I had not as a problem has arisen with my Echo Spot and Show 5 devices as a consequence of the reboot), but still no difference to my WDMyCloud. I seem not to be able to view the files in Explorer. It is very frustrating as I cannot access my archives at the moment.

Thank you for that link. I regret it is double dutch to me and I cannot make head nor tail of it. However I had followed the instructions to install SMBv1 and so I have just checked and they are still marked with a ‘tick’, so I hope they are still on!

Yeah. . . .this can be tricky. The MyCloud software doesn’t play as nicely as it should with Windows file explorer.

Do you have a fixed IP on the MyCloud?
Do you have a “name” that you set on the mycloud (Default is something like “MyCloud”. You can put in your own name, like “babyNas” or “Fred”).

First. . . private vs public network. That can make all the difference.
Right click on the wifi icon in taskbar.
Click “Open Network & internet settings”
You can get to this same spot by typing “Network status” in the search bar on the taskbar.
Click “Change connection properties”

Under “Network Profile” Make sure “Private” is checked, not “public”. (Default is public)

To reach the MyCloud;
Open windows file explorer
The MyCloud may or may not appear as a “computer” under network. (Common issue. . doesn’t appear)
Type the IP address, with double forward slashes, of the MyCloud in the address bar. The friendly name should also work.
If you use backslashes, or forget the slashes, your webbrowser will pop open with the device UI being shown.

Hope this helps.

Thank you very much for those suggestions. I have checked and I am Private although connected by LAN and not wifi. I still cannot open MyCloud. It appears in Explorer under Network as an icon of the drive with the name WDMyCloud beside it. I can reach it by using Edge and inserting the IPAddress or double clicking on the Icon, but that is where I stop. If I double click on the icon I get to a page (after clearing security) where I can see the Capacity of the drive, how much is taken up by Movies, Photos, Music & Other and how much is Free. I can change the tabs from Home to Users, Shares, Apps, Clound Access, Backups & Settings. But I cannot see the files. I am totally stumped and bewildered.

NAS_User. Thank you. I tried putting the ipAddress in the Address bar of explorer using backslashes (\ high on left and low on right) and it worked. I could see it in explorer with all the files and dates modified and was able to transfer those that I required in explorer. However it was a double backslash followed by the IPAddress and not a double forward slash (/ bottom left to top right). It worked and I am very grateful to you and the other assistants in saving my bacon. Thank you very much.

This is the way I normally access the device.

And yes. . . 40% of the time I forget which way the slashes go.

Thanks for the backslash tip. Forward slashes cost me much time. Remaining problem: I can now see my folders with their names. But I’m asked for a password on each which I have forgotten. (at least my recorded pw’s don’t work.) There is no prompt for forgotten user pw’s. Anyone know how to retrieve or recreate them for each of the folders?

One can change the user password in the WD my cloud dashboard.

How to access the Dashboard on a My Cloud (single bay) device
https://support-en.wd.com/app/answers/detail/a_id/15104

If one has forgotten their admin password to access the My Cloud dashboard they can reset the amdin password back to default.

How to Reset a My Cloud (single bay) Device
https://support-en.wd.com/app/answers/detail/a_id/24022

This is a function of how Windows 10 utilizes port forwarding on your network. I’m not aware there’s been a solution to this that works in all cases. The best way is to use Advanced IP Scanner to identify the drive and them map it in Windows Explorer.