Can no longer see MyCloud contents via File Explorer/Network

My laptop has just been replaced with another that also runs Windows 10 and therefore I re-installed WD Access. I have had the MyCloud for a few years now, it is not the new personal mycloud that was recently released.

I used to be able to explore the files on MyCloud from File Explorer using WD Access. By exploring the network, I could see everything on my cloud and could delete anything and everything there.
Now I can see music,videos and photos by exploring PC, but I can’t see other file types such as Word documents, and I can’t delete anything from this view.

Is this a consequence of WD Access being changed to accommodate the new product? How can I make WD Access work the way it used to for me?

TIA … Greg

@gvm77

Look at this topic in the WD My Cloud forum.

Thankyou very much for the quick reply. I made the change and restarted the
computer, but unfortunately the symptoms have not changed :frowning: … Greg

I should add that MyCloud was always showing as storage within File
Explorer/Network, but when I double click on it I go to the User Interface
(10.1.1.6), not the data files

Whoops, I had not re-run wd access before testing. All is ok, thankyou so
much, you have made my day! … Greg

Access to MyCloud via File Explorer/Network is proving to be flaky (inconsistent operations). Right now it does not work, I have checked that the SMB 1.0/CIFS File Sharing Support box is still checked and I have ‘run’ ‘WD Access/open’ a couple of times and the functionality has not returned. Any ideas please? TIA … Greg

This fix has been unsatisfactory. I have turned off SMB file sharing support, and from now on will enter \wdmycloud into file explorer address bar instead

Another potential source of grief is the “Homegroup” feature.

See also this post.

so frustrating! Now entering \wdmycloud into file explorer address bar doesn’t work either … apparently the system can’t contact a domain controller to authenticate the request. Why does accessing the cloud have to be so hard?

Hi. I am struggling with this exact same issue. Have been researching web for last 3 days and trying various fixes with no success. Does anyone have a new answer?
I can access via wd apps but cant “explore” in file explorer in win 10. I used to have this access. Cloud icon is not present in storage section. Just see a flat square file icon that wont open. Just sends me to web interface. In media part of file explorer the wd icon is there. This sends me to twonky on web server. So pc knows its there but is unable to read and access the file structure having been able to in the past.
Tried SMB 1.0/CIFS fix. Tried a few other suggestions I found on line.
Any help appreciated. Thx. Tim

Whoops, I had not re-run wd access before testing. All is ok, thankyou so
much, you have made my day! voip phone system

Try typing \\(Local IP of your server)
EX \\192.168.1.211
is mine and that lets me have access in file explorer

What do you mean by “I had not re-run wd access before testing”? I’m having the same issue. I’m only able to get to the web user interface but I want to browse the files in Windows file explorer. Nothing suggested so far works for me. Thanks.

Don’t know if this will help anyone but I spent ages (months) trying to find out why I couldn’t access my My cloud device or only fleetingly.
I had swapped my router due to router failure.
On the original router I’d allocated a fixed IP address. The new router was allocating a different IP address every time router was rebooted and Zone alarm firewall was blocking access.
All resolved when I allocated a fixed IP address and saved My cloud as trusted network in zone firewall.
It was elusive because I kept getting access after doing some things - I can’t remember exactly what, - but next time I looked Mycloud had disappeared from my network in windows explorer. I think zone alarm would not shut off access immediately but had shut it down on my next refresh of file explorer. Wierd.

What do you mean by “I had not re-run wd access before testing”?

WD Access is the program that usually sits in the system tray. I just found it is not there in mine so maybe it doesn’t matter that it is not running. LIke other posters, I find the operation of the Cloud unpredictable … Greg

I have had this issue for several years, now:
Original problem: occasionally dropping off network requiring NAS to be rebooted.

  • Previously: Turned on network discovery and printer sharing (private & public) No change
  • Previously: Enabled NetBios over TCP/IP No change
  • Previously: Turn Windows Features on/off: Enabled SMB 1.0 and sub services No change
  • Previously: Turn off remote access & set static IP in router & in drive
  • 4/26/2020- unplugged cable & replugged it into back of drive- no change
  • 4/26/2020-Swapped cable to GS108 switch and put in different port on switch, no change, rebooted
  • 5/6/2020: turned off sleep mode (WAITING TO SEE IF IT DROPS OUT-didn’t help)
  • 5/21/2020: connected straight to router
    a) Left on and rebooted computer. Still couldn’t see
    b) remove/replace power to NAS 5/21.
    c) on 5/23 had to reboot. Will continue to see if persists
    NEW PROBLEM: 5/25/2020: started only being able to connect to NAS via LAN, WIFI connectivity doesn’t work
  • 5/28/2020: installed latest/last NAS firmware (not listed in auto updates, done manually) - 2.12.127
  • 5/29/2020: Switch NAS to SMB1 (no change)
  • 5/29/2020: switch NAS to SMB3 (no change)

I have not been able to find any solutions for no wi-fi only access. I suspect it is not the router but a PC setting?? My other PC can access the NAS thru mapping but the WD My Cloud Icon only allows dashboard access. (Another problem for another post)

Same issue here, i can see perfeclty my nas in the explorer in another computer but i cant in a new system Im building.

Not a Windows user, but these questions come up so often and the “answers” seem to be a laundry list of things to try. This is MS comment on SMBv1 https://docs.microsoft.com/en-us/windows-server/storage/file-server/troubleshoot/smbv1-not-installed-by-default-in-windows (and why you should not use it :wink: and what to do about the issue not being able to see some device on your network (scroll down to Explorer Network Browsing). Bottom line is that Win10 expects WS-Discovery to find devices. You may be able to customize mDNS Responder (/usr/local/sbin/genMDNSResponderConfig.sh) on MyCloud to generate those broadcasts.